aboutsummaryrefslogtreecommitdiff
path: root/math/blocksolve95
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2015-01-07 22:38:36 +0000
committerThierry Thomas <thierry@FreeBSD.org>2015-01-07 22:38:36 +0000
commit2fb0b6f329c50dbf9aafdf913a28b697b02c9364 (patch)
tree9fd2e9f72c814146fc15d5ebafab532e9b48f37a /math/blocksolve95
parent36444fcac3618ba3b0a9e482b4255367c7fa2502 (diff)
downloadports-2fb0b6f329c50dbf9aafdf913a28b697b02c9364.tar.gz
ports-2fb0b6f329c50dbf9aafdf913a28b697b02c9364.zip
- Use options;
- Do not check the existence of libatlas. Suggested by: bapt
Notes
Notes: svn path=/head/; revision=376503
Diffstat (limited to 'math/blocksolve95')
-rw-r--r--math/blocksolve95/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/math/blocksolve95/Makefile b/math/blocksolve95/Makefile
index 96e6af63a0e5..01c0482db398 100644
--- a/math/blocksolve95/Makefile
+++ b/math/blocksolve95/Makefile
@@ -22,11 +22,17 @@ LIB_DEPENDS= libf2c.so:${PORTSDIR}/lang/f2c \
libmpich.so:${PORTSDIR}/net/mpich2
USES= fortran gmake tar:Z
-.if defined(WITH_ATLAS)
-USES+= blaslapack:atlas
-.else
-USES+= blaslapack
-.endif
+
+OPTIONS_RADIO= BLAS
+OPTIONS_RADIO_BLAS= REFERENCE ATLAS
+OPTIONS_DEFAULT= REFERENCE
+
+REFERENCE_DESC= Blas / Lapack
+REFERENCE_USES= blaslapack:netlib
+
+ATLAS_DESC= ATLAS
+ATLAS_USES= blaslapack:atlas
+
MAKEFILE= makefile
MAKE_ARGS= GMAKE=${MAKE_CMD} PETSC_ARCH=${PETSC_ARCH} BOPT=${BOPT} \
BLAS_LIB="${BLASLIB}" LAPACK_LIB="-L${LOCALBASE}/lib ${LAPACKLIB}"
@@ -40,11 +46,7 @@ FFLAGS+= -O2
INCLUDES= BMmsg.h BSdepend.h BSlog.h BSmy_blas.h BSprivate.h BSsparse.h
PORTDOCS= manual.ps
-.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/lib/libatlas.so) && !defined(WITH_BLAS)
-WITH_ATLAS= yes
-.endif
+.include <bsd.port.options.mk>
do-install:
${INSTALL_DATA} ${WRKSRC}/lib/lib${BOPT}/${PETSC_ARCH}/libBS95.a \
@@ -74,4 +76,4 @@ regression-test: build
${LOCALBASE}/bin/mpdallexit
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>