aboutsummaryrefslogtreecommitdiff
path: root/math/blocksolve95
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2014-08-23 13:52:17 +0000
committerThierry Thomas <thierry@FreeBSD.org>2014-08-23 13:52:17 +0000
commit80933db99d589c736ad41043181f921d0fef7512 (patch)
tree6c9f2ec5c9ebc40a3636da8fbad9e17199a69dc6 /math/blocksolve95
parentd2cddc450bf3c3bcd5c4241f90ae947dafbb2b4d (diff)
downloadports-80933db99d589c736ad41043181f921d0fef7512.tar.gz
ports-80933db99d589c736ad41043181f921d0fef7512.zip
- Fix build
- Stagify - Add a license - Remove $HOME set to $WRKDIR in $MAKE_ENV, this breaks mpd.
Notes
Notes: svn path=/head/; revision=365732
Diffstat (limited to 'math/blocksolve95')
-rw-r--r--math/blocksolve95/Makefile38
-rw-r--r--math/blocksolve95/files/BSman3.inc85
-rw-r--r--math/blocksolve95/files/patch-bmake__freebsd__freebsd12
-rw-r--r--math/blocksolve95/files/patch-bmake__freebsd__freebsd.site6
-rw-r--r--math/blocksolve95/files/patch-examples__makefile22
-rw-r--r--math/blocksolve95/pkg-plist85
6 files changed, 128 insertions, 120 deletions
diff --git a/math/blocksolve95/Makefile b/math/blocksolve95/Makefile
index c2f33c2e7462..50c87851f656 100644
--- a/math/blocksolve95/Makefile
+++ b/math/blocksolve95/Makefile
@@ -3,7 +3,7 @@
PORTNAME= blocksolve95
PORTVERSION= 3.0
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= math parallel
MASTER_SITES= ftp://ftp.mcs.anl.gov/pub/BlockSolve95/ \
http://ftp.mcs.anl.gov/pub/BlockSolve95/
@@ -13,9 +13,13 @@ DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Software for the efficient solution of large, sparse linear systems
-BUILD_DEPENDS= ${MPIDIR}/lib/libmpich.a:${PORTSDIR}/net/mpich2
-LIB_DEPENDS= libf2c.so:${PORTSDIR}/lang/f2c
-RUN_DEPENDS= ${MPIDIR}/bin/mpirun:${PORTSDIR}/net/mpich2
+LICENSE= AS-IS
+LICENSE_NAME= AS-IS
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+LIB_DEPENDS= libf2c.so:${PORTSDIR}/lang/f2c \
+ libmpich.so.2:${PORTSDIR}/net/mpich2
USES= fortran gmake tar:Z
MAKEFILE= makefile
@@ -31,7 +35,6 @@ FFLAGS+= -O2
INCLUDES= BMmsg.h BSdepend.h BSlog.h BSmy_blas.h BSprivate.h BSsparse.h
PORTDOCS= manual.ps
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libatlas.so) && !defined(WITH_BLAS)
@@ -50,15 +53,17 @@ LAPACK_LIB= -L${LOCALBASE}/lib -llapack
do-install:
${INSTALL_DATA} ${WRKSRC}/lib/lib${BOPT}/${PETSC_ARCH}/libBS95.a \
- ${PREFIX}/lib
- ${INSTALL_DATA} ${INCLUDES:S|^|${WRKSRC}/include/|} ${PREFIX}/include
- ${INSTALL_MAN} ${MAN3:S|^|${WRKSRC}/doc/man/man3/|} ${MANPREFIX}/man/man3
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/manual/|} ${DOCSDIR}
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
- @${RM} ${EXAMPLESDIR}/makefile.orig
+ ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_DATA} ${INCLUDES:S|^|${WRKSRC}/include/|} ${STAGEDIR}${PREFIX}/include
+ ${INSTALL_MAN} ${WRKSRC}/doc/man/man3/* ${STAGEDIR}${MANPREFIX}/man/man3
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/manual/|} ${STAGEDIR}${DOCSDIR}
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
+ @${RM} ${STAGEDIR}${EXAMPLESDIR}/makefile.orig
.endif
.if defined(MAINTAINER_MODE)
@@ -69,10 +74,9 @@ regression-test: build
@${ECHO_MSG} "${HOME}/.mpd.conf has been generated - please change the secret word!"
. endif
${LOCALBASE}/bin/mpd &
- @(cd ${BUILD_WRKSRC}/examples; \
- ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} bsrunexamples clean)
+ (cd ${BUILD_WRKSRC}/examples && \
+ ${SETENV} ${MAKE_ENV:C|HOME=|wHOME=|} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} bsrunexamples clean)
${LOCALBASE}/bin/mpdallexit
.endif
-.include "${FILESDIR}/BSman3.inc"
.include <bsd.port.post.mk>
diff --git a/math/blocksolve95/files/BSman3.inc b/math/blocksolve95/files/BSman3.inc
deleted file mode 100644
index 9b260ff076ad..000000000000
--- a/math/blocksolve95/files/BSman3.inc
+++ /dev/null
@@ -1,85 +0,0 @@
-MAN3= BSb_back_solve.3 \
- BSb_backward.3 \
- BSb_for_solve.3 \
- BSb_forward.3 \
- BSback_solve.3 \
- BSback_solve1.3 \
- BSbackward.3 \
- BSbackward1.3 \
- BSbjacobi.3 \
- BScopy_nz.3 \
- BScopy_par_mat.3 \
- BScreate_ctx.3 \
- BSctx_print.3 \
- BSctx_set_cs.3 \
- BSctx_set_ct.3 \
- BSctx_set_err.3 \
- BSctx_set_guess.3 \
- BSctx_set_id.3 \
- BSctx_set_is.3 \
- BSctx_set_max_it.3 \
- BSctx_set_method.3 \
- BSctx_set_np.3 \
- BSctx_set_num_rhs.3 \
- BSctx_set_pr.3 \
- BSctx_set_pre.3 \
- BSctx_set_print_log.3 \
- BSctx_set_ps.3 \
- BSctx_set_restart.3 \
- BSctx_set_rt.3 \
- BSctx_set_scaling.3 \
- BSctx_set_si.3 \
- BSctx_set_tol.3 \
- BSeasy_A.3 \
- BSfactor.3 \
- BSfinalize.3 \
- BSfor_solve.3 \
- BSfor_solve1.3 \
- BSforward.3 \
- BSforward1.3 \
- BSfree_comm.3 \
- BSfree_copy_par_mat.3 \
- BSfree_ctx.3 \
- BSfree_easymat.3 \
- BSfree_off_map.3 \
- BSfree_par_mat.3 \
- BSfree_reperm.3 \
- BSfree_spmat.3 \
- BSfreeg2l.3 \
- BSfreel2g.3 \
- BSget_diag.3 \
- BSglob2loc.3 \
- BSglob2proc.3 \
- BSglobal_flops.3 \
- BSglobal_nnz.3 \
- BSglobal_num_cliques.3 \
- BSglobal_num_inodes.3 \
- BSinit.3 \
- BSinv_diag_block.3 \
- BSloc2glob.3 \
- BSlocal_flops.3 \
- BSlocal_nnz.3 \
- BSlocal_num_cliques.3 \
- BSlocal_num_inodes.3 \
- BSmain_perm.3 \
- BSmain_reperm.3 \
- BSmake_off_map.3 \
- BSmat_subtract.3 \
- BSnum_colors.3 \
- BSoffset.3 \
- BSpar_gmres.3 \
- BSpar_isolve.3 \
- BSpar_solve.3 \
- BSpar_sym_solve.3 \
- BSprint_log.3 \
- BSsave_diag.3 \
- BSscale_diag.3 \
- BSset_diag.3 \
- BSset_diagv.3 \
- BSset_mat_icc_storage.3 \
- BSset_mat_symmetric.3 \
- BSsetup_block.3 \
- BSsetup_factor.3 \
- BSsetup_forward.3 \
- BStri_mult.3 \
- BStri_solve.3
diff --git a/math/blocksolve95/files/patch-bmake__freebsd__freebsd b/math/blocksolve95/files/patch-bmake__freebsd__freebsd
index d3334f6431fc..7fed78efde8d 100644
--- a/math/blocksolve95/files/patch-bmake__freebsd__freebsd
+++ b/math/blocksolve95/files/patch-bmake__freebsd__freebsd
@@ -1,6 +1,6 @@
---- bmake/freebsd/freebsd.orig Tue Jan 9 16:40:08 1996
-+++ bmake/freebsd/freebsd Sun Oct 3 18:12:06 2004
-@@ -1,13 +1,13 @@
+--- bmake/freebsd/freebsd.orig 1996-01-09 16:40:08.000000000 +0100
++++ bmake/freebsd/freebsd 2014-08-23 14:53:31.000000000 +0200
+@@ -1,16 +1,16 @@
-CC = gcc -DPARCH_freebsd
-FC = f77
@@ -18,7 +18,11 @@
+FLINKER = $(FC) $(BASEOPTF)
CONF = -DHAVE_PWD_H -DHAVE_MALLOC_H -DHAVE_STRING_H \
-DHAVE_SWAPPED_BYTES -DHAVE_X11
- SYS_LIB =
+-SYS_LIB =
++SYS_LIB = $(LDFLAGS)
+
+ include $(BS_DIR)/bmake/common
+
@@ -33,13 +33,13 @@
$(RM) $*.o
.F.o:
diff --git a/math/blocksolve95/files/patch-bmake__freebsd__freebsd.site b/math/blocksolve95/files/patch-bmake__freebsd__freebsd.site
index bab70597d456..aba3db98d02d 100644
--- a/math/blocksolve95/files/patch-bmake__freebsd__freebsd.site
+++ b/math/blocksolve95/files/patch-bmake__freebsd__freebsd.site
@@ -20,9 +20,9 @@
-MPI_LIB = /usr/local/mpi/lib/freebsd/ch_p4/libmpi.a
-MPI_INCLUDE = -I/usr/local/mpi/include
-MPIRUN = /usr/local/mpi/bin/mpirun
-+MPI_LIB = $(LOCALBASE)/mpich2/lib/libmpich.a
-+MPI_INCLUDE = -I$(LOCALBASE)/mpich2/include
-+MPIRUN = $(LOCALBASE)/mpich2/bin/mpirun
++MPI_LIB = -lmpich -lmpe -lmpl
++MPI_INCLUDE = -I$(LOCALBASE)/include
++MPIRUN = $(LOCALBASE)/bin/mpirun
#
# Location of BlockSolve95
#
diff --git a/math/blocksolve95/files/patch-examples__makefile b/math/blocksolve95/files/patch-examples__makefile
index fab4c12b501b..ce1ed3b41b53 100644
--- a/math/blocksolve95/files/patch-examples__makefile
+++ b/math/blocksolve95/files/patch-examples__makefile
@@ -1,5 +1,5 @@
---- examples/makefile.orig Thu Oct 17 22:15:08 1996
-+++ examples/makefile Sat Jul 22 16:50:24 2006
+--- examples/makefile.orig 1996-10-17 22:15:08.000000000 +0200
++++ examples/makefile 2014-08-23 15:20:37.000000000 +0200
@@ -19,19 +19,19 @@
$(MPI_LIB) $(FC_LIB) $(SYS_LIB) -lm
LINCLUDE = $(SOURCEH)
@@ -18,17 +18,17 @@
- -@$(MPIRUN) -np 1 grid6.$(PETSC_ARCH) 1 1 1 10 10 10 0 1 3
- -@$(MPIRUN) -np 4 grid7.$(PETSC_ARCH) 2 2 1 8 8 8 0 1 3 1 0.01
- -@$(MPIRUN) -np 4 grid8.$(PETSC_ARCH) 2 2 1 8 8 8 0 1 3 0.01
-+ -@$(MPIRUN) -np 4 ./grid0.$(PETSC_ARCH) 2 2 1 10 10 10
++ -$(MPIRUN) -np 4 ./grid0.$(PETSC_ARCH) 2 2 1 10 10 10
+ #@$(MPIRUN) -np 4 ./grid1.$(PETSC_ARCH) 2 2 1 10 10 10
+ #@$(MPIRUN) -np 4 ./grid2.$(PETSC_ARCH) 2 2 10 10 10
-+ -@$(MPIRUN) -np 4 ./grid3.$(PETSC_ARCH) 10 9
-+ -@$(MPIRUN) -np 4 ./grid4.$(PETSC_ARCH) 2 2 1 10 10 10
-+ -@$(MPIRUN) -np 1 ./grid5.$(PETSC_ARCH) 1 1 1 10 10 10 1 3 1 1 1 1 2
-+ -@$(MPIRUN) -np 1 ./grid5.$(PETSC_ARCH) 1 1 1 10 10 10 0 3 1 0 0 1 2
-+ -@$(MPIRUN) -np 1 ./grid6.$(PETSC_ARCH) 1 1 1 10 10 10 1 1 3
-+ -@$(MPIRUN) -np 1 ./grid6.$(PETSC_ARCH) 1 1 1 10 10 10 0 1 3
-+ -@$(MPIRUN) -np 4 ./grid7.$(PETSC_ARCH) 2 2 1 8 8 8 0 1 3 1 0.01
-+ -@$(MPIRUN) -np 4 ./grid8.$(PETSC_ARCH) 2 2 1 8 8 8 0 1 3 0.01
++ -$(MPIRUN) -np 4 ./grid3.$(PETSC_ARCH) 10 9
++ -$(MPIRUN) -np 4 ./grid4.$(PETSC_ARCH) 2 2 1 10 10 10
++ -$(MPIRUN) -np 1 ./grid5.$(PETSC_ARCH) 1 1 1 10 10 10 1 3 1 1 1 1 2
++ -$(MPIRUN) -np 1 ./grid5.$(PETSC_ARCH) 1 1 1 10 10 10 0 3 1 0 0 1 2
++ -$(MPIRUN) -np 1 ./grid6.$(PETSC_ARCH) 1 1 1 10 10 10 1 1 3
++ -$(MPIRUN) -np 1 ./grid6.$(PETSC_ARCH) 1 1 1 10 10 10 0 1 3
++ -$(MPIRUN) -np 4 ./grid7.$(PETSC_ARCH) 2 2 1 8 8 8 0 1 3 1 0.01
++ -$(MPIRUN) -np 4 ./grid8.$(PETSC_ARCH) 2 2 1 8 8 8 0 1 3 0.01
deletelibs:
diff --git a/math/blocksolve95/pkg-plist b/math/blocksolve95/pkg-plist
index c1f85a8a1b52..111dc2beb8e5 100644
--- a/math/blocksolve95/pkg-plist
+++ b/math/blocksolve95/pkg-plist
@@ -5,6 +5,91 @@ include/BSmy_blas.h
include/BSprivate.h
include/BSsparse.h
lib/libBS95.a
+man/man3/BSb_back_solve.3.gz
+man/man3/BSb_backward.3.gz
+man/man3/BSb_for_solve.3.gz
+man/man3/BSb_forward.3.gz
+man/man3/BSback_solve.3.gz
+man/man3/BSback_solve1.3.gz
+man/man3/BSbackward.3.gz
+man/man3/BSbackward1.3.gz
+man/man3/BSbjacobi.3.gz
+man/man3/BScopy_nz.3.gz
+man/man3/BScopy_par_mat.3.gz
+man/man3/BScreate_ctx.3.gz
+man/man3/BSctx_print.3.gz
+man/man3/BSctx_set_cs.3.gz
+man/man3/BSctx_set_ct.3.gz
+man/man3/BSctx_set_err.3.gz
+man/man3/BSctx_set_guess.3.gz
+man/man3/BSctx_set_id.3.gz
+man/man3/BSctx_set_is.3.gz
+man/man3/BSctx_set_max_it.3.gz
+man/man3/BSctx_set_method.3.gz
+man/man3/BSctx_set_np.3.gz
+man/man3/BSctx_set_num_rhs.3.gz
+man/man3/BSctx_set_pr.3.gz
+man/man3/BSctx_set_pre.3.gz
+man/man3/BSctx_set_print_log.3.gz
+man/man3/BSctx_set_ps.3.gz
+man/man3/BSctx_set_restart.3.gz
+man/man3/BSctx_set_rt.3.gz
+man/man3/BSctx_set_scaling.3.gz
+man/man3/BSctx_set_si.3.gz
+man/man3/BSctx_set_tol.3.gz
+man/man3/BSeasy_A.3.gz
+man/man3/BSfactor.3.gz
+man/man3/BSfinalize.3.gz
+man/man3/BSfor_solve.3.gz
+man/man3/BSfor_solve1.3.gz
+man/man3/BSforward.3.gz
+man/man3/BSforward1.3.gz
+man/man3/BSfree_comm.3.gz
+man/man3/BSfree_copy_par_mat.3.gz
+man/man3/BSfree_ctx.3.gz
+man/man3/BSfree_easymat.3.gz
+man/man3/BSfree_off_map.3.gz
+man/man3/BSfree_par_mat.3.gz
+man/man3/BSfree_reperm.3.gz
+man/man3/BSfree_spmat.3.gz
+man/man3/BSfreeg2l.3.gz
+man/man3/BSfreel2g.3.gz
+man/man3/BSget_diag.3.gz
+man/man3/BSglob2loc.3.gz
+man/man3/BSglob2proc.3.gz
+man/man3/BSglobal_flops.3.gz
+man/man3/BSglobal_nnz.3.gz
+man/man3/BSglobal_num_cliques.3.gz
+man/man3/BSglobal_num_inodes.3.gz
+man/man3/BSinit.3.gz
+man/man3/BSinv_diag_block.3.gz
+man/man3/BSloc2glob.3.gz
+man/man3/BSlocal_flops.3.gz
+man/man3/BSlocal_nnz.3.gz
+man/man3/BSlocal_num_cliques.3.gz
+man/man3/BSlocal_num_inodes.3.gz
+man/man3/BSmain_perm.3.gz
+man/man3/BSmain_reperm.3.gz
+man/man3/BSmake_off_map.3.gz
+man/man3/BSmat_subtract.3.gz
+man/man3/BSnum_colors.3.gz
+man/man3/BSoffset.3.gz
+man/man3/BSpar_gmres.3.gz
+man/man3/BSpar_isolve.3.gz
+man/man3/BSpar_solve.3.gz
+man/man3/BSpar_sym_solve.3.gz
+man/man3/BSprint_log.3.gz
+man/man3/BSsave_diag.3.gz
+man/man3/BSscale_diag.3.gz
+man/man3/BSset_diag.3.gz
+man/man3/BSset_diagv.3.gz
+man/man3/BSset_mat_icc_storage.3.gz
+man/man3/BSset_mat_symmetric.3.gz
+man/man3/BSsetup_block.3.gz
+man/man3/BSsetup_factor.3.gz
+man/man3/BSsetup_forward.3.gz
+man/man3/BStri_mult.3.gz
+man/man3/BStri_solve.3.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README.examples
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/free_grid.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/get_mat.c