aboutsummaryrefslogtreecommitdiff
path: root/math/calc
diff options
context:
space:
mode:
authorJean-Marc Zucconi <jmz@FreeBSD.org>2008-05-13 15:11:55 +0000
committerJean-Marc Zucconi <jmz@FreeBSD.org>2008-05-13 15:11:55 +0000
commit92c3d81314b3648d0bd4c55b9d1f8cc2d8aad72e (patch)
treefffac46e5a5cdb5fb4cd46ef96e00cceaed3d9ee /math/calc
parent132f132008240ce809ea0da19812d8af4fdabcb1 (diff)
downloadports-92c3d81314b3648d0bd4c55b9d1f8cc2d8aad72e.tar.gz
ports-92c3d81314b3648d0bd4c55b9d1f8cc2d8aad72e.zip
Update to 2.12.3.3
PR: ports/123571 Submitted by: leeym
Notes
Notes: svn path=/head/; revision=212995
Diffstat (limited to 'math/calc')
-rw-r--r--math/calc/Makefile9
-rw-r--r--math/calc/distinfo6
-rw-r--r--math/calc/files/patch-Makefile57
-rw-r--r--math/calc/files/patch-alloc.h19
-rw-r--r--math/calc/pkg-plist46
5 files changed, 44 insertions, 93 deletions
diff --git a/math/calc/Makefile b/math/calc/Makefile
index 60ae02f686b6..dad698968dc7 100644
--- a/math/calc/Makefile
+++ b/math/calc/Makefile
@@ -6,14 +6,17 @@
#
PORTNAME= calc
-PORTVERSION= 2.12.1.8
+PORTVERSION= 2.12.3.3
CATEGORIES= math
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= jmz@FreeBSD.org
COMMENT= Arbitrary precision calculator
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
MAN1= calc.1
.include <bsd.port.mk>
diff --git a/math/calc/distinfo b/math/calc/distinfo
index 47b7849c80f0..8d0b756809c2 100644
--- a/math/calc/distinfo
+++ b/math/calc/distinfo
@@ -1,3 +1,3 @@
-MD5 (calc-2.12.1.8.tar.gz) = 163fcec68cf13f750407161b015f787b
-SHA256 (calc-2.12.1.8.tar.gz) = 6fbaeb450103139b8b84416a11b87051e105313bc509b4ad35d86d9d5a6582f1
-SIZE (calc-2.12.1.8.tar.gz) = 1022615
+MD5 (calc-2.12.3.3.tar.bz2) = 2b6b511bba836653a444094622e65041
+SHA256 (calc-2.12.3.3.tar.bz2) = d901319433062c3993b736c59e3552f94d8d29947c96fded6250a6c35ae8ef00
+SIZE (calc-2.12.3.3.tar.bz2) = 865486
diff --git a/math/calc/files/patch-Makefile b/math/calc/files/patch-Makefile
index 5e6d28d47e10..5539d1a453c3 100644
--- a/math/calc/files/patch-Makefile
+++ b/math/calc/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig Wed Feb 7 01:35:20 2007
-+++ Makefile Wed Feb 7 14:54:34 2007
-@@ -571,7 +571,7 @@
+--- Makefile.orig 2008-05-10 08:04:43.000000000 -0700
++++ Makefile 2008-05-10 08:05:39.000000000 -0700
+@@ -585,7 +585,7 @@
#INCDIR= /usr/local/include
#INCDIR= /dev/env/DJDIR/include
@@ -9,7 +9,7 @@
# Where to install calc realted things
#
-@@ -598,15 +598,15 @@
+@@ -612,15 +612,15 @@
#
#BINDIR= /usr/local/bin
#BINDIR= /dev/env/DJDIR/bin
@@ -26,9 +26,9 @@
-CALC_SHAREDIR= /usr/share/calc
+CALC_SHAREDIR= ${PREFIX}/share/calc
- #CALC_INCDIR= /usr/local/include/calc
- #CALC_INCDIR= /dev/env/DJDIR/include/calc
-@@ -680,7 +680,7 @@
+ # NOTE: Do not set CALC_INCDIR to /usr/include or /usr/local/include!!!
+ # Always be sure that the CALC_INCDIR path ends in /calc to avoid
+@@ -698,7 +698,7 @@
#MANDIR=
#MANDIR= /usr/local/man/man1
#MANDIR= /usr/man/man1
@@ -37,46 +37,3 @@
#MANDIR= /dev/env/DJDIR/man/man1
#MANDIR= /usr/man/u_man/man1
#MANDIR= /usr/contrib/man/man1
-@@ -785,13 +785,13 @@
- #
- # If in doubt, set USE_READLINE, READLINE_LIB and READLINE_INCLUDE to nothing.
- #
--USE_READLINE=
--#USE_READLINE= -DUSE_READLINE
-+#USE_READLINE=
-+USE_READLINE= -DUSE_READLINE
- #
--READLINE_LIB=
-+#READLINE_LIB=
- #READLINE_LIB= -lreadline -lhistory -lncurses
- #READLINE_LIB= -L/usr/gnu/lib -lreadline -lhistory -lncurses
--#READLINE_LIB= -L/usr/local/lib -lreadline -lhistory -lncurses
-+READLINE_LIB= -lreadline -lhistory -lncurses
- #
- # For Apple OS X: install fink from http://fink.sourceforge.net
- # and then do a 'fink install readline' and then use:
-@@ -1008,13 +1008,13 @@
- CCOPT= ${DEBUG} ${NO_SHARED}
- CCMISC=
- #
--CFLAGS= -DCALC_SRC ${CCWARN} ${CCOPT} ${CCMISC}
--ICFLAGS= -DCALC_SRC ${CCWARN} ${CCMISC}
-+CFLAGS+= -DCALC_SRC
-+ICFLAGS= -DCALC_SRC
- #
- LDFLAGS= ${NO_SHARED} ${LD_NO_SHARED}
- ILDFLAGS=
- #
--LCC= gcc
-+LCC= cc
- CC= ${PURIFY} ${LCC} ${CCWERR}
- #
- ###
-@@ -1573,6 +1573,7 @@
- TARGETS= ${LICENSE} ${CALC_LIBS} custom/.all calc${EXT} sample/.all \
- cal/.all help/.all help/builtin cscript/.all calc.1 calc.usage
-
-+RM= rm
-
- ###
- #
diff --git a/math/calc/files/patch-alloc.h b/math/calc/files/patch-alloc.h
index d56bc3dd0b34..e69de29bb2d1 100644
--- a/math/calc/files/patch-alloc.h
+++ b/math/calc/files/patch-alloc.h
@@ -1,19 +0,0 @@
-*** alloc.h~ Thu Mar 31 03:05:41 1994
---- alloc.h Sun Apr 16 17:27:55 1995
-***************
-*** 10,16 ****
-
- #include "have_malloc.h"
- #ifdef HAVE_MALLOC_H
-! # include <malloc.h>
- #else
- # if defined(__STDC__)
- extern void *malloc();
---- 10,16 ----
-
- #include "have_malloc.h"
- #ifdef HAVE_MALLOC_H
-! /* # include <malloc.h> */
- #else
- # if defined(__STDC__)
- extern void *malloc();
diff --git a/math/calc/pkg-plist b/math/calc/pkg-plist
index 64ce63770d2c..544525ceb9f6 100644
--- a/math/calc/pkg-plist
+++ b/math/calc/pkg-plist
@@ -19,6 +19,7 @@ include/calc/cmath.h
include/calc/conf.h
include/calc/config.h
include/calc/custom.h
+include/calc/decl.h
include/calc/endian_calc.h
include/calc/file.h
include/calc/fposval.h
@@ -31,7 +32,6 @@ include/calc/have_getpgid.h
include/calc/have_getprid.h
include/calc/have_getsid.h
include/calc/have_gettime.h
-include/calc/have_malloc.h
include/calc/have_memmv.h
include/calc/have_newstr.h
include/calc/have_offscl.h
@@ -49,26 +49,32 @@ include/calc/have_ustat.h
include/calc/hist.h
include/calc/jump.h
include/calc/label.h
+include/calc/lib_calc.h
include/calc/lib_util.h
include/calc/longbits.h
-include/calc/math_error.h
-include/calc/md5.h
include/calc/nametype.h
include/calc/opcodes.h
include/calc/prime.h
include/calc/qmath.h
-include/calc/shs.h
-include/calc/shs1.h
-include/calc/string.h
+include/calc/sha1.h
+include/calc/str.h
include/calc/symbol.h
include/calc/terminal.h
include/calc/token.h
include/calc/value.h
-include/calc/win32dll.h
include/calc/zmath.h
include/calc/zrand.h
include/calc/zrandom.h
-lib/libcalc.a
+lib/libcalc.so
+lib/libcalc.so.2
+lib/libcalc.so.2.12
+lib/libcalc.so.2.12.3
+lib/libcalc.so.2.12.3.3
+lib/libcustcalc.so
+lib/libcustcalc.so.2
+lib/libcustcalc.so.2.12
+lib/libcustcalc.so.2.12.3
+lib/libcustcalc.so.2.12.3.3
%%DATADIR%%/README
%%DATADIR%%/alg_config.cal
%%DATADIR%%/beer.cal
@@ -82,12 +88,13 @@ lib/libcalc.a
%%DATADIR%%/custhelp/help
%%DATADIR%%/custhelp/pmodm127
%%DATADIR%%/custhelp/pzasusb8
+%%DATADIR%%/custhelp/register
%%DATADIR%%/custhelp/sysinfo
%%DATADIR%%/custom/argv.cal
%%DATADIR%%/custom/halflen.cal
-%%DATADIR%%/custom/libcustcalc.a
%%DATADIR%%/custom/pmodm127.cal
%%DATADIR%%/custom/pzasusb8.cal
+%%DATADIR%%/custom/register.cal
%%DATADIR%%/deg.cal
%%DATADIR%%/dotest.cal
%%DATADIR%%/ellip.cal
@@ -137,6 +144,7 @@ lib/libcalc.a
%%DATADIR%%/help/builtin
%%DATADIR%%/help/calc_tty
%%DATADIR%%/help/calclevel
+%%DATADIR%%/help/calcpath
%%DATADIR%%/help/catalan
%%DATADIR%%/help/ceil
%%DATADIR%%/help/cfappr
@@ -156,6 +164,7 @@ lib/libcalc.a
%%DATADIR%%/help/cot
%%DATADIR%%/help/coth
%%DATADIR%%/help/count
+%%DATADIR%%/help/cp
%%DATADIR%%/help/credit
%%DATADIR%%/help/csc
%%DATADIR%%/help/csch
@@ -299,7 +308,6 @@ lib/libcalc.a
%%DATADIR%%/help/mattrace
%%DATADIR%%/help/mattrans
%%DATADIR%%/help/max
-%%DATADIR%%/help/md5
%%DATADIR%%/help/memsize
%%DATADIR%%/help/meq
%%DATADIR%%/help/min
@@ -377,7 +385,6 @@ lib/libcalc.a
%%DATADIR%%/help/segment
%%DATADIR%%/help/select
%%DATADIR%%/help/sgn
-%%DATADIR%%/help/sha
%%DATADIR%%/help/sha1
%%DATADIR%%/help/sin
%%DATADIR%%/help/sinh
@@ -390,6 +397,7 @@ lib/libcalc.a
%%DATADIR%%/help/srandom
%%DATADIR%%/help/ssq
%%DATADIR%%/help/statement
+%%DATADIR%%/help/stoponerror
%%DATADIR%%/help/str
%%DATADIR%%/help/strcat
%%DATADIR%%/help/strcmp
@@ -475,10 +483,12 @@ lib/libcalc.a
%%DATADIR%%/unitfrac.cal
%%DATADIR%%/varargs.cal
%%DATADIR%%/xx_print.cal
-@dirrm %%DATADIR%%/help
-@dirrm %%DATADIR%%/custom
-@dirrm %%DATADIR%%/custhelp
-@dirrm %%DATADIR%%
-@dirrm include/calc/custom
-@dirrm include/calc
-@dirrm bin/cscript
+@dirrmtry share/man/man1
+@dirrmtry share/man
+@dirrmtry %%DATADIR%%/help
+@dirrmtry %%DATADIR%%/custom
+@dirrmtry %%DATADIR%%/custhelp
+@dirrmtry %%DATADIR%%
+@dirrmtry include/calc/custom
+@dirrmtry include/calc
+@dirrmtry bin/cscript