aboutsummaryrefslogtreecommitdiff
path: root/math/calcoo
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-01-19 16:26:01 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-01-19 16:26:01 +0000
commite90c4b51fa45458d4fb94159bd60dacc765092d7 (patch)
tree49d9c3ab8790aa49615b0ae7c625b90f75a5653b /math/calcoo
parent55bb75388c538dcf7d45cb3e9892c48e99570895 (diff)
downloadports-e90c4b51fa45458d4fb94159bd60dacc765092d7.tar.gz
ports-e90c4b51fa45458d4fb94159bd60dacc765092d7.zip
Calcoo is a Gtk-based scientific calculator designed to provide maximum
usability.
Notes
Notes: svn path=/head/; revision=53344
Diffstat (limited to 'math/calcoo')
-rw-r--r--math/calcoo/Makefile21
-rw-r--r--math/calcoo/distinfo1
-rw-r--r--math/calcoo/files/patch-src::c_main.c13
-rw-r--r--math/calcoo/pkg-comment1
-rw-r--r--math/calcoo/pkg-descr17
-rw-r--r--math/calcoo/pkg-plist2
6 files changed, 55 insertions, 0 deletions
diff --git a/math/calcoo/Makefile b/math/calcoo/Makefile
new file mode 100644
index 000000000000..1da78c64b248
--- /dev/null
+++ b/math/calcoo/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: calcoo
+# Date created: 2002-01-17
+# Whom: Christian Weisgerber <naddy@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= calcoo
+PORTVERSION= 1.3.4
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www.physics.umn.edu/~kaminski/calcoo/
+MASTER_SITE_SUBDIR= calcoo
+
+MAINTAINER= naddy@FreeBSD.org
+
+USE_GTK= yes
+GNU_CONFIGURE= yes
+
+MAN1= calcoo.1
+
+.include <bsd.port.mk>
diff --git a/math/calcoo/distinfo b/math/calcoo/distinfo
new file mode 100644
index 000000000000..8ee2975c88f1
--- /dev/null
+++ b/math/calcoo/distinfo
@@ -0,0 +1 @@
+MD5 (calcoo-1.3.4.tar.gz) = 968a4b9394951811a113f33c2c9d5f75
diff --git a/math/calcoo/files/patch-src::c_main.c b/math/calcoo/files/patch-src::c_main.c
new file mode 100644
index 000000000000..fea1f6a0a94f
--- /dev/null
+++ b/math/calcoo/files/patch-src::c_main.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- src/c_main.c.orig Wed Dec 12 17:18:06 2001
++++ src/c_main.c Fri Jan 18 22:40:01 2002
+@@ -59,6 +59,7 @@
+ reset_registers();
+ cpu->prescribed_format = DEFAULT_DISPLAY_FORMAT;
+ cpu->angle_measure = DEFAULT_ANGLE_MEASURE;
++ cpu->curr_mem = 0;
+ /* slightly underestimated precision
+ * it is going to be used in evaluation of
+ * trigonometric functions to get sin PI = 0 rather than 10^-17 */
diff --git a/math/calcoo/pkg-comment b/math/calcoo/pkg-comment
new file mode 100644
index 000000000000..332258d71fa6
--- /dev/null
+++ b/math/calcoo/pkg-comment
@@ -0,0 +1 @@
+Gtk-based scientific calculator
diff --git a/math/calcoo/pkg-descr b/math/calcoo/pkg-descr
new file mode 100644
index 000000000000..d4bd7c5a765e
--- /dev/null
+++ b/math/calcoo/pkg-descr
@@ -0,0 +1,17 @@
+Calcoo is a scientific calculator designed to provide maximum
+usability. The features that make Calcoo better than (at least some)
+other calculator programs are:
+
+* Bitmapped button labels and display digits to improve readability.
+* No double-function buttons.
+* Undo/redo buttons.
+* Copy/pase interaction with X clipboard.
+* Both RPN (reverse Polish notation) and "standard" modes are available.
+* Tick marks to separate thousands.
+
+Below are the features that Calcoo lacks (but which are useless anyway):
+
+* Statistical mode.
+* HEX mode.
+
+WWW: http://calcoo.sourceforge.net/
diff --git a/math/calcoo/pkg-plist b/math/calcoo/pkg-plist
new file mode 100644
index 000000000000..0039aa7ff225
--- /dev/null
+++ b/math/calcoo/pkg-plist
@@ -0,0 +1,2 @@
+@comment $FreeBSD$
+bin/calcoo