aboutsummaryrefslogtreecommitdiff
path: root/math/cantor/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-02-03 20:10:37 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-02-03 20:10:37 +0000
commitcb8b1428c6bb9ed135f61a9cecbe8397defbf329 (patch)
tree0a68a09c88303888985b47f7045bed36788aefc2 /math/cantor/Makefile
parent563bcaab10c891e4bee07c4ec1fbf46515c5a0b4 (diff)
downloadports-cb8b1428c6bb9ed135f61a9cecbe8397defbf329.tar.gz
ports-cb8b1428c6bb9ed135f61a9cecbe8397defbf329.zip
Notes
Diffstat (limited to 'math/cantor/Makefile')
-rw-r--r--math/cantor/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/math/cantor/Makefile b/math/cantor/Makefile
index 00159ab50fc0..6d043105082f 100644
--- a/math/cantor/Makefile
+++ b/math/cantor/Makefile
@@ -1,9 +1,4 @@
-# New ports collection Makefile for: cantor
-# Date created: 5 September 2011
-# Whom: Alberto Villa <avilla@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= cantor
PORTVERSION= ${KDE4_VERSION}
@@ -28,21 +23,22 @@ USE_QT4= qtestlib_build xmlpatterns \
USE_XZ= yes
MAKE_JOBS_SAFE= yes
-OPTIONS= MAXIMA "Maxima backend" off \
- OCTAVE "Octave backend" off \
- R "R backend" off
+OPTIONS_DEFINE= MAXIMA OCTAVE R
+MAXIMA_DESC= Maxima backend
+OCTAVE_DESC= Octave backend
+R_DESC= R backend
.include <bsd.port.options.mk>
-.ifdef(WITH_MAXIMA)
+.if ${PORT_OPTIONS:MMAXIMA}
RUN_DEPENDS+= maxima:${PORTSDIR}/math/maxima
.endif
-.ifdef(WITH_OCTAVE)
+.if ${PORT_OPTIONS:MOCTAVE}
RUN_DEPENDS+= octave:${PORTSDIR}/math/octave
.endif
-.ifdef(WITH_R)
+.if ${PORT_OPTIONS:MR}
BUILD_DEPENDS+= R:${PORTSDIR}/math/R
RUN_DEPENDS+= R:${PORTSDIR}/math/R
# Required to set CFLAGS for -lgfortran.