aboutsummaryrefslogtreecommitdiff
path: root/math/cbc
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-04-16 07:55:42 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-04-16 07:55:42 +0000
commitd709177109442329c2781972719b391383ac4d08 (patch)
tree1dd3de3cd061fca034700fc50531a4b65fa32c16 /math/cbc
parentbd336e50c116f8b2e49b1299244cab951ad2b2c3 (diff)
downloadports-d709177109442329c2781972719b391383ac4d08.tar.gz
ports-d709177109442329c2781972719b391383ac4d08.zip
New port: Coin-or Branch and Cut: mixed integer programming solver
Notes
Notes: svn path=/head/; revision=467464
Diffstat (limited to 'math/cbc')
-rw-r--r--math/cbc/Makefile29
-rw-r--r--math/cbc/distinfo3
-rw-r--r--math/cbc/files/patch-Cbc_src_CbcModel.cpp11
-rw-r--r--math/cbc/pkg-descr8
-rw-r--r--math/cbc/pkg-plist92
5 files changed, 143 insertions, 0 deletions
diff --git a/math/cbc/Makefile b/math/cbc/Makefile
new file mode 100644
index 000000000000..bfdc4b1c0c04
--- /dev/null
+++ b/math/cbc/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= cbc
+DISTVERSIONPREFIX= releases/
+DISTVERSION= 2.9.9
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Coin-or Branch and Cut: mixed integer programming solver
+
+LICENSE= EPL
+LICENSE_FILE= ${WRKSRC}/Cbc/LICENSE
+
+LIB_DEPENDS= libblas.so:math/blas \
+ libCgl.so:math/cgl \
+ libClp.so:math/clp \
+ liblapack.so:math/lapack
+
+USES= fortran gmake libtool pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= coin-or
+GH_PROJECT= Cbc
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/*.so
+
+.include <bsd.port.mk>
diff --git a/math/cbc/distinfo b/math/cbc/distinfo
new file mode 100644
index 000000000000..3376a225d3b9
--- /dev/null
+++ b/math/cbc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522614939
+SHA256 (coin-or-Cbc-releases-2.9.9_GH0.tar.gz) = 3760fa9fe24fe3390c8b3d5f03583a62652d9b159aef9b0b609e4948ef1b8f29
+SIZE (coin-or-Cbc-releases-2.9.9_GH0.tar.gz) = 1658623
diff --git a/math/cbc/files/patch-Cbc_src_CbcModel.cpp b/math/cbc/files/patch-Cbc_src_CbcModel.cpp
new file mode 100644
index 000000000000..2c552fa973b9
--- /dev/null
+++ b/math/cbc/files/patch-Cbc_src_CbcModel.cpp
@@ -0,0 +1,11 @@
+--- Cbc/src/CbcModel.cpp.orig 2018-04-16 07:45:54 UTC
++++ Cbc/src/CbcModel.cpp
+@@ -5338,7 +5338,7 @@ void CbcModel::branchAndBound(int doStat
+ OsiClpSolverInterface * clpSolver
+ = dynamic_cast<OsiClpSolverInterface *> (solver_);
+ if (clpSolver)
+- clpSolver->setFakeObjective(reinterpret_cast<double *> (NULL));
++ clpSolver->setFakeObjective((double*)nullptr);
+ }
+ #endif
+ moreSpecialOptions_ = saveMoreSpecialOptions;
diff --git a/math/cbc/pkg-descr b/math/cbc/pkg-descr
new file mode 100644
index 000000000000..6042ed466c4d
--- /dev/null
+++ b/math/cbc/pkg-descr
@@ -0,0 +1,8 @@
+Cbc (Coin-or branch and cut) is an open-source mixed integer programming solver
+written in C++. It can be used as a callable library or using a stand-alone
+executable. It can be called through AMPL (natively), GAMS (using the links
+provided by the Optimization Services and GAMSlinks projects), MPL (through the
+CoinMP project), AIMMS (through the AIMMSlinks project), PuLP, CMPL, OpenSolver
+for Excel, JuMP, or MiniZinc.
+
+WWW: https://projects.coin-or.org/Cbc
diff --git a/math/cbc/pkg-plist b/math/cbc/pkg-plist
new file mode 100644
index 000000000000..b4df848b9e06
--- /dev/null
+++ b/math/cbc/pkg-plist
@@ -0,0 +1,92 @@
+bin/cbc
+include/coin/CbcBranchActual.hpp
+include/coin/CbcBranchAllDifferent.hpp
+include/coin/CbcBranchBase.hpp
+include/coin/CbcBranchCut.hpp
+include/coin/CbcBranchDecision.hpp
+include/coin/CbcBranchDefaultDecision.hpp
+include/coin/CbcBranchDynamic.hpp
+include/coin/CbcBranchLotsize.hpp
+include/coin/CbcBranchToFixLots.hpp
+include/coin/CbcBranchingObject.hpp
+include/coin/CbcClique.hpp
+include/coin/CbcCompare.hpp
+include/coin/CbcCompareActual.hpp
+include/coin/CbcCompareBase.hpp
+include/coin/CbcCompareDefault.hpp
+include/coin/CbcCompareDepth.hpp
+include/coin/CbcCompareEstimate.hpp
+include/coin/CbcCompareObjective.hpp
+include/coin/CbcConfig.h
+include/coin/CbcConsequence.hpp
+include/coin/CbcCountRowCut.hpp
+include/coin/CbcCutGenerator.hpp
+include/coin/CbcCutModifier.hpp
+include/coin/CbcCutSubsetModifier.hpp
+include/coin/CbcDummyBranchingObject.hpp
+include/coin/CbcEventHandler.hpp
+include/coin/CbcFathom.hpp
+include/coin/CbcFathomDynamicProgramming.hpp
+include/coin/CbcFeasibilityBase.hpp
+include/coin/CbcFixVariable.hpp
+include/coin/CbcFollowOn.hpp
+include/coin/CbcFullNodeInfo.hpp
+include/coin/CbcGeneral.hpp
+include/coin/CbcGeneralDepth.hpp
+include/coin/CbcHeuristic.hpp
+include/coin/CbcHeuristicDINS.hpp
+include/coin/CbcHeuristicDW.hpp
+include/coin/CbcHeuristicDive.hpp
+include/coin/CbcHeuristicDiveCoefficient.hpp
+include/coin/CbcHeuristicDiveFractional.hpp
+include/coin/CbcHeuristicDiveGuided.hpp
+include/coin/CbcHeuristicDiveLineSearch.hpp
+include/coin/CbcHeuristicDivePseudoCost.hpp
+include/coin/CbcHeuristicDiveVectorLength.hpp
+include/coin/CbcHeuristicFPump.hpp
+include/coin/CbcHeuristicGreedy.hpp
+include/coin/CbcHeuristicLocal.hpp
+include/coin/CbcHeuristicPivotAndFix.hpp
+include/coin/CbcHeuristicRENS.hpp
+include/coin/CbcHeuristicRINS.hpp
+include/coin/CbcHeuristicRandRound.hpp
+include/coin/CbcHeuristicVND.hpp
+include/coin/CbcLinked.hpp
+include/coin/CbcMessage.hpp
+include/coin/CbcMipStartIO.hpp
+include/coin/CbcModel.hpp
+include/coin/CbcNWay.hpp
+include/coin/CbcNode.hpp
+include/coin/CbcNodeInfo.hpp
+include/coin/CbcObject.hpp
+include/coin/CbcObjectUpdateData.hpp
+include/coin/CbcParam.hpp
+include/coin/CbcPartialNodeInfo.hpp
+include/coin/CbcSOS.hpp
+include/coin/CbcSimpleInteger.hpp
+include/coin/CbcSimpleIntegerDynamicPseudoCost.hpp
+include/coin/CbcSimpleIntegerPseudoCost.hpp
+include/coin/CbcSolver.hpp
+include/coin/CbcStrategy.hpp
+include/coin/CbcSubProblem.hpp
+include/coin/CbcTree.hpp
+include/coin/CbcTreeLocal.hpp
+include/coin/Cbc_C_Interface.h
+include/coin/ClpAmplObjective.hpp
+include/coin/ClpConstraintAmpl.hpp
+include/coin/OsiCbcSolverInterface.hpp
+lib/libCbc.so
+lib/libCbc.so.3
+lib/libCbc.so.3.9.9
+lib/libCbcSolver.so
+lib/libCbcSolver.so.3
+lib/libCbcSolver.so.3.9.9
+lib/libOsiCbc.so
+lib/libOsiCbc.so.3
+lib/libOsiCbc.so.3.9.9
+libdata/pkgconfig/cbc.pc
+libdata/pkgconfig/osi-cbc.pc
+share/coin/doc/Cbc/AUTHORS
+share/coin/doc/Cbc/LICENSE
+share/coin/doc/Cbc/README
+share/coin/doc/Cbc/cbc_addlibs.txt