aboutsummaryrefslogtreecommitdiff
path: root/math/ceres-solver
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-05-15 20:41:52 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-05-15 20:41:52 +0000
commita67144205f04cd5c5f0f66da8913ee9623c3d398 (patch)
treeaf7a553a7dae8e177e6ff01db7929d87f0e8bf9a /math/ceres-solver
parent2015dc0438ab52a737df1f66eae4c697eb74d499 (diff)
downloadports-a67144205f04cd5c5f0f66da8913ee9623c3d398.tar.gz
ports-a67144205f04cd5c5f0f66da8913ee9623c3d398.zip
math/ceres-solver: unbreak NETLIB=on by backing out r465552
-- Found BLAS: /usr/local/lib/libopenblas.so -- Found LAPACK library: /usr/local/lib/libopenblas.so;/usr/local/lib/libopenblas.so Pointy hat to: jbeich
Notes
Notes: svn path=/head/; revision=470051
Diffstat (limited to 'math/ceres-solver')
-rw-r--r--math/ceres-solver/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/math/ceres-solver/Makefile b/math/ceres-solver/Makefile
index 436a3cdf9522..5d71bec87db7 100644
--- a/math/ceres-solver/Makefile
+++ b/math/ceres-solver/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ceres-solver
DISTVERSION= 1.14.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= jbeich@FreeBSD.org
@@ -71,18 +71,18 @@ LAPACK_DESC= Linear Algebra PACKage
LAPACK_USES= fortran # LDFLAGS
LAPACK_CMAKE_BOOL= LAPACK
ATLAS_USES= blaslapack:atlas
-ATLAS_MAKE_ENV= BLA_VENDOR=ATLAS
-ATLAS_CMAKE_ON= -DLAPACK_LIBRARIES:STRING=alapack
+ATLAS_CMAKE_ON= -DBLA_VENDOR:STRING="ATLAS" \
+ -DLAPACK_LIBRARIES:STRING=alapack
ATLAS_IMPLIES= LAPACK
GOTOBLAS_DESC= Goto blas implementation
GOTOBLAS_USES= blaslapack:gotoblas
-GOTOBLAS_MAKE_ENV= BLA_VENDOR=Goto
+GOTOBLAS_CMAKE_ON= -DBLA_VENDOR:STRING="Goto"
GOTOBLAS_IMPLIES= LAPACK
NETLIB_USES= blaslapack:netlib
-NETLIB_MAKE_ENV= BLA_VENDOR=Generic
+NETLIB_CMAKE_ON= -DBLA_VENDOR:STRING="Generic"
NETLIB_IMPLIES= LAPACK
OPENBLAS_USES= blaslapack:openblas
-OPENBLAS_MAKE_ENV= BLA_VENDOR=OpenBLAS
+OPENBLAS_CMAKE_ON= -DBLA_VENDOR:STRING="OpenBLAS"
OPENBLAS_IMPLIES= LAPACK
SPARSE_DESC= Sparse linear algebra library