aboutsummaryrefslogtreecommitdiff
path: root/math/ceres-solver
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-05-15 20:54:02 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-05-15 20:54:02 +0000
commitd430b323127317fe89d81f8d459c2a51fe09f266 (patch)
tree58110e8e218bcfd4bd4293c7a45ef5ba9f7fcb0a /math/ceres-solver
parent6551dfcc43eae94c92e9e27e6a07289479ba88d0 (diff)
downloadports-d430b323127317fe89d81f8d459c2a51fe09f266.tar.gz
ports-d430b323127317fe89d81f8d459c2a51fe09f266.zip
math/ceres-solver: unbreak TBB=on (r470052 didn't help)
In file included from internal/ceres/block_random_access_dense_matrix.cc:31: In file included from internal/ceres/block_random_access_dense_matrix.h:34: In file included from internal/ceres/block_random_access_matrix.h:36: In file included from internal/ceres/mutex.h:98: include/ceres/internal/port.h:56:4: error: One of CERES_USE_OPENMP, CERES_USE_TBB,CERES_USE_CXX11_THREADS or CERES_NO_THREADS must be defined. # error One of CERES_USE_OPENMP, CERES_USE_TBB,CERES_USE_CXX11_THREADS or CERES_NO_THREADS must be defined. ^ Pointy hat to: jbeich
Notes
Notes: svn path=/head/; revision=470056
Diffstat (limited to 'math/ceres-solver')
-rw-r--r--math/ceres-solver/files/patch-CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/math/ceres-solver/files/patch-CMakeLists.txt b/math/ceres-solver/files/patch-CMakeLists.txt
index d52e30ba0b39..1b4b708c8128 100644
--- a/math/ceres-solver/files/patch-CMakeLists.txt
+++ b/math/ceres-solver/files/patch-CMakeLists.txt
@@ -7,7 +7,7 @@ https://github.com/ceres-solver/ceres-solver/issues/355
# -std=c++11 s/t we will detect the C++11 versions of unordered_map &
# shared_ptr if they exist.
- set(CMAKE_REQUIRED_FLAGS "${CMAKE_REQUIRED_FLAGS} -std=c++11")
-+ set(CMAKE_CXX_STANDARD 11)
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
endif (CXX11 AND COMPILER_HAS_CXX11_FLAG)
# Set the Ceres compile definitions for the unordered_map configuration.