aboutsummaryrefslogtreecommitdiff
path: root/math/cgal/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-01-02 16:49:24 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-01-02 16:49:24 +0000
commit51d04637cb2aa7e77e78d6b7de91125251405083 (patch)
treefefd75a0b797bfd5f2fbecc832b9a94f740ee983 /math/cgal/Makefile
parenta3cc859109302e74945b2f3684edfd3e5c434fdc (diff)
downloadports-51d04637cb2aa7e77e78d6b7de91125251405083.tar.gz
ports-51d04637cb2aa7e77e78d6b7de91125251405083.zip
New USES=eigen
Usage: USES=eigen:<version>[,<type>] version: 2 or 3 (required) type: build (default), run For example: USES=eigen:2,build,run will add a BUILD- and RUN_DEPENDS on math/eigen2, and USES=eigen:3 will add a BUILD_DEPENDS on math/eigen3. * Convert the existing ports to use it - biology/iqtree: remove run time dependency (seemed not to be needed) - graphics/movit: remove run time dependency (seemed not to be needed) - science/avogadro: add run time dependeny (installed cmake file requires it to be present) Reviewed by: rakuco, mat Differential Revision: https://reviews.freebsd.org/D13702
Notes
Notes: svn path=/head/; revision=457914
Diffstat (limited to 'math/cgal/Makefile')
-rw-r--r--math/cgal/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/math/cgal/Makefile b/math/cgal/Makefile
index b81bd341b65c..a5f7b56e1d71 100644
--- a/math/cgal/Makefile
+++ b/math/cgal/Makefile
@@ -16,8 +16,7 @@ LICENSE_COMB= multi
BROKEN_sparc64= does not build: fails to compile all_files.cpp
-BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen3.pc:math/eigen3 \
- ${LOCALBASE}/lib/libntl.a:math/ntl
+BUILD_DEPENDS= ${LOCALBASE}/lib/libntl.a:math/ntl
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libmpfr.so:math/mpfr \
libgmp.so:math/gmp
@@ -25,7 +24,7 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
#TODO math/mpfi, math/rs, graphics/qglviewer
#Not yet in ports
-USES= cmake shebangfix tar:xz
+USES= cmake eigen:3 shebangfix tar:xz
USE_LDCONFIG= yes
SHEBANG_FILES= scripts/cgal_create_CMakeLists \
scripts/cgal_create_cmake_script