aboutsummaryrefslogtreecommitdiff
path: root/math/cgal/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-28 17:55:46 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-28 17:55:46 +0000
commit65ffa9ea032bf87b75200a81a266f516be961b83 (patch)
treef9dde41c610834a22b4fbad6907bc24c378d963c /math/cgal/Makefile
parent4cda5a29924d3f4c8aceb2dc910ec6cbcf59b2e9 (diff)
downloadports-65ffa9ea032bf87b75200a81a266f516be961b83.tar.gz
ports-65ffa9ea032bf87b75200a81a266f516be961b83.zip
- Require newer clang instead of gcc to circumvent clang 3.8 internal error; this fixes consumer ports (at least cad/openscad) which suffer from libc++/libstdc++ incompatibility
Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=429807
Diffstat (limited to 'math/cgal/Makefile')
-rw-r--r--math/cgal/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/math/cgal/Makefile b/math/cgal/Makefile
index 0fc465880ed9..2d5171e5c880 100644
--- a/math/cgal/Makefile
+++ b/math/cgal/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cgal
PORTVERSION= 4.9
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= https://github.com/CGAL/cgal/releases/download/releases%2FCGAL-4.9/
DISTNAME= CGAL-${PORTVERSION}
@@ -19,19 +19,21 @@ RUN_DEPENDS= ${LOCALBASE}/include/boost/tuple/tuple.hpp:devel/boost-libs
LIB_DEPENDS= libmpfr.so:math/mpfr \
libgmp.so:math/gmp
-BROKEN_sparc64= Does not build: fails to compile all_files.cpp
+BROKEN_sparc64= does not build: fails to compile all_files.cpp
-USE_LDCONFIG= yes
-USES= cmake shebangfix tar:xz
-USE_QT5= buildtools_build core gui opengl qmake_build widgets
-SHEBANG_FILES= scripts/cgal_create_CMakeLists \
- scripts/cgal_create_cmake_script
+USE_LDCONFIG= yes
+USES= cmake shebangfix tar:xz
+USE_QT5= buildtools_build core gui opengl qmake_build widgets
+SHEBANG_FILES= scripts/cgal_create_CMakeLists \
+ scripts/cgal_create_cmake_script
.include <bsd.port.options.mk>
-.if ${ARCH} == i386 && ${OSVERSION} >= 1100000
-# clang internal error
-USE_GCC= yes
+.if ${ARCH} == i386 && ${OPSYS} == FreeBSD && ((${OSVERSION} >= 1100000 && ${OSVERSION} < 1100508) || (${OSVERSION} >= 1200000 && ${OSVERSION} < 1200017))
+# clang internal error in clang 3.8
+BUILD_DEPENDS+= clang39:devel/llvm39
+CC= clang39
+CXX= clang++39
.endif
.include <bsd.port.mk>