aboutsummaryrefslogtreecommitdiff
path: root/math/cgal
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-09 10:38:38 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-09 10:38:38 +0000
commit85cf4395e8a2f72d1c1c91b13d2275fc17f6bab0 (patch)
treed09eb0e6166161860acba44a3080525e70289f89 /math/cgal
parenta10f160bc424c43d8d8308b07f8ea3685c64f6bf (diff)
downloadports-85cf4395e8a2f72d1c1c91b13d2275fc17f6bab0.tar.gz
ports-85cf4395e8a2f72d1c1c91b13d2275fc17f6bab0.zip
- Fix build of cgal consumers (sfcgal) with boost 1.60
PR: 199601 Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=408549
Diffstat (limited to 'math/cgal')
-rw-r--r--math/cgal/Makefile1
-rw-r--r--math/cgal/files/patch-include_CGAL_Straight__skeleton_2_Straight_skeleton_builder_2_impl.h16
2 files changed, 17 insertions, 0 deletions
diff --git a/math/cgal/Makefile b/math/cgal/Makefile
index b3accfdccb35..b8cef342a96f 100644
--- a/math/cgal/Makefile
+++ b/math/cgal/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cgal
PORTVERSION= 4.6
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://gforge.inria.fr/frs/download.php/34703/
DISTNAME= CGAL-${PORTVERSION}
diff --git a/math/cgal/files/patch-include_CGAL_Straight__skeleton_2_Straight_skeleton_builder_2_impl.h b/math/cgal/files/patch-include_CGAL_Straight__skeleton_2_Straight_skeleton_builder_2_impl.h
new file mode 100644
index 000000000000..17aeede9dc54
--- /dev/null
+++ b/math/cgal/files/patch-include_CGAL_Straight__skeleton_2_Straight_skeleton_builder_2_impl.h
@@ -0,0 +1,16 @@
+--- include/CGAL/Straight_skeleton_2/Straight_skeleton_builder_2_impl.h.orig 2014-08-29 14:14:56 UTC
++++ include/CGAL/Straight_skeleton_2/Straight_skeleton_builder_2_impl.h
+@@ -21,6 +21,13 @@
+
+ #include <boost/bind.hpp>
+ #include <boost/utility.hpp>
++
++// Workaround for boost bug #11880
++#include <boost/version.hpp>
++#if BOOST_VERSION == 106000
++ #include <boost/type_traits/ice.hpp>
++#endif
++
+ #include <boost/graph/adjacency_matrix.hpp>
+ #include <CGAL/Unique_hash_map.h>
+