aboutsummaryrefslogtreecommitdiff
path: root/math/clingo
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-11-16 03:56:37 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-11-16 03:56:37 +0000
commitf0565a526dd8b9b0ae712beee76cc7f8380f65e4 (patch)
tree853d3db2cfce32df15c52c8d90ff7041d60f6545 /math/clingo
parentc92883d2d1e1901cc7052a6b503b079085f9ce41 (diff)
downloadports-f0565a526dd8b9b0ae712beee76cc7f8380f65e4.tar.gz
ports-f0565a526dd8b9b0ae712beee76cc7f8380f65e4.zip
New port: math/clingo: Grounder and solver for logic programs
Notes
Notes: svn path=/head/; revision=517713
Diffstat (limited to 'math/clingo')
-rw-r--r--math/clingo/Makefile25
-rw-r--r--math/clingo/distinfo5
-rw-r--r--math/clingo/pkg-descr5
-rw-r--r--math/clingo/pkg-plist14
4 files changed, 49 insertions, 0 deletions
diff --git a/math/clingo/Makefile b/math/clingo/Makefile
new file mode 100644
index 000000000000..e8415d725975
--- /dev/null
+++ b/math/clingo/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= clingo
+DISTVERSIONPREFIX= v
+DISTVERSION= 5.4.0
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Grounder and solver for logic programs
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+BUILD_DEPENDS= re2c:devel/re2c
+
+USES= cmake
+USE_GITHUB= yes
+GH_ACCOUNT= potassco
+GH_TUPLE= potassco:clasp:c183473:clasp/clasp
+USE_LDCONFIG= yes
+
+CMAKE_OFF= CLINGO_BUILD_WITH_PYTHON # broken, see https://github.com/potassco/clingo/issues/178
+CMAKE_OFF+= CLINGO_BUILD_WITH_LUA
+
+.include <bsd.port.mk>
diff --git a/math/clingo/distinfo b/math/clingo/distinfo
new file mode 100644
index 000000000000..c7a5edf358bd
--- /dev/null
+++ b/math/clingo/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1573875509
+SHA256 (potassco-clingo-v5.4.0_GH0.tar.gz) = e2de331ee0a6d254193aab5995338a621372517adcf91568092be8ac511c18f3
+SIZE (potassco-clingo-v5.4.0_GH0.tar.gz) = 2822810
+SHA256 (potassco-clasp-c183473_GH0.tar.gz) = 04e9660309832a0c7627970fce605b3da8755858f33d39b6e132ad62eaa126db
+SIZE (potassco-clasp-c183473_GH0.tar.gz) = 621447
diff --git a/math/clingo/pkg-descr b/math/clingo/pkg-descr
new file mode 100644
index 000000000000..39219b775a7b
--- /dev/null
+++ b/math/clingo/pkg-descr
@@ -0,0 +1,5 @@
+Answer Set Programming (ASP) offers a simple and powerful modeling language to
+solve combinatorial problems. With these tools users can concentrate on an
+actual problem, rather than a smart way of implementing it.
+
+WWW: https://potassco.org/
diff --git a/math/clingo/pkg-plist b/math/clingo/pkg-plist
new file mode 100644
index 000000000000..6437ca208cb7
--- /dev/null
+++ b/math/clingo/pkg-plist
@@ -0,0 +1,14 @@
+bin/clasp
+bin/clingo
+bin/gringo
+bin/lpconvert
+bin/reify
+include/clingo.h
+include/clingo.hh
+lib/cmake/Clingo/ClingoConfig.cmake
+lib/cmake/Clingo/ClingoConfigVersion.cmake
+lib/cmake/Clingo/ClingoTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Clingo/ClingoTargets.cmake
+lib/libclingo.so
+lib/libclingo.so.3
+lib/libclingo.so.3.0