aboutsummaryrefslogtreecommitdiff
path: root/math/cmh
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-01-15 11:01:17 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-01-15 11:01:17 +0000
commit356b8553c5c8498a44876746a5b63a0b46197b1c (patch)
tree889b1693d98999d1dee9f58d47faffda2ba355a3 /math/cmh
parent89f07463314fc8bc7d528d6b8d52b23066263610 (diff)
downloadports-356b8553c5c8498a44876746a5b63a0b46197b1c.tar.gz
ports-356b8553c5c8498a44876746a5b63a0b46197b1c.zip
New port: math/cmh: Compute Igusa class polynomials
Notes
Notes: svn path=/head/; revision=561632
Diffstat (limited to 'math/cmh')
-rw-r--r--math/cmh/Makefile37
-rw-r--r--math/cmh/distinfo3
-rw-r--r--math/cmh/pkg-descr7
-rw-r--r--math/cmh/pkg-plist13
4 files changed, 60 insertions, 0 deletions
diff --git a/math/cmh/Makefile b/math/cmh/Makefile
new file mode 100644
index 000000000000..e0872871eb2d
--- /dev/null
+++ b/math/cmh/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= cmh
+DISTVERSION= 1.0.20200923
+CATEGORIES= math
+#MASTER_SITES= http://www.multiprecision.org/downloads/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Compute Igusa class polynomials
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libfplll.so:math/fplll \
+ libgmp.so:math/gmp \
+ libmpc.so:math/mpc \
+ libmpfr.so:math/mpfr \
+ libmpfrcx.so:math/mpfrcx \
+ libpari.so:math/pari
+RUN_DEPENDS= bash:shells/bash
+
+USES= autoreconf gmake libtool localbase shebangfix
+USE_LDCONFIG= yes
+
+USE_GITLAB= yes
+GL_SITE= https://gitlab.inria.fr/
+GL_COMMIT= 53bba6332e8df9d30ed9bb839bd78afe6aa60153
+
+SHEBANG_FILES= scripts/cmh-classpol.sh.in
+
+GNU_CONFIGURE= yes
+
+INSTALL_TARGET= install-strip
+
+INFO= cm
+
+.include <bsd.port.mk>
diff --git a/math/cmh/distinfo b/math/cmh/distinfo
new file mode 100644
index 000000000000..21ae75e2f60c
--- /dev/null
+++ b/math/cmh/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1610707507
+SHA256 (cmh-cmh-53bba6332e8df9d30ed9bb839bd78afe6aa60153_GL0.tar.gz) = da85333523611d520da3113e1253dad10a2a038f75542bc77afcb11432ec7298
+SIZE (cmh-cmh-53bba6332e8df9d30ed9bb839bd78afe6aa60153_GL0.tar.gz) = 138285
diff --git a/math/cmh/pkg-descr b/math/cmh/pkg-descr
new file mode 100644
index 000000000000..b7463a60265c
--- /dev/null
+++ b/math/cmh/pkg-descr
@@ -0,0 +1,7 @@
+This software package computes Igusa (genus 2) class polynomials, which
+parameterise the CM points in the moduli space of 2-dimensional abelian
+varieties, i.e. Jacobians of hyperelliptic curves.
+
+This program is also able to compute theta constants at arbitrary precision.
+
+WWW: http://www.multiprecision.org/cmh/home.html
diff --git a/math/cmh/pkg-plist b/math/cmh/pkg-plist
new file mode 100644
index 000000000000..a7069634aa45
--- /dev/null
+++ b/math/cmh/pkg-plist
@@ -0,0 +1,13 @@
+bin/cm2
+bin/cmh-classpol.sh
+include/cmh.h
+lib/cmh/libparsepari.a
+lib/cmh/libparsepari.so
+lib/cmh/libparsepari.so.0
+lib/cmh/libparsepari.so.0.0.0
+lib/libcmh.a
+lib/libcmh.so
+lib/libcmh.so.0
+lib/libcmh.so.0.0.0
+%%DATADIR%%/checkpol.gp
+%%DATADIR%%/shimura.gp