aboutsummaryrefslogtreecommitdiff
path: root/math/coin-or-mumps
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-02-23 19:13:41 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-02-23 20:02:16 +0000
commit831a9b667f853d7c9e30e60eafbaa9bc7458f1e0 (patch)
treeefa76d17cbd7e11fd9da54ddf72b6f7020940bf1 /math/coin-or-mumps
parentf93ce0d23da27e2bc19196fabb4bbcd7c78959aa (diff)
downloadports-831a9b667f853d7c9e30e60eafbaa9bc7458f1e0.tar.gz
ports-831a9b667f853d7c9e30e60eafbaa9bc7458f1e0.zip
Diffstat (limited to 'math/coin-or-mumps')
-rw-r--r--math/coin-or-mumps/Makefile47
-rw-r--r--math/coin-or-mumps/distinfo5
-rw-r--r--math/coin-or-mumps/pkg-descr5
-rw-r--r--math/coin-or-mumps/pkg-plist8
4 files changed, 65 insertions, 0 deletions
diff --git a/math/coin-or-mumps/Makefile b/math/coin-or-mumps/Makefile
new file mode 100644
index 000000000000..b0b8f85dec0f
--- /dev/null
+++ b/math/coin-or-mumps/Makefile
@@ -0,0 +1,47 @@
+PORTNAME= mumps
+DISTVERSIONPREFIX= releases/
+DISTVERSION= 1.6.3
+CATEGORIES= math
+MASTER_SITES= http://mumps.enseeiht.fr/:mumps
+PKGNAMEPREFIX= coin-or-
+DISTFILES= MUMPS_${MUMPS_VERSION}.tar.gz:mumps
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= COIN-OR autotools harness to build Mumps
+
+LICENSE= EPL
+
+LIB_DEPENDS= libblas.so:math/blas \
+ libcoinmetis.so:math/coin-or-metis
+
+USES= fortran gmake libtool pkgconfig
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= coin-or-tools
+GH_PROJECT= ThirdParty-Mumps
+
+GNU_CONFIGURE= yes
+
+INSTALL_TARGET= install-strip
+
+MUMPS_VERSION= 4.10.0 # from the script get.Mumps
+
+.include <bsd.port.pre.mk>
+
+.if ${GCC_DEFAULT} >= 10
+# workaround for Rank mismatch between actual argument at (1) and actual argument at (2) (scalar and rank-1)
+# in theory, this should set FCFLAGS, but the port does not conform
+FFLAGS+= -fallow-argument-mismatch
+.endif
+
+post-extract: # link MUMPS into the location in the tree
+ @cd ${WRKSRC} && ${LN} -s ${WRKDIR}/MUMPS_${MUMPS_VERSION} MUMPS
+
+pre-build: # patching from get.Mumps
+ @cd ${WRKSRC} && \
+ ${PATCH} -p0 < mumps.patch && \
+ ${PATCH} -p0 < mumps_mpi.patch && \
+ ${MV} MUMPS/libseq/mpi.h MUMPS/libseq/mumps_mpi.h
+
+.include <bsd.port.post.mk>
diff --git a/math/coin-or-mumps/distinfo b/math/coin-or-mumps/distinfo
new file mode 100644
index 000000000000..f007decca5d9
--- /dev/null
+++ b/math/coin-or-mumps/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1645642530
+SHA256 (MUMPS_4.10.0.tar.gz) = d0f86f91a74c51a17a2ff1be9c9cee2338976f13a6d00896ba5b43a5ca05d933
+SIZE (MUMPS_4.10.0.tar.gz) = 2481516
+SHA256 (coin-or-tools-ThirdParty-Mumps-releases-1.6.3_GH0.tar.gz) = c66a2e77c601e8e094c6b71c1b13d015745481afb286e5776bb4379e241168c8
+SIZE (coin-or-tools-ThirdParty-Mumps-releases-1.6.3_GH0.tar.gz) = 269165
diff --git a/math/coin-or-mumps/pkg-descr b/math/coin-or-mumps/pkg-descr
new file mode 100644
index 000000000000..f6e28d98c5fe
--- /dev/null
+++ b/math/coin-or-mumps/pkg-descr
@@ -0,0 +1,5 @@
+This is an autotools-based build system to build and install
+MUltifrontal Massively Parallel sparse direct Solver (MUMPS).
+This installation of MUMPS is used by some other COIN-OR projects.
+
+WWW: https://github.com/coin-or-tools/ThirdParty-Mumps
diff --git a/math/coin-or-mumps/pkg-plist b/math/coin-or-mumps/pkg-plist
new file mode 100644
index 000000000000..014b4b648744
--- /dev/null
+++ b/math/coin-or-mumps/pkg-plist
@@ -0,0 +1,8 @@
+include/coin/ThirdParty/dmumps_c.h
+include/coin/ThirdParty/mumps_c_types.h
+include/coin/ThirdParty/mumps_compat.h
+include/coin/ThirdParty/mumps_mpi.h
+lib/libcoinmumps.so
+lib/libcoinmumps.so.1
+lib/libcoinmumps.so.1.6.3
+libdata/pkgconfig/coinmumps.pc