aboutsummaryrefslogtreecommitdiff
path: root/math/coinmumps
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-10-19 03:54:22 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-10-19 03:54:22 +0000
commit3a3dd306aab05d448af5476ce0354a5f085e93f8 (patch)
tree629553111bb117aba6ee801791fcc7f375f9e485 /math/coinmumps
parent5f507e4ade313305431ad0c3d3b18c24fff2b21f (diff)
downloadports-3a3dd306aab05d448af5476ce0354a5f085e93f8.tar.gz
ports-3a3dd306aab05d448af5476ce0354a5f085e93f8.zip
New port: math/coinmumps: MUltifrontal Massively Parallel sparse direct Solver (MUMPS)
Notes
Notes: svn path=/head/; revision=552709
Diffstat (limited to 'math/coinmumps')
-rw-r--r--math/coinmumps/Makefile41
-rw-r--r--math/coinmumps/distinfo5
-rw-r--r--math/coinmumps/pkg-descr5
-rw-r--r--math/coinmumps/pkg-plist8
4 files changed, 59 insertions, 0 deletions
diff --git a/math/coinmumps/Makefile b/math/coinmumps/Makefile
new file mode 100644
index 000000000000..84f652569cba
--- /dev/null
+++ b/math/coinmumps/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= coinmumps
+DISTVERSIONPREFIX= releases/
+DISTVERSION= 1.6.2
+CATEGORIES= math
+MASTER_SITES= http://coin-or-tools.github.io/ThirdParty-Mumps/:mumps
+PKGNAMEPREFIX= coin-or-
+DISTFILES= MUMPS_${MUMPS_VERSION}.tar.gz:mumps
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= MUltifrontal Massively Parallel sparse direct Solver (MUMPS)
+
+LICENSE= PD
+LICENSE_FILE= ${WRKDIR}/MUMPS_${MUMPS_VERSION}/LICENSE
+
+LIB_DEPENDS= libblas.so:math/blas
+
+USES= fortran gmake libtool
+USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= coin-or-tools
+GH_PROJECT= ThirdParty-Mumps
+
+INSTALL_TARGET= install-strip
+
+MUMPS_VERSION= 4.10.0
+
+post-extract:
+ @${RLN} ${WRKDIR}/MUMPS_${MUMPS_VERSION} ${WRKSRC}/MUMPS
+
+post-patch: # from get.Mumps
+ @cd ${WRKSRC} && \
+ ${PATCH} -p0 < mumps.patch && \
+ ${PATCH} -p0 < mumps_mpi.patch && \
+ ${MV} MUMPS/libseq/mpi.h MUMPS/libseq/mumps_mpi.h
+
+.include <bsd.port.mk>
diff --git a/math/coinmumps/distinfo b/math/coinmumps/distinfo
new file mode 100644
index 000000000000..81511cdbaec2
--- /dev/null
+++ b/math/coinmumps/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1603072890
+SHA256 (MUMPS_4.10.0.tar.gz) = d0f86f91a74c51a17a2ff1be9c9cee2338976f13a6d00896ba5b43a5ca05d933
+SIZE (MUMPS_4.10.0.tar.gz) = 2481516
+SHA256 (coin-or-tools-ThirdParty-Mumps-releases-1.6.2_GH0.tar.gz) = 0cfdd30b9cb42d9539ad9c495629f56dd1fc0b59cea691bbe71a129fabd8895d
+SIZE (coin-or-tools-ThirdParty-Mumps-releases-1.6.2_GH0.tar.gz) = 269074
diff --git a/math/coinmumps/pkg-descr b/math/coinmumps/pkg-descr
new file mode 100644
index 000000000000..98f3a540d68a
--- /dev/null
+++ b/math/coinmumps/pkg-descr
@@ -0,0 +1,5 @@
+An autotools-based build system to build and install MUltifrontal Massively
+Parallel sparse direct Solver (MUMPS). This installation of MUMPS is used by
+some other COIN-OR projects.
+
+WWW: https://github.com/coin-or-tools/ThirdParty-Mumps
diff --git a/math/coinmumps/pkg-plist b/math/coinmumps/pkg-plist
new file mode 100644
index 000000000000..9bf45156bcb1
--- /dev/null
+++ b/math/coinmumps/pkg-plist
@@ -0,0 +1,8 @@
+include/coin/ThirdParty/dmumps_c.h
+include/coin/ThirdParty/mumps_c_types.h
+include/coin/ThirdParty/mumps_compat.h
+include/coin/ThirdParty/mumps_mpi.h
+lib/libcoinmumps.so
+lib/libcoinmumps.so.1
+lib/libcoinmumps.so.1.6.2
+libdata/pkgconfig/coinmumps.pc