aboutsummaryrefslogtreecommitdiff
path: root/math/concorde/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-07-01 02:25:37 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-07-01 02:25:37 +0000
commit4fa7aaa67d15b0e35f17ee08f4caa6aaeb2ee948 (patch)
tree67a286f54208b575052415831d46df60d1be8cad /math/concorde/Makefile
parent9ed6c1e5dc33ad82ae901b8e37a187d5d4291375 (diff)
downloadports-4fa7aaa67d15b0e35f17ee08f4caa6aaeb2ee948.tar.gz
ports-4fa7aaa67d15b0e35f17ee08f4caa6aaeb2ee948.zip
Notes
Diffstat (limited to 'math/concorde/Makefile')
-rw-r--r--math/concorde/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/math/concorde/Makefile b/math/concorde/Makefile
index 2acbc30a28ce..ab62afda4e0b 100644
--- a/math/concorde/Makefile
+++ b/math/concorde/Makefile
@@ -18,8 +18,18 @@ WRKSRC= ${WRKDIR}/concorde
GNU_CONFIGURE= yes
+INCFILES= bigguy.h combs.h config.h consec1.h cut.h cuttree.h \
+ delaunay.h edgegen.h fmatch.h heldkarp.h kdtree.h \
+ linkern.h localcut.h lp.h machdefs.h macrorus.h mlinkern.h \
+ necklace.h pq.h pqsets.h profdata.h profrus.h tinytsp.h \
+ tsp.h util.h verify.h
+
do-install:
${INSTALL_DATA} ${WRKSRC}/concorde.a ${PREFIX}/lib/libconcorde.a
- ${INSTALL_DATA} ${WRKSRC}/concorde.h ${PREFIX}/include
+ ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 755 ${PREFIX}/include/concorde
+ ${INSTALL_DATA} ${WRKSRC}/concorde.h ${PREFIX}/include/concorde
+.for f in ${INCFILES}
+ ${INSTALL_DATA} ${WRKSRC}/INCLUDE/${f} ${PREFIX}/include/concorde
+.endfor
.include <bsd.port.mk>