aboutsummaryrefslogtreecommitdiff
path: root/math/creme
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-05-14 07:55:16 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-05-14 07:56:06 +0000
commit0a733dd7d79479e46380fa7e68c0c98f1361afd3 (patch)
tree8b72569a21a4ca311daad4575c8c924f63e6d822 /math/creme
parentfd036e9a4af953428f579dab47448956db26aa99 (diff)
downloadports-0a733dd7d79479e46380fa7e68c0c98f1361afd3.tar.gz
ports-0a733dd7d79479e46380fa7e68c0c98f1361afd3.zip
New port: math/creme: Randomized thermal relaxation method for MaxFS problems
Diffstat (limited to 'math/creme')
-rw-r--r--math/creme/Makefile25
-rw-r--r--math/creme/distinfo3
-rw-r--r--math/creme/pkg-descr10
-rw-r--r--math/creme/pkg-plist16
4 files changed, 54 insertions, 0 deletions
diff --git a/math/creme/Makefile b/math/creme/Makefile
new file mode 100644
index 000000000000..cbb1093ded6c
--- /dev/null
+++ b/math/creme/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= creme
+DISTVERSION= g20210114
+CATEGORIES= math
+PKGNAMEPREFIX= coin-or-
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Randomized thermal relaxation method for MaxFS problems
+
+LICENSE= EPL
+
+USES= compiler:c++11-lang gmake libtool
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= coin-or
+GH_PROJECT= Creme
+GH_TAGNAME= ab42f19
+
+GNU_CONFIGURE= yes
+
+INSTALL_TARGET= install-strip
+
+TEST_TARGET= test
+
+.include <bsd.port.mk>
diff --git a/math/creme/distinfo b/math/creme/distinfo
new file mode 100644
index 000000000000..e6efea3a4c82
--- /dev/null
+++ b/math/creme/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1620974340
+SHA256 (coin-or-Creme-g20210114-ab42f19_GH0.tar.gz) = 48ab55638c07a8bc6f5959e1e7f4c48b77e6a59322a3699ed7464a71ac586a88
+SIZE (coin-or-Creme-g20210114-ab42f19_GH0.tar.gz) = 3256085
diff --git a/math/creme/pkg-descr b/math/creme/pkg-descr
new file mode 100644
index 000000000000..100a20208853
--- /dev/null
+++ b/math/creme/pkg-descr
@@ -0,0 +1,10 @@
+Creme is an implementation of the randomized thermal relaxation method to find
+a feasible solution of the Maximum Feasible Subsystem (MaxFS) problem. The MaxFS
+problem consists, given a Linear Programming problem
+
+A x <= b,
+
+generally infeasible, in finding a feasible subsystem containing a maximum
+number of inequalities.
+
+WWW: https://github.com/coin-or/Creme
diff --git a/math/creme/pkg-plist b/math/creme/pkg-plist
new file mode 100644
index 000000000000..837fa04a81c9
--- /dev/null
+++ b/math/creme/pkg-plist
@@ -0,0 +1,16 @@
+bin/creme
+include/coin/chooseblock.h
+include/coin/cmdline.h
+include/coin/init.h
+include/coin/isfeas.h
+include/coin/linopt.h
+include/coin/locsrch.h
+include/coin/lpio.h
+include/coin/misc.h
+include/coin/move.h
+include/coin/rtr.h
+include/coin/sparse.h
+lib/libCreme.so
+lib/libCreme.so.0
+lib/libCreme.so.0.0.0
+libdata/pkgconfig/creme.pc