aboutsummaryrefslogtreecommitdiff
path: root/math/cudd/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-03-23 06:31:10 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-03-23 06:31:10 +0000
commit50b3a2264664dcc8e7f9a1c0364a9022f3df5138 (patch)
tree0d266f7dae0d796fa57c2eafdbdd25f7309a7c86 /math/cudd/Makefile
parent6bb008a3b79dc783ba7f8efe68b9a99c05f8bb08 (diff)
downloadports-50b3a2264664dcc8e7f9a1c0364a9022f3df5138.tar.gz
ports-50b3a2264664dcc8e7f9a1c0364a9022f3df5138.zip
New port: math/cudd: Package for the manipulation of Binary Decision Diagrams (BDDs), etc
Notes
Notes: svn path=/head/; revision=528952
Diffstat (limited to 'math/cudd/Makefile')
-rw-r--r--math/cudd/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/math/cudd/Makefile b/math/cudd/Makefile
new file mode 100644
index 000000000000..ea8268165c3d
--- /dev/null
+++ b/math/cudd/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= cudd
+DISTVERSION= 3.0.0
+CATEGORIES= math
+MASTER_SITES= https://davidkebo.com/source/cudd_versions/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Package for the manipulation of Binary Decision Diagrams (BDDs), etc
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= gmake libtool
+USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-shared
+
+PLIST_FILES= include/cudd.h \
+ lib/libcudd-3.0.0.so.0 \
+ lib/libcudd-3.0.0.so.0.0.0 \
+ lib/libcudd.a \
+ lib/libcudd.so
+
+.include <bsd.port.mk>