aboutsummaryrefslogtreecommitdiff
path: root/math/curv
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-04-11 19:48:52 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-04-12 00:33:47 +0000
commit8bd75ffd808902bb002b3d1c46a89478cfa57d8b (patch)
tree5b2262b416f056b7eb377feceb2c2e872395732b /math/curv
parentf99057b3c2e7980852b1be4ab86a5cacaf8ad457 (diff)
downloadports-8bd75ffd808902bb002b3d1c46a89478cfa57d8b.tar.gz
ports-8bd75ffd808902bb002b3d1c46a89478cfa57d8b.zip
Diffstat (limited to 'math/curv')
-rw-r--r--math/curv/files/patch-CMakeLists.txt4
-rw-r--r--math/curv/files/patch-cmake_FindILMBase.cmake10
2 files changed, 12 insertions, 2 deletions
diff --git a/math/curv/files/patch-CMakeLists.txt b/math/curv/files/patch-CMakeLists.txt
index 9a67dffa815b..25ece990b936 100644
--- a/math/curv/files/patch-CMakeLists.txt
+++ b/math/curv/files/patch-CMakeLists.txt
@@ -1,4 +1,4 @@
---- CMakeLists.txt.orig 2019-10-15 23:21:21 UTC
+--- CMakeLists.txt.orig 2019-12-08 04:12:07 UTC
+++ CMakeLists.txt
@@ -10,18 +10,14 @@ execute_process(COMMAND sh -c "${CMAKE_SOURCE_DIR}/cma
@@ -48,7 +48,7 @@
file(GLOB Src "curv/*.c" "curv/*.cc")
add_executable(curv ${Src})
-target_link_libraries(curv PUBLIC libcurv_geom libcurv imgui glfw glad ${LibOpenGL} replxx double-conversion boost_iostreams boost_filesystem boost_system openvdb_static Half tbb dl pthread)
-+target_link_libraries(curv PUBLIC libcurv_geom libcurv imgui glfw glad ${LibOpenGL} replxx double-conversion boost_iostreams boost_filesystem boost_system openvdb Half tbb dl pthread)
++target_link_libraries(curv PUBLIC libcurv_geom libcurv imgui glfw glad ${LibOpenGL} replxx double-conversion boost_iostreams boost_filesystem boost_system openvdb Imath tbb dl pthread)
file(GLOB CurvcSrc "curvc/*.cc")
add_executable(curvc EXCLUDE_FROM_ALL ${CurvcSrc})
diff --git a/math/curv/files/patch-cmake_FindILMBase.cmake b/math/curv/files/patch-cmake_FindILMBase.cmake
new file mode 100644
index 000000000000..df960f135ab6
--- /dev/null
+++ b/math/curv/files/patch-cmake_FindILMBase.cmake
@@ -0,0 +1,10 @@
+--- cmake/FindILMBase.cmake.orig 2019-12-08 04:12:07 UTC
++++ cmake/FindILMBase.cmake
+@@ -6,6 +6,6 @@
+
+ SET( ILMBASE_FOUND TRUE )
+ SET( ILMBASE_INCLUDE_DIR "" )
+-SET( Ilmbase_HALF_LIBRARY -lHalf )
++SET( Ilmbase_HALF_LIBRARY -lImath )
+ SET( Ilmbase_IEX_LIBRARY -lIex )
+ SET( Ilmbase_ILMTHREAD_LIBRARY -lIlmThread )