aboutsummaryrefslogtreecommitdiff
path: root/math/cvc3
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-02-11 19:54:32 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-02-11 19:54:32 +0000
commitb18b84acc013d25cc11387e15c052456c07fb5cc (patch)
treedec12fce35a38d301a416be534197bd00d3406a3 /math/cvc3
parent016523dab8c4400fd99d22b0ac7daf090989c1cb (diff)
downloadports-b18b84acc013d25cc11387e15c052456c07fb5cc.tar.gz
ports-b18b84acc013d25cc11387e15c052456c07fb5cc.zip
math/cvc3: unbreak with gcc6 or later
In file included from src/include/expr_manager.h:445:0, from src/include/expr.h:803, from expr.cpp:25: src/include/expr_value.h: In static member function 'static size_t CVC3::ExprString::hash(const string&)': src/include/expr_value.h:667:34: error: no match for call to '(std::hash<char*>) (const char*)' return s_charHash(str.c_str()); ^ In file included from src/include/hash_map.h:54:0, from src/include/compat_hash_map.h:34, from src/include/expr.h:33, from src/include/assumptions.h:36, from src/include/theorem_producer.h:75, from common_theorem_producer.h:34, from common_theorem_producer.cpp:27: src/include/hash_table.h: In instantiation of 'Hash::hash_table<_Key, _Value, _HashFcn, _EqualKey, _ExtractKey>::~hash_table() [with _Key = CVC3::Expr; _Value = std::pair<const CVC3::Expr, CVC3::CDOmap<CVC3::Expr, CVC3::Theorem, std::hash<CVC3::Expr> >*>; _HashFcn = std::hash<CVC3::Expr>; _EqualKey = std::equal_to<CVC3::Expr>; _ExtractKey = Hash::_Select1st<std::pair<const CVC3::Expr, CVC3::CDOmap<CVC3::Expr, CVC3::Theorem, std::hash<CVC3::Expr> >*> >]': src/include/hash_map.h:82:9: required from 'CVC3::CDMap<Key, Data, HashFcn>::~CDMap() [with Key = CVC3::Expr; Data = CVC3::Theorem; HashFcn = std::hash<CVC3::Expr>]' common_theorem_producer.h:60:38: required from here src/include/hash_table.h:319:5: error: use of deleted function 'std::hash<CVC3::Expr>::~hash()' } ^
Notes
Notes: svn path=/head/; revision=433908
Diffstat (limited to 'math/cvc3')
-rw-r--r--math/cvc3/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/math/cvc3/Makefile b/math/cvc3/Makefile
index 9f82bfeb4247..0c3aa290d5ee 100644
--- a/math/cvc3/Makefile
+++ b/math/cvc3/Makefile
@@ -21,6 +21,7 @@ CXXFLAGS+= -fPIC
GNU_CONFIGURE= yes
USES= bison gmake pathfix perl5
PATHFIX_MAKEFILEIN= Makefile
+USE_CXXSTD= gnu++98
USE_GCC= any
USE_LDCONFIG= yes