aboutsummaryrefslogtreecommitdiff
path: root/math/dune-common
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-03-14 22:02:17 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-03-14 22:02:17 +0000
commit4980f9c4dbaa983c7f4ecc7659119a0a1f82c833 (patch)
treebc71e9fe85cb4631676e2f0ddc9942f31d168d5b /math/dune-common
parent38d6eaa8a065eb9c382a2253094e00b02b45bec1 (diff)
downloadports-4980f9c4dbaa983c7f4ecc7659119a0a1f82c833.tar.gz
ports-4980f9c4dbaa983c7f4ecc7659119a0a1f82c833.zip
New port: math/dune-common: DUNE framework: Build system, infrastructure and foundation classes
Notes
Notes: svn path=/head/; revision=528451
Diffstat (limited to 'math/dune-common')
-rw-r--r--math/dune-common/Makefile44
-rw-r--r--math/dune-common/distinfo3
-rw-r--r--math/dune-common/files/patch-CMakeLists.txt12
-rw-r--r--math/dune-common/pkg-descr6
-rw-r--r--math/dune-common/pkg-plist206
5 files changed, 271 insertions, 0 deletions
diff --git a/math/dune-common/Makefile b/math/dune-common/Makefile
new file mode 100644
index 000000000000..fde69e524d02
--- /dev/null
+++ b/math/dune-common/Makefile
@@ -0,0 +1,44 @@
+# $FreeBSD$
+
+PORTNAME= dune-common
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.7.0
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= DUNE framework: Build system, infrastructure and foundation classes
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+BUILD_DEPENDS= openmpi>0:net/openmpi \
+ vc>0:devel/vc
+LIB_DEPENDS= libopenblas.so:math/openblas \
+ libtbb.so:devel/tbb
+
+USES= cmake compiler:c++17-lang fortran pkgconfig python shebangfix
+SHEBANG_FILES= bin/dune-ctest
+USE_GITLAB= yes
+USE_LDCONFIG= yes
+
+GL_ACCOUNT= core
+GL_SITE= https://gitlab.dune-project.org
+GL_ACCOUNT= core
+GL_COMMIT= c5321673af09725a411bdd81aa2be5cfaf8bf9a6
+
+CMAKE_ON= BUILD_SHARED_LIBS
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
+
+DOCS_BUILD_DEPENDS= latex:print/tex-formats
+DOCS_CMAKE_BOOL= FREEBSD_INSTALL_DOCS
+DOCS_BUILD_DEPENDS= doxygen:devel/doxygen \
+ sphinx-build:textproc/py-sphinx
+
+PORTDOCS= *
+
+post-stage-DOCS-on: # https://gitlab.dune-project.org/core/dune-common/issues/191
+ @${RMDIR} ${STAGEDIR}${DOCSDIR}/comm
+
+.include <bsd.port.mk>
diff --git a/math/dune-common/distinfo b/math/dune-common/distinfo
new file mode 100644
index 000000000000..fae8a3469a7e
--- /dev/null
+++ b/math/dune-common/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1584201333
+SHA256 (core-dune-common-c5321673af09725a411bdd81aa2be5cfaf8bf9a6_GL0.tar.gz) = 1154fc0054c0a214fbfff776f10588fe5f4c23efa8c6333574ee0758085990fb
+SIZE (core-dune-common-c5321673af09725a411bdd81aa2be5cfaf8bf9a6_GL0.tar.gz) = 573359
diff --git a/math/dune-common/files/patch-CMakeLists.txt b/math/dune-common/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..29b64ae6dd74
--- /dev/null
+++ b/math/dune-common/files/patch-CMakeLists.txt
@@ -0,0 +1,12 @@
+--- CMakeLists.txt.orig 2020-03-14 17:13:03 UTC
++++ CMakeLists.txt
+@@ -21,7 +21,9 @@ add_subdirectory("lib")
+ add_subdirectory("share")
+ add_subdirectory("dune")
+ add_subdirectory("bin")
++if (FREEBSD_INSTALL_DOCS)
+ add_subdirectory("doc")
++endif()
+ add_subdirectory("cmake/modules")
+ add_subdirectory("cmake/scripts")
+
diff --git a/math/dune-common/pkg-descr b/math/dune-common/pkg-descr
new file mode 100644
index 000000000000..af82bea15b05
--- /dev/null
+++ b/math/dune-common/pkg-descr
@@ -0,0 +1,6 @@
+DUNE, the Distributed and Unified Numerics Environment is a modular toolbox for
+solving partial differential equations (PDEs) with grid-based methods. It
+supports the easy implementation of methods like Finite Elements (FE), Finite
+Volumes (FV), and also Finite Differences (FD).
+
+WWW: https://www.dune-project.org/
diff --git a/math/dune-common/pkg-plist b/math/dune-common/pkg-plist
new file mode 100644
index 000000000000..2cad8a63217c
--- /dev/null
+++ b/math/dune-common/pkg-plist
@@ -0,0 +1,206 @@
+bin/dune-ctest
+bin/dune-git-whitespace-hook
+bin/dunecontrol
+bin/duneproject
+include/dune/common/alignedallocator.hh
+include/dune/common/arraylist.hh
+include/dune/common/assertandreturn.hh
+include/dune/common/bartonnackmanifcheck.hh
+include/dune/common/bigunsignedint.hh
+include/dune/common/binaryfunctions.hh
+include/dune/common/bitsetvector.hh
+include/dune/common/boundschecking.hh
+include/dune/common/classname.hh
+include/dune/common/concept.hh
+include/dune/common/conditional.hh
+include/dune/common/debugalign.hh
+include/dune/common/debugallocator.hh
+include/dune/common/debugstream.hh
+include/dune/common/densematrix.hh
+include/dune/common/densevector.hh
+include/dune/common/deprecated.hh
+include/dune/common/diagonalmatrix.hh
+include/dune/common/documentation.hh
+include/dune/common/dotproduct.hh
+include/dune/common/dynmatrix.hh
+include/dune/common/dynmatrixev.hh
+include/dune/common/dynvector.hh
+include/dune/common/enumset.hh
+include/dune/common/exceptions.hh
+include/dune/common/filledarray.hh
+include/dune/common/float_cmp.cc
+include/dune/common/float_cmp.hh
+include/dune/common/fmatrix.hh
+include/dune/common/fmatrixev.hh
+include/dune/common/ftraits.hh
+include/dune/common/function.hh
+include/dune/common/fvector.hh
+include/dune/common/gcd.hh
+include/dune/common/genericiterator.hh
+include/dune/common/gmpfield.hh
+include/dune/common/hash.hh
+include/dune/common/hybridutilities.hh
+include/dune/common/indent.hh
+include/dune/common/indices.hh
+include/dune/common/interfaces.hh
+include/dune/common/ios_state.hh
+include/dune/common/iteratorfacades.hh
+include/dune/common/iteratorrange.hh
+include/dune/common/keywords.hh
+include/dune/common/lcm.hh
+include/dune/common/lru.hh
+include/dune/common/mallocallocator.hh
+include/dune/common/math.hh
+include/dune/common/matvectraits.hh
+include/dune/common/overloadset.hh
+include/dune/common/parallel/collectivecommunication.hh
+include/dune/common/parallel/communication.hh
+include/dune/common/parallel/communicator.hh
+include/dune/common/parallel/future.hh
+include/dune/common/parallel/indexset.hh
+include/dune/common/parallel/indicessyncer.hh
+include/dune/common/parallel/interface.hh
+include/dune/common/parallel/localindex.hh
+include/dune/common/parallel/mpicollectivecommunication.hh
+include/dune/common/parallel/mpicommunication.hh
+include/dune/common/parallel/mpidata.hh
+include/dune/common/parallel/mpifuture.hh
+include/dune/common/parallel/mpiguard.hh
+include/dune/common/parallel/mpihelper.hh
+include/dune/common/parallel/mpipack.hh
+include/dune/common/parallel/mpitraits.hh
+include/dune/common/parallel/plocalindex.hh
+include/dune/common/parallel/remoteindices.hh
+include/dune/common/parallel/selection.hh
+include/dune/common/parallel/variablesizecommunicator.hh
+include/dune/common/parameterizedobject.hh
+include/dune/common/parametertree.hh
+include/dune/common/parametertreeparser.hh
+include/dune/common/path.hh
+include/dune/common/poolallocator.hh
+include/dune/common/power.hh
+include/dune/common/precision.hh
+include/dune/common/promotiontraits.hh
+include/dune/common/propertymap.hh
+include/dune/common/proxymemberaccess.hh
+include/dune/common/quadmath.hh
+include/dune/common/rangeutilities.hh
+include/dune/common/reservedvector.hh
+include/dune/common/scalarmatrixview.hh
+include/dune/common/scalarvectorview.hh
+include/dune/common/shared_ptr.hh
+include/dune/common/simd.hh
+include/dune/common/simd/base.hh
+include/dune/common/simd/defaults.hh
+include/dune/common/simd/interface.hh
+include/dune/common/simd/io.hh
+include/dune/common/simd/loop.hh
+include/dune/common/simd/simd.hh
+include/dune/common/simd/standard.hh
+include/dune/common/simd/test.hh
+include/dune/common/simd/vc.hh
+include/dune/common/singleton.hh
+include/dune/common/sllist.hh
+include/dune/common/std/apply.hh
+include/dune/common/std/make_array.hh
+include/dune/common/std/memory.hh
+include/dune/common/std/optional.hh
+include/dune/common/std/type_traits.hh
+include/dune/common/std/utility.hh
+include/dune/common/std/variant.hh
+include/dune/common/stdstreams.hh
+include/dune/common/stdthread.hh
+include/dune/common/streamoperators.hh
+include/dune/common/stringutility.hh
+include/dune/common/test/arithmetictestsuite.hh
+include/dune/common/test/checkmatrixinterface.hh
+include/dune/common/test/collectorstream.hh
+include/dune/common/test/iteratortest.hh
+include/dune/common/test/testsuite.hh
+include/dune/common/timer.hh
+include/dune/common/to_unique_ptr.hh
+include/dune/common/tupleutility.hh
+include/dune/common/tuplevector.hh
+include/dune/common/typelist.hh
+include/dune/common/typetraits.hh
+include/dune/common/typeutilities.hh
+include/dune/common/unused.hh
+include/dune/common/vc.hh
+include/dune/common/version.hh
+include/dune/common/visibility.hh
+lib/cmake/dune-common/dune-common-config-version.cmake
+lib/cmake/dune-common/dune-common-config.cmake
+lib/cmake/dune-common/dune-common-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/dune-common/dune-common-targets.cmake
+lib/dunecontrol/dune-common/dune.module
+lib/dunemodules.lib
+lib/libdunecommon.so
+libdata/pkgconfig/dune-common.pc
+%%DOCS%%man/man1/dunecontrol.1.gz
+share/bash-completion/completions/dunecontrol
+%%DATADIR%%/config.h.cmake
+%%DOCS%%%%DATADIR%%/doc/doxygen/Doxystyle
+%%DOCS%%%%DATADIR%%/doc/doxygen/doxygen-macros
+share/dune/cmake/modules/AddGMPFlags.cmake
+share/dune/cmake/modules/AddMETISFlags.cmake
+share/dune/cmake/modules/AddPTScotchFlags.cmake
+share/dune/cmake/modules/AddParMETISFlags.cmake
+share/dune/cmake/modules/AddQuadMathFlags.cmake
+share/dune/cmake/modules/AddSuiteSparseFlags.cmake
+share/dune/cmake/modules/AddUMFPackFlags.cmake
+share/dune/cmake/modules/AddVcFlags.cmake
+share/dune/cmake/modules/CMakeBuiltinFunctionsDocumentation.cmake
+share/dune/cmake/modules/CheckCXXFeatures.cmake
+share/dune/cmake/modules/DuneCMakeCompat.cmake
+share/dune/cmake/modules/DuneCommonMacros.cmake
+share/dune/cmake/modules/DuneCxaDemangle.cmake
+share/dune/cmake/modules/DuneDoc.cmake
+share/dune/cmake/modules/DuneDoxygen.cmake
+share/dune/cmake/modules/DuneEnableAllPackages.cmake
+share/dune/cmake/modules/DuneExecuteProcess.cmake
+share/dune/cmake/modules/DuneInstance.cmake
+share/dune/cmake/modules/DuneMPI.cmake
+share/dune/cmake/modules/DuneMacros.cmake
+share/dune/cmake/modules/DunePathHelper.cmake
+share/dune/cmake/modules/DunePkgConfig.cmake
+share/dune/cmake/modules/DunePythonCommonMacros.cmake
+share/dune/cmake/modules/DunePythonFindPackage.cmake
+share/dune/cmake/modules/DunePythonInstallPackage.cmake
+share/dune/cmake/modules/DunePythonRequireVersion.cmake
+share/dune/cmake/modules/DunePythonTestCommand.cmake
+share/dune/cmake/modules/DunePythonVirtualenv.cmake
+share/dune/cmake/modules/DuneSphinxCMakeDoc.cmake
+share/dune/cmake/modules/DuneStreams.cmake
+share/dune/cmake/modules/DuneSymlinkOrCopy.cmake
+share/dune/cmake/modules/DuneTestMacros.cmake
+share/dune/cmake/modules/FindGMP.cmake
+share/dune/cmake/modules/FindInkscape.cmake
+share/dune/cmake/modules/FindLatexMk.cmake
+share/dune/cmake/modules/FindMETIS.cmake
+share/dune/cmake/modules/FindMProtect.cmake
+share/dune/cmake/modules/FindPTScotch.cmake
+share/dune/cmake/modules/FindParMETIS.cmake
+share/dune/cmake/modules/FindSphinx.cmake
+share/dune/cmake/modules/FindSuiteSparse.cmake
+share/dune/cmake/modules/FindTBB.cmake
+share/dune/cmake/modules/FindUMFPack.cmake
+share/dune/cmake/modules/Headercheck.cmake
+share/dune/cmake/modules/LanguageSupport.cmake
+share/dune/cmake/modules/OverloadCompilerFlags.cmake
+share/dune/cmake/modules/UseInkscape.cmake
+share/dune/cmake/modules/UseLATEX.cmake
+share/dune/cmake/modules/UseLatexMk.cmake
+share/dune/cmake/modules/latexmkrc.cmake
+share/dune/cmake/scripts/CreateDoxyFile.cmake
+share/dune/cmake/scripts/FinalizeHeadercheck.cmake
+share/dune/cmake/scripts/InstallFile.cmake
+share/dune/cmake/scripts/RunDoxygen.cmake
+share/dune/cmake/scripts/conf.py.in
+share/dune/cmake/scripts/envdetect.py
+share/dune/cmake/scripts/extract_cmake_data.py
+share/dune/cmake/scripts/index.rst.in
+share/dune/cmake/scripts/main77.cc.in
+share/dune/cmake/scripts/module_library.cc.in
+share/dune/cmake/scripts/pyversion.py
+share/dune/cmake/scripts/run-in-dune-env.sh.in
+share/dune/cmake/scripts/sphinx_cmake_dune.py