aboutsummaryrefslogtreecommitdiff
path: root/math/dune-foamgrid/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-01-17 07:06:16 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-01-17 07:06:16 +0000
commit88365273b1368593f80dc4f15a77ac2b4719126c (patch)
tree4452aeb6ca6bfc261290d05cb1d8c370ae619a59 /math/dune-foamgrid/Makefile
parentb835409a4d0bc7fbfb3f2b5ab31c5a536e6a0683 (diff)
downloadports-88365273b1368593f80dc4f15a77ac2b4719126c.tar.gz
ports-88365273b1368593f80dc4f15a77ac2b4719126c.zip
New port: math/dune-foamgrid: DUNE framework: one- and two-dimensional simplex grids
Notes
Notes: svn path=/head/; revision=561795
Diffstat (limited to 'math/dune-foamgrid/Makefile')
-rw-r--r--math/dune-foamgrid/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/math/dune-foamgrid/Makefile b/math/dune-foamgrid/Makefile
new file mode 100644
index 000000000000..c3f83450b2a9
--- /dev/null
+++ b/math/dune-foamgrid/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= dune-foamgrid
+DISTVERSION= g20200106
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= DUNE framework: one- and two-dimensional simplex grids
+
+LICENSE= GPLv2+
+
+HPP_DEPENDS= dune-common>0:math/dune-common \
+ dune-geometry>0:math/dune-geometry \
+ dune-grid>0:math/dune-grid
+BUILD_DEPENDS= ${HPP_DEPENDS}
+RUN_DEPENDS= ${HPP_DEPENDS}
+
+USES= cmake compiler:c++17-lang fortran pkgconfig
+USE_GITLAB= yes
+
+GL_SITE= https://gitlab.dune-project.org
+GL_ACCOUNT= extensions
+GL_COMMIT= d49187be4940227c945ced02f8457ccc9d47536a
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
+
+DOCS_CMAKE_BOOL= FREEBSD_INSTALL_DOCS
+DOCS_BUILD_DEPENDS= doxygen:devel/doxygen \
+ sphinx-build:textproc/py-sphinx
+
+PORTDOCS= *
+
+.include <bsd.port.mk>