aboutsummaryrefslogtreecommitdiff
path: root/math/dune-geometry
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-03-14 22:04:54 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-03-14 22:04:54 +0000
commit6adf84d1d97be102542c95788b0e080ca3aec77b (patch)
treefb22674a5cd337cf5b88a337fb190c283150d19b /math/dune-geometry
parent4980f9c4dbaa983c7f4ecc7659119a0a1f82c833 (diff)
downloadports-6adf84d1d97be102542c95788b0e080ca3aec77b.tar.gz
ports-6adf84d1d97be102542c95788b0e080ca3aec77b.zip
New port: math/dune-geometry: DUNE framework: Geometry transformations, reference elements, etc
Notes
Notes: svn path=/head/; revision=528452
Diffstat (limited to 'math/dune-geometry')
-rw-r--r--math/dune-geometry/Makefile40
-rw-r--r--math/dune-geometry/distinfo3
-rw-r--r--math/dune-geometry/files/patch-CMakeLists.txt12
-rw-r--r--math/dune-geometry/pkg-descr8
-rw-r--r--math/dune-geometry/pkg-plist40
5 files changed, 103 insertions, 0 deletions
diff --git a/math/dune-geometry/Makefile b/math/dune-geometry/Makefile
new file mode 100644
index 000000000000..417b383a93d7
--- /dev/null
+++ b/math/dune-geometry/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= dune-geometry
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.7.0
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= DUNE framework: Geometry transformations, reference elements, etc
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+BUILD_DEPENDS= openmpi>0:net/openmpi \
+ vc>0:devel/vc
+LIB_DEPENDS= libdunecommon.so:math/dune-common \
+ libopenblas.so:math/openblas \
+ libtbb.so:devel/tbb
+
+USES= cmake compiler:c++17-lang fortran pkgconfig python
+USE_GITLAB= yes
+USE_LDCONFIG= yes
+
+GL_ACCOUNT= core
+GL_SITE= https://gitlab.dune-project.org
+GL_ACCOUNT= core
+GL_COMMIT= bcf9e469f3c105d5f497dbf81801e8dbd09cde92
+
+CMAKE_ON= BUILD_SHARED_LIBS
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
+
+DOCS_CMAKE_BOOL= FREEBSD_INSTALL_DOCS
+DOCS_BUILD_DEPENDS= doxygen:devel/doxygen \
+ sphinx-build:textproc/py-sphinx
+
+PORTDOCS= *
+
+.include <bsd.port.mk>
diff --git a/math/dune-geometry/distinfo b/math/dune-geometry/distinfo
new file mode 100644
index 000000000000..c08bc50921e2
--- /dev/null
+++ b/math/dune-geometry/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1584206597
+SHA256 (core-dune-geometry-bcf9e469f3c105d5f497dbf81801e8dbd09cde92_GL0.tar.gz) = 170fe7d33bb531d55b9459a557cd3ff3a6207661f546081937a2c6587b2313b5
+SIZE (core-dune-geometry-bcf9e469f3c105d5f497dbf81801e8dbd09cde92_GL0.tar.gz) = 723673
diff --git a/math/dune-geometry/files/patch-CMakeLists.txt b/math/dune-geometry/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..8439fee6fd34
--- /dev/null
+++ b/math/dune-geometry/files/patch-CMakeLists.txt
@@ -0,0 +1,12 @@
+--- CMakeLists.txt.orig 2020-03-14 17:27:33 UTC
++++ CMakeLists.txt
+@@ -21,7 +21,9 @@ include(DuneMacros)
+ dune_project()
+
+ add_subdirectory("dune")
++if (FREEBSD_INSTALL_DOCS)
+ add_subdirectory("doc")
++endif()
+ add_subdirectory("lib")
+
+ # finalize the dune project, e.g. generating config.h etc.
diff --git a/math/dune-geometry/pkg-descr b/math/dune-geometry/pkg-descr
new file mode 100644
index 000000000000..6cf19e78bfd7
--- /dev/null
+++ b/math/dune-geometry/pkg-descr
@@ -0,0 +1,8 @@
+dune-geometry is a module of the DUNE Numerics framework for solving partial
+differential equations (PDEs) with grid-based methods.
+
+dune-geometry includes everything related to the DUNE reference elements. This
+includes the reference elements themselves, mappings on the reference elements
+(geometries), and quadratures.
+
+WWW: https://www.dune-project.org/
diff --git a/math/dune-geometry/pkg-plist b/math/dune-geometry/pkg-plist
new file mode 100644
index 000000000000..0e136e05d7c2
--- /dev/null
+++ b/math/dune-geometry/pkg-plist
@@ -0,0 +1,40 @@
+include/dune/geometry/affinegeometry.hh
+include/dune/geometry/axisalignedcubegeometry.hh
+include/dune/geometry/dimension.hh
+include/dune/geometry/generalvertexorder.hh
+include/dune/geometry/multilineargeometry.hh
+include/dune/geometry/quadraturerules.hh
+include/dune/geometry/quadraturerules/compositequadraturerule.hh
+include/dune/geometry/quadraturerules/gauss_imp.hh
+include/dune/geometry/quadraturerules/gausslobatto_imp.hh
+include/dune/geometry/quadraturerules/jacobi_1_0_imp.hh
+include/dune/geometry/quadraturerules/jacobi_2_0_imp.hh
+include/dune/geometry/quadraturerules/jacobi_n_0.hh
+include/dune/geometry/quadraturerules/pointquadrature.hh
+include/dune/geometry/quadraturerules/simplexquadrature.hh
+include/dune/geometry/quadraturerules/tensorproductquadrature.hh
+include/dune/geometry/referenceelement.hh
+include/dune/geometry/referenceelementimplementation.hh
+include/dune/geometry/referenceelements.hh
+include/dune/geometry/refinement.hh
+include/dune/geometry/refinement/base.cc
+include/dune/geometry/refinement/hcube.cc
+include/dune/geometry/refinement/hcubetriangulation.cc
+include/dune/geometry/refinement/prismtriangulation.cc
+include/dune/geometry/refinement/pyramidtriangulation.cc
+include/dune/geometry/refinement/simplex.cc
+include/dune/geometry/test/checkgeometry.hh
+include/dune/geometry/topologyfactory.hh
+include/dune/geometry/type.hh
+include/dune/geometry/typeindex.hh
+include/dune/geometry/utility/typefromvertexcount.hh
+include/dune/geometry/virtualrefinement.cc
+include/dune/geometry/virtualrefinement.hh
+lib/cmake/dune-geometry/dune-geometry-config-version.cmake
+lib/cmake/dune-geometry/dune-geometry-config.cmake
+lib/cmake/dune-geometry/dune-geometry-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/dune-geometry/dune-geometry-targets.cmake
+lib/dunecontrol/dune-geometry/dune.module
+lib/libdunegeometry.so
+libdata/pkgconfig/dune-geometry.pc
+%%DATADIR%%/config.h.cmake