aboutsummaryrefslogtreecommitdiff
path: root/math/dune-istl
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-01-17 00:30:20 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-01-17 00:30:20 +0000
commitf6e35ec477e67ae665cc95d8686dfa900b437722 (patch)
tree6a925095f118aaaf21afe5a6ecfbf61845d93860 /math/dune-istl
parentd25df6fb91e5f51c7c6935c0fe2c98cf0cd20f8f (diff)
downloadports-f6e35ec477e67ae665cc95d8686dfa900b437722.tar.gz
ports-f6e35ec477e67ae665cc95d8686dfa900b437722.zip
math/dune-istl: Fix math/arpack++ detection im installed cmake files; Add dependencies
Notes
Notes: svn path=/head/; revision=561774
Diffstat (limited to 'math/dune-istl')
-rw-r--r--math/dune-istl/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/math/dune-istl/Makefile b/math/dune-istl/Makefile
index 35e4531bd071..b615f89d5122 100644
--- a/math/dune-istl/Makefile
+++ b/math/dune-istl/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= dune-istl
-DISTVERSIONPREFIX= v
DISTVERSION= 2.7.1
+PORTREVISION= 1
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -11,9 +11,12 @@ COMMENT= DUNE framework: Iterative Solver Template Library
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE.md
-BUILD_DEPENDS= dune-common>0:math/dune-common \
+HPP_DEPENDS= arpack++>0:math/arpack++ \
+ dune-common>0:math/dune-common \
+ suitesparse>0:math/suitesparse # needed in headers, but OPTIONAL dependency set is wider: https://gitlab.dune-project.org/core/dune-istl/-/issues/97
+BUILD_DEPENDS= ${HPP_DEPENDS} \
vc>0:devel/vc
-RUN_DEPENDS= dune-common>0:math/dune-common
+RUN_DEPENDS= ${HPP_DEPENDS}
USES= cmake compiler:c++17-lang fortran pkgconfig
USE_GITLAB= yes
@@ -24,12 +27,15 @@ GL_COMMIT= 761b28aa1deaa786ec55584ace99667545f1b493
NO_ARCH= yes
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS PARMETIS
OPTIONS_SUB= yes
DOCS_CMAKE_BOOL= FREEBSD_INSTALL_DOCS
DOCS_BUILD_DEPENDS= doxygen:devel/doxygen \
- sphinx-build:textproc/py-sphinx
+
+PARMETIS_DESC= Install PerMetis # needed in headers, but license prohibits packaging
+PARMETIS_BUILD_DEPENDS= ParMetis>0:math/parmetis
+PARMETIS_RUN_DEPENDS= ParMetis>0:math/parmetis
PORTDOCS= *