aboutsummaryrefslogtreecommitdiff
path: root/math/dune-vtk
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-01-17 07:20:10 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-01-17 07:20:10 +0000
commit7b5c94026465ab747f7e908e9c59b1e02c35af8f (patch)
tree25d912163e297bf0c5ed7699fda3cb5544912eeb /math/dune-vtk
parent88365273b1368593f80dc4f15a77ac2b4719126c (diff)
downloadports-7b5c94026465ab747f7e908e9c59b1e02c35af8f.tar.gz
ports-7b5c94026465ab747f7e908e9c59b1e02c35af8f.zip
New port: math/dune-vtk: DUNE framework: File reader and writer for the VTK XML format
Notes
Notes: svn path=/head/; revision=561796
Diffstat (limited to 'math/dune-vtk')
-rw-r--r--math/dune-vtk/Makefile52
-rw-r--r--math/dune-vtk/distinfo3
-rw-r--r--math/dune-vtk/files/patch-CMakeLists.txt12
-rw-r--r--math/dune-vtk/pkg-descr6
-rw-r--r--math/dune-vtk/pkg-plist62
5 files changed, 135 insertions, 0 deletions
diff --git a/math/dune-vtk/Makefile b/math/dune-vtk/Makefile
new file mode 100644
index 000000000000..7d94bb929799
--- /dev/null
+++ b/math/dune-vtk/Makefile
@@ -0,0 +1,52 @@
+# $FreeBSD$
+
+PORTNAME= dune-vtk
+DISTVERSION= g20201220
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= DUNE framework: File reader and writer for the VTK XML format
+
+LICENSE= GPLv2+
+
+HPP_DEPENDS= ${LOCALBASE}/include/dune/foamgrid/foamgrid.hh:math/dune-foamgrid \
+ dune-localfunctions>0:math/dune-localfunctions \
+ dune-spgrid>0:math/dune-spgrid
+BUILD_DEPENDS= ${HPP_DEPENDS} \
+ dune-functions>0:math/dune-functions \
+ ${LOCALBASE}/mpi/openmpi/lib/libmpi.so:net/openmpi
+LIB_DEPENDS= libarpack.so:math/arpack-ng \
+ libdunealugrid.so:math/dune-alugrid \
+ libdunecommon.so:math/dune-common \
+ libdunegeometry.so:math/dune-geometry \
+ libdunegrid.so:math/dune-grid \
+ libdunepolygongrid.so:math/dune-polygongrid \
+ libugL.so:math/dune-uggrid \
+ libgmp.so:math/gmp \
+ libmetis.so:math/metis \
+ libopenblas.so:math/openblas \
+ libsuitesparseconfig.so:math/suitesparse \
+ libsuperlu.so:math/superlu \
+ libtbb.so:devel/tbb
+RUN_DEPENDS= ${HPP_DEPENDS} \
+ ${LOCALBASE}/mpi/openmpi/lib/libmpi.so:net/openmpi
+
+USES= cmake compiler:c++17-lang fortran pkgconfig
+USE_GITLAB= yes
+USE_LDCONFIG= yes
+
+GL_SITE= https://gitlab.dune-project.org
+GL_ACCOUNT= extensions
+GL_COMMIT= 847c3e5d0e5ff48ac3aad14adf6218b6578599af
+
+CMAKE_ON= BUILD_SHARED_LIBS
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_CMAKE_BOOL= FREEBSD_INSTALL_DOCS
+DOCS_BUILD_DEPENDS= doxygen:devel/doxygen \
+ sphinx-build:textproc/py-sphinx
+
+PORTDOCS= *
+
+.include <bsd.port.mk>
diff --git a/math/dune-vtk/distinfo b/math/dune-vtk/distinfo
new file mode 100644
index 000000000000..0a2a94db4a0a
--- /dev/null
+++ b/math/dune-vtk/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1610862630
+SHA256 (extensions-dune-vtk-847c3e5d0e5ff48ac3aad14adf6218b6578599af_GL0.tar.gz) = 047a001b9bd736fcee09375cccda28a2a17fbba0dfef9131c2f5e7b7cfaeb339
+SIZE (extensions-dune-vtk-847c3e5d0e5ff48ac3aad14adf6218b6578599af_GL0.tar.gz) = 80978
diff --git a/math/dune-vtk/files/patch-CMakeLists.txt b/math/dune-vtk/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..202ce998cf12
--- /dev/null
+++ b/math/dune-vtk/files/patch-CMakeLists.txt
@@ -0,0 +1,12 @@
+--- CMakeLists.txt.orig 2021-01-17 05:59:47 UTC
++++ CMakeLists.txt
+@@ -24,7 +24,9 @@ dune_enable_all_packages()
+
+ add_subdirectory(src)
+ add_subdirectory(dune)
++if (FREEBSD_INSTALL_DOCS)
+ add_subdirectory(doc)
++endif()
+ add_subdirectory(lib)
+ add_subdirectory(cmake/modules)
+
diff --git a/math/dune-vtk/pkg-descr b/math/dune-vtk/pkg-descr
new file mode 100644
index 000000000000..e7721568cc34
--- /dev/null
+++ b/math/dune-vtk/pkg-descr
@@ -0,0 +1,6 @@
+dune-vtk is a module of the DUNE Numerics framework for solving partial
+differential equations (PDEs) with grid-based methods.
+
+dune-vtk is a file reader and writer for the VTK XML format.
+
+WWW: https://www.dune-project.org/
diff --git a/math/dune-vtk/pkg-plist b/math/dune-vtk/pkg-plist
new file mode 100644
index 000000000000..019d87af312e
--- /dev/null
+++ b/math/dune-vtk/pkg-plist
@@ -0,0 +1,62 @@
+include/dune/vtk/datacollectorinterface.hh
+include/dune/vtk/datacollectorinterface.impl.hh
+include/dune/vtk/datacollectors/continuousdatacollector.hh
+include/dune/vtk/datacollectors/discontinuousdatacollector.hh
+include/dune/vtk/datacollectors/quadraticdatacollector.hh
+include/dune/vtk/datacollectors/spdatacollector.hh
+include/dune/vtk/datacollectors/structureddatacollector.hh
+include/dune/vtk/datacollectors/unstructureddatacollector.hh
+include/dune/vtk/datacollectors/yaspdatacollector.hh
+include/dune/vtk/defaultvtkfunction.hh
+include/dune/vtk/filereader.hh
+include/dune/vtk/filewriter.hh
+include/dune/vtk/function.hh
+include/dune/vtk/gridcreatorinterface.hh
+include/dune/vtk/gridcreators/common.hh
+include/dune/vtk/gridcreators/continuousgridcreator.hh
+include/dune/vtk/gridcreators/derivedgridcreator.hh
+include/dune/vtk/gridcreators/discontinuousgridcreator.hh
+include/dune/vtk/gridcreators/lagrangegridcreator.hh
+include/dune/vtk/gridcreators/parallelgridcreator.hh
+include/dune/vtk/gridcreators/serialgridcreator.hh
+include/dune/vtk/gridfunctions/common.hh
+include/dune/vtk/gridfunctions/continuousgridfunction.hh
+include/dune/vtk/gridfunctions/lagrangegridfunction.hh
+include/dune/vtk/legacyvtkfunction.hh
+include/dune/vtk/localfunction.hh
+include/dune/vtk/localfunctioninterface.hh
+include/dune/vtk/pvdwriter.hh
+include/dune/vtk/pvdwriter.impl.hh
+include/dune/vtk/types.hh
+include/dune/vtk/utility/arguments.hh
+include/dune/vtk/utility/enum.hh
+include/dune/vtk/utility/errors.hh
+include/dune/vtk/utility/filesystem.hh
+include/dune/vtk/utility/lagrangepoints.hh
+include/dune/vtk/utility/lagrangepoints.impl.hh
+include/dune/vtk/utility/string.hh
+include/dune/vtk/utility/uid.hh
+include/dune/vtk/vtkreader.hh
+include/dune/vtk/vtkreader.impl.hh
+include/dune/vtk/vtktimeserieswriter.hh
+include/dune/vtk/vtktimeserieswriter.impl.hh
+include/dune/vtk/vtkwriter.hh
+include/dune/vtk/vtkwriterinterface.hh
+include/dune/vtk/vtkwriterinterface.impl.hh
+include/dune/vtk/writers/vtkimagedatawriter.hh
+include/dune/vtk/writers/vtkimagedatawriter.impl.hh
+include/dune/vtk/writers/vtkrectilineargridwriter.hh
+include/dune/vtk/writers/vtkrectilineargridwriter.impl.hh
+include/dune/vtk/writers/vtkstructuredgridwriter.hh
+include/dune/vtk/writers/vtkstructuredgridwriter.impl.hh
+include/dune/vtk/writers/vtkunstructuredgridwriter.hh
+include/dune/vtk/writers/vtkunstructuredgridwriter.impl.hh
+lib/cmake/dune-vtk/dune-vtk-config-version.cmake
+lib/cmake/dune-vtk/dune-vtk-config.cmake
+lib/cmake/dune-vtk/dune-vtk-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/dune-vtk/dune-vtk-targets.cmake
+lib/dunecontrol/dune-vtk/dune.module
+lib/libdunevtk.so
+libdata/pkgconfig/dune-vtk.pc
+%%DATADIR%%/config.h.cmake
+share/dune/cmake/modules/DuneVtkMacros.cmake