aboutsummaryrefslogtreecommitdiff
path: root/math/eigen3/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2008-02-09 21:59:20 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2008-02-09 21:59:20 +0000
commitb7509990d64703c6e1e458f4a15876b72af85d28 (patch)
treec9141bdff285351ffd077ffe711499056e032882 /math/eigen3/Makefile
parent2818b6fdd244cd021018bbf7fb6a63de6478937b (diff)
downloadports-b7509990d64703c6e1e458f4a15876b72af85d28.tar.gz
ports-b7509990d64703c6e1e458f4a15876b72af85d28.zip
Notes
Diffstat (limited to 'math/eigen3/Makefile')
-rw-r--r--math/eigen3/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/math/eigen3/Makefile b/math/eigen3/Makefile
new file mode 100644
index 000000000000..aa602cac18ba
--- /dev/null
+++ b/math/eigen3/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: eigen
+# Date created: 2008-01-18
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= eigen
+PORTVERSION= 1.0.5
+CATEGORIES= math
+MASTER_SITES= http://download.tuxfamily.org/eigen/
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Lightweight library for vector and matrix math
+
+BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
+
+CMAKE?= ${LOCALBASE}/bin/cmake
+WRKSRC= ${WRKDIR}/${PORTNAME}/build
+MAKE_ENV= VERBOSE="1"
+CMAKE_ARGS= -DCMAKE_BUILD_TYPE=DEBUG \
+ -DCMAKE_INSTALL_PREFIX=${PREFIX} \
+ -DCMAKE_C_COMPILER:STRING='${CC}' \
+ -DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
+ -DCMAKE_CXX_COMPILER:STRING=${CXX} \
+ -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}"
+
+post-patch:
+ ${MKDIR} ${WRKSRC}
+
+do-configure:
+ cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${CMAKE} ${CMAKE_ARGS} ..
+
+.include <bsd.port.mk>