aboutsummaryrefslogtreecommitdiff
path: root/math/eigen3
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-11-25 13:25:55 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-11-25 13:25:55 +0000
commit6dd1205977572de90eb35771ee7a0ba26a9b9191 (patch)
tree631927c69283a545ec44c45d2d3c09010e6e4c2f /math/eigen3
parent3a02a9c2cce1f09976b4b7f0806909076de744de (diff)
downloadports-6dd1205977572de90eb35771ee7a0ba26a9b9191.tar.gz
ports-6dd1205977572de90eb35771ee7a0ba26a9b9191.zip
Update to 3.2.7.
PR: 203814 Submitted by: dieterich.joh@gmail.com, Tobias Berner <tcberner@gmail.com>
Notes
Notes: svn path=/head/; revision=402397
Diffstat (limited to 'math/eigen3')
-rw-r--r--math/eigen3/Makefile5
-rw-r--r--math/eigen3/distinfo4
-rw-r--r--math/eigen3/pkg-plist7
3 files changed, 11 insertions, 5 deletions
diff --git a/math/eigen3/Makefile b/math/eigen3/Makefile
index 47a8fb01c751..dc75304c9d2b 100644
--- a/math/eigen3/Makefile
+++ b/math/eigen3/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= eigen
-PORTVERSION= 3.2.2
-PORTREVISION= 1
+PORTVERSION= 3.2.7
CATEGORIES= math
MASTER_SITES= https://bitbucket.org/${PORTNAME}/${PORTNAME}/get/
DISTNAME= ${PORTVERSION}
@@ -18,6 +17,6 @@ USES= cmake:outsource tar:bzip2
CONFIGURE_ENV+= PKG_CONFIG_LIBDIR="${PREFIX}/libdata"
NO_BUILD= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTNAME}-1306d75b4a21
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTNAME}-b30b87236a1b
.include <bsd.port.mk>
diff --git a/math/eigen3/distinfo b/math/eigen3/distinfo
index ee65870b397b..b141e322584f 100644
--- a/math/eigen3/distinfo
+++ b/math/eigen3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (eigen/3.2.2.tar.bz2) = 929326dcf23a5b9125f898858f2b2b8e4685173c9a5963f86e593791abb621b1
-SIZE (eigen/3.2.2.tar.bz2) = 1142184
+SHA256 (eigen/3.2.7.tar.bz2) = e58e1a11b23cf2754e32b3c5990f318a8461a3613c7acbf6035870daa45c2f3e
+SIZE (eigen/3.2.7.tar.bz2) = 1155162
diff --git a/math/eigen3/pkg-plist b/math/eigen3/pkg-plist
index ae9274b8effb..449189ace50e 100644
--- a/math/eigen3/pkg-plist
+++ b/math/eigen3/pkg-plist
@@ -287,6 +287,7 @@ include/eigen3/Eigen/src/plugins/MatrixCwiseUnaryOps.h
include/eigen3/signature_of_eigen3_matrix_library
include/eigen3/unsupported/Eigen/AdolcForward
include/eigen3/unsupported/Eigen/AlignedVector3
+include/eigen3/unsupported/Eigen/ArpackSupport
include/eigen3/unsupported/Eigen/AutoDiff
include/eigen3/unsupported/Eigen/BVH
include/eigen3/unsupported/Eigen/FFT
@@ -308,6 +309,7 @@ include/eigen3/unsupported/Eigen/src/AutoDiff/AutoDiffScalar.h
include/eigen3/unsupported/Eigen/src/AutoDiff/AutoDiffVector.h
include/eigen3/unsupported/Eigen/src/BVH/BVAlgorithms.h
include/eigen3/unsupported/Eigen/src/BVH/KdBVH.h
+include/eigen3/unsupported/Eigen/src/Eigenvalues/ArpackSelfAdjointEigenSolver.h
include/eigen3/unsupported/Eigen/src/FFT/ei_fftw_impl.h
include/eigen3/unsupported/Eigen/src/FFT/ei_kissfft_impl.h
include/eigen3/unsupported/Eigen/src/IterativeSolvers/ConstrainedConjGrad.h
@@ -319,6 +321,11 @@ include/eigen3/unsupported/Eigen/src/IterativeSolvers/IterationController.h
include/eigen3/unsupported/Eigen/src/IterativeSolvers/MINRES.h
include/eigen3/unsupported/Eigen/src/IterativeSolvers/Scaling.h
include/eigen3/unsupported/Eigen/src/KroneckerProduct/KroneckerTensorProduct.h
+include/eigen3/unsupported/Eigen/src/LevenbergMarquardt/LMcovar.h
+include/eigen3/unsupported/Eigen/src/LevenbergMarquardt/LMonestep.h
+include/eigen3/unsupported/Eigen/src/LevenbergMarquardt/LMpar.h
+include/eigen3/unsupported/Eigen/src/LevenbergMarquardt/LMqrsolv.h
+include/eigen3/unsupported/Eigen/src/LevenbergMarquardt/LevenbergMarquardt.h
include/eigen3/unsupported/Eigen/src/MatrixFunctions/MatrixExponential.h
include/eigen3/unsupported/Eigen/src/MatrixFunctions/MatrixFunction.h
include/eigen3/unsupported/Eigen/src/MatrixFunctions/MatrixFunctionAtomic.h