aboutsummaryrefslogtreecommitdiff
path: root/math/ent
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2013-07-28 20:37:23 +0000
committerJuergen Lock <nox@FreeBSD.org>2013-07-28 20:37:23 +0000
commit66e327d6b8a586326f88ffd96119680e25cd0e14 (patch)
tree00f353e37276f712245f558dbffd7284352f764d /math/ent
parentdf7dc9be0a8e323109cd79059e07b946d56765c9 (diff)
downloadports-66e327d6b8a586326f88ffd96119680e25cd0e14.tar.gz
ports-66e327d6b8a586326f88ffd96119680e25cd0e14.zip
Add new port math/ent:
ent applies various tests to sequences of bytes stored in files and reports the results of those tests. The program is useful for evaluating pseudorandom number generators for encryption and statistical sampling applications, compression algorithms, and other applications where the information density of a file is of interest. WWW: http://www.fourmilab.ch/random/ PR: ports/180899 Submitted by: Horia Racoviceanu <horia@racoviceanu.com>
Notes
Notes: svn path=/head/; revision=323853
Diffstat (limited to 'math/ent')
-rw-r--r--math/ent/Makefile29
-rw-r--r--math/ent/distinfo2
-rw-r--r--math/ent/pkg-descr7
3 files changed, 38 insertions, 0 deletions
diff --git a/math/ent/Makefile b/math/ent/Makefile
new file mode 100644
index 000000000000..853c540c03bb
--- /dev/null
+++ b/math/ent/Makefile
@@ -0,0 +1,29 @@
+# Created by: Horia Racoviceanu <horia@racoviceanu.com>
+# $FreeBSD$
+
+PORTNAME= ent
+PORTVERSION= 0.20080128
+CATEGORIES= math
+MASTER_SITES= http://www.fourmilab.ch/random/
+DISTNAME= random
+DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= horia@racoviceanu.com
+COMMENT= Entropy calculation and analysis of putative random sequences
+
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+ALL_TARGET= ent
+PLIST_FILES= bin/ent
+
+regression-test: build
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check)
+
+post-patch:
+ ${REINPLACE_CMD} -e '/CC = /d' -e '/CFLAGS = /s,$$, ${CFLAGS},' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ent ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/math/ent/distinfo b/math/ent/distinfo
new file mode 100644
index 000000000000..b1eaf2013248
--- /dev/null
+++ b/math/ent/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ent/0.20080128/random.zip) = c14ed62db24511848d6b37d4bf8869185b65be9042ffad5272257f3a249569ec
+SIZE (ent/0.20080128/random.zip) = 76200
diff --git a/math/ent/pkg-descr b/math/ent/pkg-descr
new file mode 100644
index 000000000000..b0f906eafb66
--- /dev/null
+++ b/math/ent/pkg-descr
@@ -0,0 +1,7 @@
+ent applies various tests to sequences of bytes stored in files and reports the
+results of those tests. The program is useful for evaluating pseudorandom
+number generators for encryption and statistical sampling applications,
+compression algorithms, and other applications where the information density of
+a file is of interest.
+
+WWW: http://www.fourmilab.ch/random/