aboutsummaryrefslogtreecommitdiff
path: root/math/eukleides
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2015-11-28 04:24:16 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2015-11-28 04:24:16 +0000
commit1f2d3fe605d36e197794354dd8be5eb5cc138504 (patch)
tree2cb403c437a2b3a4236d31e95983d51b717b7674 /math/eukleides
parent27603e1cd467b375e7e241f9eb5fefcf3f26803b (diff)
downloadports-1f2d3fe605d36e197794354dd8be5eb5cc138504.tar.gz
ports-1f2d3fe605d36e197794354dd8be5eb5cc138504.zip
- Patch euktoeps, so it uses GNU getopt
- Add dependency on misc/getopt Reported by: Nicolas <nh.techn at gmail.com>
Notes
Notes: svn path=/head/; revision=402508
Diffstat (limited to 'math/eukleides')
-rw-r--r--math/eukleides/Makefile5
-rw-r--r--math/eukleides/files/patch-bash_euktoeps11
2 files changed, 14 insertions, 2 deletions
diff --git a/math/eukleides/Makefile b/math/eukleides/Makefile
index 1520726f6b72..15e090726d7e 100644
--- a/math/eukleides/Makefile
+++ b/math/eukleides/Makefile
@@ -3,7 +3,7 @@
PORTNAME= eukleides
PORTVERSION= 1.5.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= http://www.eukleides.org/files/
@@ -14,7 +14,8 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libreadline.so:${PORTSDIR}/devel/readline
-RUN_DEPENDS= pstoedit:${PORTSDIR}/graphics/pstoedit
+RUN_DEPENDS= pstoedit:${PORTSDIR}/graphics/pstoedit \
+ getopt>=0:${PORTSDIR}/misc/getopt
USE_TEX= latex
USES= bison gettext iconv gmake tar:bzip2
diff --git a/math/eukleides/files/patch-bash_euktoeps b/math/eukleides/files/patch-bash_euktoeps
new file mode 100644
index 000000000000..a18cda179805
--- /dev/null
+++ b/math/eukleides/files/patch-bash_euktoeps
@@ -0,0 +1,11 @@
+--- bash/euktoeps.orig
++++ bash/euktoeps
+@@ -31,7 +31,7 @@
+ exit $1
+ }
+
+-args=$(getopt -o i:l::#:d:vh --long include:,locale::,interactive:,data:,version,help \
++args=$(%%LOCALBASE%%/bin/getopt -o i:l::#:d:vh --long include:,locale::,interactive:,data:,version,help \
+ -n 'Euktoeps' -- "$@")
+
+ if [ $? -ne 0 ]