aboutsummaryrefslogtreecommitdiff
path: root/math/eukleides
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-20 13:06:49 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-20 13:06:49 +0000
commit31002feb3c66c1dfcc9a26e1e042e121a542e84b (patch)
tree27bef2fc750e212ea1893f9ac9c2b88410abd663 /math/eukleides
parent4367e9a00cc9eedc3e1af4c6f610546b793d93e8 (diff)
downloadports-31002feb3c66c1dfcc9a26e1e042e121a542e84b.tar.gz
ports-31002feb3c66c1dfcc9a26e1e042e121a542e84b.zip
- Fix LICENSE
- Switch to options helpers - Do not stage unneeded files properly to fix stage-qa: Error: '/bin/bash' is an invalid shebang you need USES=shebangfix for 'bin/euktoeps.orig.bak' Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=409236
Diffstat (limited to 'math/eukleides')
-rw-r--r--math/eukleides/Makefile33
1 files changed, 13 insertions, 20 deletions
diff --git a/math/eukleides/Makefile b/math/eukleides/Makefile
index 15e090726d7e..a0ae03c29e4e 100644
--- a/math/eukleides/Makefile
+++ b/math/eukleides/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://www.eukleides.org/files/
MAINTAINER= ashish@FreeBSD.org
COMMENT= Euclidean geometry drawing language
-LICENSE= GPLv3
+LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libreadline.so:${PORTSDIR}/devel/readline
@@ -21,19 +21,15 @@ USE_TEX= latex
USES= bison gettext iconv gmake tar:bzip2
INSTALL_TARGET= install PREFIX=${STAGEDIR}${PREFIX}
-OPTIONS_DEFINE= DOCS EXAMPLES
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-USES+= makeinfo
-USE_TEX+= pdftex:build
-INFO= eukleides
-.endif
-
PORTDOCS= de.pdf fr.pdf
PORTEXAMPLES= greenwich.euk sundial.euk vonkoch.euk
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+DOCS_USES= makeinfo
+DOCS_USE= TEX=pdftex:build
+DOCS_INFO= eukleides
+
post-patch:
@${GREP} -lR "#!/bin/bash" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|#!/bin/bash|#!/bin/sh|g'
@@ -46,21 +42,18 @@ post-patch:
-e "s|%%DOCSDIR%%|\$${PREFIX}/${DOCSDIR_REL}|g"
@${GREP} -lFR "gcc" ${WRKSRC} |${XARGS} ${REINPLACE_CMD} \
-e "s|gcc|${CC}|g"
-.if ! ${PORT_OPTIONS:MDOCS}
+
+post-patch-DOCS-off:
@${REINPLACE_CMD} -e '/^install:/ s/install_doc//g' \
-e '/^all:/ s/doc//g' ${WRKSRC}/Makefile
-.endif
-.if ! ${PORT_OPTIONS:MEXAMPLES}
+post-patch-EXAMPLES-off:
@${REINPLACE_CMD} -e 's/install_exm$$//g' ${WRKSRC}/Makefile
-.endif
-pre-install:
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+pre-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
post-install:
- for i in euktoeps euktopdf euktotex; do \
- ${RM} ${STAGEDIR}${PREFIX}/bin/$${i}.bak; \
- done
+ @${RM} -f ${STAGEDIR}${PREFIX}/bin/*.bak*
.include <bsd.port.mk>