aboutsummaryrefslogtreecommitdiff
path: root/math/eukleides
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2014-06-22 13:11:17 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2014-06-22 13:11:17 +0000
commitffc72665c6acec839cda4336ee2b0927e2fdc071 (patch)
treec414ded7941a47ea77d83c2037934365be8c5254 /math/eukleides
parent11721bb61fd217cf24f6d2852dfa02cc806ac8e3 (diff)
downloadports-ffc72665c6acec839cda4336ee2b0927e2fdc071.tar.gz
ports-ffc72665c6acec839cda4336ee2b0927e2fdc071.zip
- Update to 1.5.4
- Add LICENSE information - Add STAGE support - Fix building with clang
Notes
Notes: svn path=/head/; revision=358798
Diffstat (limited to 'math/eukleides')
-rw-r--r--math/eukleides/Makefile41
-rw-r--r--math/eukleides/distinfo4
-rw-r--r--math/eukleides/pkg-plist5
3 files changed, 30 insertions, 20 deletions
diff --git a/math/eukleides/Makefile b/math/eukleides/Makefile
index e48be9cf4834..42986ab4d877 100644
--- a/math/eukleides/Makefile
+++ b/math/eukleides/Makefile
@@ -2,24 +2,28 @@
# $FreeBSD$
PORTNAME= eukleides
-PORTVERSION= 1.5.3
-PORTREVISION= 4
+PORTVERSION= 1.5.4
CATEGORIES= math
MASTER_SITES= http://www.eukleides.org/files/
MAINTAINER= ashish@FreeBSD.org
COMMENT= A Euclidean geometry drawing language
-LIB_DEPENDS= readline.6:${PORTSDIR}/devel/readline
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libreadline.so:${PORTSDIR}/devel/readline
RUN_DEPENDS= pstoedit:${PORTSDIR}/graphics/pstoedit
USE_TEX= latex
USES= bison gettext iconv gmake tar:bzip2
-MAN1= eukleides.1 euktoeps.1 euktopdf.1 euktopst.1 euktotex.1
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
-.ifndef NOPORTDOCS
-BUILD_DEPENDS= pdflatex:${PORTSDIR}/print/teTeX-base
+.if ${PORT_OPTIONS:MDOCS}
+USE_TEX+= pdftex:build
PORTDOCS= de.pdf fr.pdf
INFO= eukleides
.endif
@@ -28,34 +32,35 @@ INFO= eukleides
PORTEXAMPLES= greenwich.euk sundial.euk vonkoch.euk
.endif
-NO_STAGE= yes
post-patch:
- ${GREP} -lR "#!/bin/bash" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ @${GREP} -lR "#!/bin/bash" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|#!/bin/bash|#!/bin/sh|g'
- ${GREP} -lR "ginstall-info" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ @${GREP} -lR "ginstall-info" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|ginstall-info|install-info|g'
- ${GREP} -lR "%%[[:alpha:]]\+%%" ${WRKSRC} |${XARGS} ${REINPLACE_CMD} \
- -e "s|%%PREFIX%%|${PREFIX}|g" \
+ @${GREP} -lR "%%[[:alpha:]]\+%%" ${WRKSRC} |${XARGS} ${REINPLACE_CMD} \
+ -e "s|%%PREFIX%%|${STAGEDIR}${PREFIX}|g" \
-e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
- -e "s|%%EXAMPLESDIR%%|${EXAMPLESDIR}|g" \
- -e "s|%%DOCSDIR%%|${DOCSDIR}|g"
-.ifdef NOPORTDOCS
- ${REINPLACE_CMD} -e '/^install:/ s/install_doc//g' \
+ -e "s|%%EXAMPLESDIR%%|${STAGEDIR}${EXAMPLESDIR}|g" \
+ -e "s|%%DOCSDIR%%|${STAGEDIR}${DOCSDIR}|g"
+ @${GREP} -lFR "gcc" ${WRKSRC} |${XARGS} ${REINPLACE_CMD} \
+ -e "s|gcc|${CC}|g"
+.if defined(${PORT_OPTIONS:MDOCS})
+ @${REINPLACE_CMD} -e '/^install:/ s/install_doc//g' \
-e '/^all:/ s/doc//g' ${WRKSRC}/Makefile
.endif
.ifdef NOPORTEXAMPLES
- ${REINPLACE_CMD} -e 's/install_exm$$//g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's/install_exm$$//g' ${WRKSRC}/Makefile
.endif
pre-install:
.ifndef NOPORTEXAMPLES
- ${MKDIR} ${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.endif
post-install:
for i in euktoeps euktopdf euktotex; do \
- ${RM} ${PREFIX}/bin/$${i}.bak; \
+ ${RM} ${STAGEDIR}${PREFIX}/bin/$${i}.bak; \
done
.include <bsd.port.mk>
diff --git a/math/eukleides/distinfo b/math/eukleides/distinfo
index 9095ea317875..5b2ef64538ea 100644
--- a/math/eukleides/distinfo
+++ b/math/eukleides/distinfo
@@ -1,2 +1,2 @@
-SHA256 (eukleides-1.5.3.tar.bz2) = a9c2f08497d3cb48832fb332784fb4f53a0b1e38f98ce44031773873d97ac32c
-SIZE (eukleides-1.5.3.tar.bz2) = 77439
+SHA256 (eukleides-1.5.4.tar.bz2) = 18c489460cb2cb98f4ea9c0187519ef77b4422117fd43bcd4e4836580ef40c69
+SIZE (eukleides-1.5.4.tar.bz2) = 77410
diff --git a/math/eukleides/pkg-plist b/math/eukleides/pkg-plist
index 48da7c32e81e..abd9fbfa0c62 100644
--- a/math/eukleides/pkg-plist
+++ b/math/eukleides/pkg-plist
@@ -7,6 +7,11 @@ share/locale/de/LC_MESSAGES/eukleides.mo
share/locale/fr/LC_MESSAGES/eukleides.mo
share/texmf/tex/latex/eukleides/eukleides.sty
share/texmf/tex/latex/eukleides/eukleides.tex
+man/man1/euktoeps.1.gz
+man/man1/euktopdf.1.gz
+man/man1/euktopst.1.gz
+man/man1/euktotex.1.gz
+man/man1/eukleides.1.gz
@dirrm share/texmf/tex/latex/eukleides
@dirrmtry share/texmf/tex/latex
@dirrmtry share/texmf/tex