aboutsummaryrefslogtreecommitdiff
path: root/math/faiss
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-08-31 01:18:05 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-08-31 01:18:05 +0000
commit50340f51921d548fcf075104f6c5db9abd015f08 (patch)
treee5f0b540a51ba9d91f57cd167253ac5559c1013e /math/faiss
parent4f2b5f1a1d63894ee7d5cd64ad2cf4e3c47d8dc4 (diff)
downloadports-50340f51921d548fcf075104f6c5db9abd015f08.tar.gz
ports-50340f51921d548fcf075104f6c5db9abd015f08.zip
New port: math/faiss: Library for efficient similarity search & clustering of dense vectors
Notes
Notes: svn path=/head/; revision=547139
Diffstat (limited to 'math/faiss')
-rw-r--r--math/faiss/Makefile31
-rw-r--r--math/faiss/distinfo3
-rw-r--r--math/faiss/pkg-descr6
-rw-r--r--math/faiss/pkg-plist62
4 files changed, 102 insertions, 0 deletions
diff --git a/math/faiss/Makefile b/math/faiss/Makefile
new file mode 100644
index 000000000000..208a18213141
--- /dev/null
+++ b/math/faiss/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= faiss
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.6.3-72
+DISTVERSIONSUFFIX= -gc97f890
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library for efficient similarity search & clustering of dense vectors
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libopenblasp-r0.3.9.so:math/openblas
+
+USES= cmake compiler:c++11-lang
+USE_GITHUB= yes
+GH_ACCOUNT= facebookresearch
+USE_LDCONFIG= yes
+
+CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_OFF= FAISS_ENABLE_GPU FAISS_ENABLE_PYTHON
+
+do-test:
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DBUILD_TESTING:BOOL=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
+
+.include <bsd.port.mk>
diff --git a/math/faiss/distinfo b/math/faiss/distinfo
new file mode 100644
index 000000000000..36dc6b70738c
--- /dev/null
+++ b/math/faiss/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1598835056
+SHA256 (facebookresearch-faiss-v1.6.3-72-gc97f890_GH0.tar.gz) = 3eab64e47d8ffc6c5d42da75c1d88898b23034c067eb2225ccc9a4eb27b0c854
+SIZE (facebookresearch-faiss-v1.6.3-72-gc97f890_GH0.tar.gz) = 2752018
diff --git a/math/faiss/pkg-descr b/math/faiss/pkg-descr
new file mode 100644
index 000000000000..6051399b1367
--- /dev/null
+++ b/math/faiss/pkg-descr
@@ -0,0 +1,6 @@
+Faiss is a library for efficient similarity search and clustering of dense
+vectors. It contains algorithms that search in sets of vectors of any size,
+up to ones that possibly do not fit in RAM. It also contains supporting code
+for evaluation and parameter tuning.
+
+WWW: https://github.com/facebookresearch/faiss
diff --git a/math/faiss/pkg-plist b/math/faiss/pkg-plist
new file mode 100644
index 000000000000..fe43e60913e8
--- /dev/null
+++ b/math/faiss/pkg-plist
@@ -0,0 +1,62 @@
+include/faiss/AutoTune.h
+include/faiss/Clustering.h
+include/faiss/DirectMap.h
+include/faiss/IVFlib.h
+include/faiss/Index.h
+include/faiss/Index2Layer.h
+include/faiss/IndexBinary.h
+include/faiss/IndexBinaryFlat.h
+include/faiss/IndexBinaryFromFloat.h
+include/faiss/IndexBinaryHNSW.h
+include/faiss/IndexBinaryHash.h
+include/faiss/IndexBinaryIVF.h
+include/faiss/IndexFlat.h
+include/faiss/IndexHNSW.h
+include/faiss/IndexIVF.h
+include/faiss/IndexIVFFlat.h
+include/faiss/IndexIVFPQ.h
+include/faiss/IndexIVFPQR.h
+include/faiss/IndexIVFSpectralHash.h
+include/faiss/IndexLSH.h
+include/faiss/IndexLattice.h
+include/faiss/IndexPQ.h
+include/faiss/IndexPreTransform.h
+include/faiss/IndexReplicas.h
+include/faiss/IndexScalarQuantizer.h
+include/faiss/IndexShards.h
+include/faiss/InvertedLists.h
+include/faiss/MatrixStats.h
+include/faiss/MetaIndexes.h
+include/faiss/MetricType.h
+include/faiss/OnDiskInvertedLists.h
+include/faiss/VectorTransform.h
+include/faiss/clone_index.h
+include/faiss/impl/AuxIndexStructures.h
+include/faiss/impl/FaissAssert.h
+include/faiss/impl/FaissException.h
+include/faiss/impl/HNSW.h
+include/faiss/impl/PolysemousTraining.h
+include/faiss/impl/ProductQuantizer-inl.h
+include/faiss/impl/ProductQuantizer.h
+include/faiss/impl/ScalarQuantizer.h
+include/faiss/impl/ThreadedIndex-inl.h
+include/faiss/impl/ThreadedIndex.h
+include/faiss/impl/io.h
+include/faiss/impl/io_macros.h
+include/faiss/impl/lattice_Zn.h
+include/faiss/impl/platform_macros.h
+include/faiss/index_factory.h
+include/faiss/index_io.h
+include/faiss/utils/Heap.h
+include/faiss/utils/WorkerThread.h
+include/faiss/utils/distances.h
+include/faiss/utils/extra_distances.h
+include/faiss/utils/hamming-inl.h
+include/faiss/utils/hamming.h
+include/faiss/utils/random.h
+include/faiss/utils/utils.h
+lib/libfaiss.so
+%%DATADIR%%/faiss-config-version.cmake
+%%DATADIR%%/faiss-config.cmake
+%%DATADIR%%/faiss-targets-%%CMAKE_BUILD_TYPE%%.cmake
+%%DATADIR%%/faiss-targets.cmake