aboutsummaryrefslogtreecommitdiff
path: root/math/fftw/Makefile
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-03-18 08:38:33 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-03-18 08:38:33 +0000
commit8d087a6cf09331f49618430b0d609cc79134b723 (patch)
treec8937a66b1fd7a8fbec5282c96ed0d89d9e51325 /math/fftw/Makefile
parent42d57a80e550d99534e6046defa1a5ec5a99df78 (diff)
Notes
Diffstat (limited to 'math/fftw/Makefile')
-rw-r--r--math/fftw/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/math/fftw/Makefile b/math/fftw/Makefile
new file mode 100644
index 000000000000..b6a4bbe64081
--- /dev/null
+++ b/math/fftw/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: fftw
+# Version required: 2.0.1
+# Date created: Dec 28 1998
+# Whom: Lars Koeller <lkoeller@cc.fh-lippe.de>
+#
+# $Id$
+#
+
+DISTNAME= fftw-2.0.1
+CATEGORIES= math
+MASTER_SITES= ftp://theory.lcs.mit.edu/pub/fftw/ \
+ ftp://ftp.uni-bielefeld.de/pub/systems/FreeBSD/lkoeller/
+
+MAINTAINER= Lars.Koeller@Uni-Bielefeled.DE
+
+HAS_CONFIGURE= YES
+
+.include <bsd.port.mk>
+
+.if ${ARCH} == "i386"
+ CONFIGURE_ARGS= --enable-i386-hacks
+.endif
+
+CONFIGURE_ARGS+= --enable-shared
+
+post-install:
+ if [ ! -f ${PREFIX}/info/dir ]; then \
+ ${SED} -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
+ fi
+ .for info in fftw.info
+ install-info ${PREFIX}/info/${info} ${PREFIX}/info/dir
+ .endfor