aboutsummaryrefslogtreecommitdiff
path: root/math/fftw3
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2009-08-25 20:24:09 +0000
committerDiane Bruce <db@FreeBSD.org>2009-08-25 20:24:09 +0000
commit0ba6a0a241d16d086df25c7bf79e66f06b882318 (patch)
tree61c40c3901edaadaaee4b5b8ea874f731035d21a /math/fftw3
parent9569ca1257de548468f9796b5998c0c11f8aee7e (diff)
downloadports-0ba6a0a241d16d086df25c7bf79e66f06b882318.tar.gz
ports-0ba6a0a241d16d086df25c7bf79e66f06b882318.zip
- After digging into the Makefile and configure for fftw3 I discovered
that USE_FORTRAN was only used to determine what name mangling scheme it had to use to compile the shim libs for fortran, but compiling everything using 'C' anyway. With this diff, the slave ports fftw3-long-fortran, fftw3-float-fortran and fftw3-fortran disapear since the shims are always built, without necessitating the use of a USE_FORTRAN. Approved by: ahze (Maintainer)
Notes
Notes: svn path=/head/; revision=240324
Diffstat (limited to 'math/fftw3')
-rw-r--r--math/fftw3/Makefile28
1 files changed, 7 insertions, 21 deletions
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index cf8a6976767a..a351caf02851 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fftw3
PORTVERSION= 3.2.2
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= math
MASTER_SITES= ftp://ftp.fftw.org/pub/fftw/ \
ftp://ftp.fftw.org/pub/fftw/old/
@@ -40,14 +40,6 @@ INSTALL_TARGET= install-pkgconfigDATA install-libLTLIBRARIES install-exec
OPTIONS= OPTIMIZED_CFLAGS "Enable optimized CFLAGS" off
-.if defined(FORTRAN_SHIM)
-USE_FORTRAN= yes
-CONFLICTS= fftw3-3*
-.else
-CONFIGURE_ARGS+= --disable-fortran
-CONFLICTS= fftw3-*fortran-3*
-.endif
-
.include <bsd.port.pre.mk>
.if defined(WITH_OPTIMIZED_CFLAGS)
@@ -76,33 +68,22 @@ CONFIGURE_ENV+= CFLAGS="${CFLAGS_3DNOW}"
.if defined(FFTW3_FLAVOR)
.if ${FFTW3_FLAVOR}=="float"
FFTW3_SUFX= f
-.if defined(FORTRAN_SHIM)
-FFTW3_PKGNAMESUFFIX= -float-fortran
-.else
FFTW3_PKGNAMESUFFIX= -float
-.endif
CONFIGURE_ARGS+=--enable-float
.else
.if ${FFTW3_FLAVOR}=="long"
. if ${OSVERSION} < 800000
-ONLY_FOR_ARCHS= i386 sparc64
+ONLY_FOR_ARCHS= i386 sparc64
LIB_DEPENDS+= ml.0:${PORTSDIR}/math/ldouble
. endif
FFTW3_SUFX= l
-.if defined(FORTRAN_SHIM)
-FFTW3_PKGNAMESUFFIX= -long-fortran
-.else
FFTW3_PKGNAMESUFFIX= -long
-.endif
CONFIGURE_ARGS+=--enable-long-double
.endif
.endif
.endif
.if ${FFTW3_FLAVOR}=="default"
-.if defined(FORTRAN_SHIM)
-FFTW3_PKGNAMESUFFIX= -fortran
-.endif
PLIST_SUB+= DEF=""
.else
PLIST_SUB+= DEF="@comment "
@@ -132,6 +113,11 @@ post-patch:
.endif
.endif
+post-configure:
+ @{ECHO_CMD} "#define F77_FUNC(name,NAME) name ## _" >>${WRKSRC}/config.h
+ @{ECHO_CMD} "#define F77_FUNC_(name,NAME) name ## _" >>${WRKSRC}/config.h
+ @{ECHO_CMD} "#define F77_FUNC_EQUIV 1" >>${WRKSRC}/config.h
+
.if defined(FFTW3_FLAVOR) && ${FFTW3_FLAVOR}!="default"
post-install:
@${INSTALL_MAN} ${WRKSRC}/tools/fftw${FFTW3_SUFX}-wisdom.1 ${PREFIX}/man/man1