aboutsummaryrefslogtreecommitdiff
path: root/math/fftw3
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2013-02-14 12:21:32 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2013-02-14 12:21:32 +0000
commit530576f184491ecb7088df34d9bc33ef3c57bea4 (patch)
tree61e40d21bd3752243cc1cbc5cb9d88222444ae79 /math/fftw3
parent226dfcce0b7ade16ec8914bd9c14195f3e654a3f (diff)
downloadports-530576f184491ecb7088df34d9bc33ef3c57bea4.tar.gz
ports-530576f184491ecb7088df34d9bc33ef3c57bea4.zip
fix WITH_OPENMP on recent -CURRENT built WITH_CLANG_IS_CC [1];
use USE_PKGCONFIG Reported by: A. Shterenlikht, Denis [1]
Notes
Notes: svn path=/head/; revision=312217
Diffstat (limited to 'math/fftw3')
-rw-r--r--math/fftw3/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index bd5f1aede2f4..5b470c798f64 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -1,13 +1,10 @@
-# New ports collection makefile for: fftw
-# Date created: Dec 28 1998
-# Whom: Lars Koeller <Lars.Koeller@Uni-Bielefeld.DE>
-#
+# Created by: Lars Koeller <Lars.Koeller@Uni-Bielefeld.DE>
# $FreeBSD$
# $MCom: ports-experimental/math/fftw3/Makefile,v 1.1 2006/03/28 00:08:57 ahze Exp $
PORTNAME= fftw3
PORTVERSION= 3.3.3
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= math
MASTER_SITES= ftp://ftp.fftw.org/pub/fftw/ \
ftp://ftp.fftw.org/pub/fftw/old/
@@ -22,9 +19,10 @@ FFTW3_FLAVOR?= default
FFTW3_SUFX=
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack pkgconfig
+USE_GNOME= gnomehack
USE_PERL5_BUILD=yes
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
CONFIGURE_ARGS = --enable-shared --enable-threads --disable-fortran
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
@@ -50,12 +48,9 @@ OPTIONS_DEFAULT= OPTIMIZED_CFLAGS
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MOPENMP}
-.if !empty(CC:T:M*clang*)
-IGNORE = : clang does not support OpenMP. Disable the OPENMP option or\
-use another compiler
-.endif
CONFIGURE_ARGS+= --enable-openmp
PLIST_SUB+= OPENMP=""
+USE_GCC= any
.else
CONFIGURE_ARGS+= --disable-openmp
PLIST_SUB+= OPENMP="@comment "