aboutsummaryrefslogtreecommitdiff
path: root/math/flint2
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-30 01:13:14 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-30 01:13:14 +0000
commite39e93bd5e0c447950b299ca1131d65b1570ad7b (patch)
tree31e1fd02814fefc814c0b8334bfbbd3558da6876 /math/flint2
parent6f2ff657efc9a029f02eb43a6b1643aee4b952b9 (diff)
downloadports-e39e93bd5e0c447950b299ca1131d65b1570ad7b.tar.gz
ports-e39e93bd5e0c447950b299ca1131d65b1570ad7b.zip
New port: math/flint2: Fast library for number theory
Notes
Notes: svn path=/head/; revision=465941
Diffstat (limited to 'math/flint2')
-rw-r--r--math/flint2/Makefile30
-rw-r--r--math/flint2/distinfo5
-rw-r--r--math/flint2/pkg-descr11
-rw-r--r--math/flint2/pkg-plist114
4 files changed, 160 insertions, 0 deletions
diff --git a/math/flint2/Makefile b/math/flint2/Makefile
new file mode 100644
index 000000000000..bf29f24baefe
--- /dev/null
+++ b/math/flint2/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= flint2
+DISTVERSION= g20170804
+CATEGORIES= math
+
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES= d900af4ca348b054c0e6b2a6645a54744ec9e74b.patch:-p1 # fix 32-bit failure: https://github.com/fredrik-johansson/flint2/pull/22
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Fast library for number theory
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libgmp.so:math/gmp \
+ libmpfr.so:math/mpfr
+
+USES= gmake
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
+USE_GITHUB= yes
+GH_ACCOUNT= fredrik-johansson
+GH_TAGNAME= 5f2a264
+USE_LDCONFIG= yes
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libflint.so.*
+
+.include <bsd.port.mk>
diff --git a/math/flint2/distinfo b/math/flint2/distinfo
new file mode 100644
index 000000000000..440233aa6c80
--- /dev/null
+++ b/math/flint2/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1522371962
+SHA256 (fredrik-johansson-flint2-g20170804-5f2a264_GH0.tar.gz) = f3400a0342d95f1f705d41a535e9298c7501991383dfeef7bf82edb7ef76bf62
+SIZE (fredrik-johansson-flint2-g20170804-5f2a264_GH0.tar.gz) = 4023335
+SHA256 (d900af4ca348b054c0e6b2a6645a54744ec9e74b.patch) = 2f3f44d274c51ca4e8ca73e4d9ec696d33649934067d5f6f36532985f3138f2a
+SIZE (d900af4ca348b054c0e6b2a6645a54744ec9e74b.patch) = 1190
diff --git a/math/flint2/pkg-descr b/math/flint2/pkg-descr
new file mode 100644
index 000000000000..9e98d5b64e79
--- /dev/null
+++ b/math/flint2/pkg-descr
@@ -0,0 +1,11 @@
+FLINT is a C library for doing number theory, maintained by William Hart.
+
+FLINT supports arithmetic with numbers, polynomials, power series and matrices
+over many base rings, including:
+* Multiprecision integers and rationals
+* Integers modulo n
+* p-adic numbers
+* Finite fields (prime and non-prime order)
+* Real and complex numbers (via the Arb extension library)
+
+WWW: http://www.flintlib.org/
diff --git a/math/flint2/pkg-plist b/math/flint2/pkg-plist
new file mode 100644
index 000000000000..83a30c80cd48
--- /dev/null
+++ b/math/flint2/pkg-plist
@@ -0,0 +1,114 @@
+include/flint/NTL-interface.h
+include/flint/aprcl.h
+include/flint/arith.h
+include/flint/arithxx.h
+include/flint/config.h
+include/flint/d_mat.h
+include/flint/d_vec.h
+include/flint/double_extras.h
+include/flint/exception.h
+include/flint/fft.h
+include/flint/fft_tuning.h
+include/flint/flint.h
+include/flint/flintxx.h
+include/flint/flintxx/default_rules.h
+include/flint/flintxx/evaluation_tools.h
+include/flint/flintxx/expression.h
+include/flint/flintxx/expression_traits.h
+include/flint/flintxx/flint_classes.h
+include/flint/flintxx/flint_exception.h
+include/flint/flintxx/forwarding.h
+include/flint/flintxx/frandxx.h
+include/flint/flintxx/ltuple.h
+include/flint/flintxx/matrix.h
+include/flint/flintxx/mp.h
+include/flint/flintxx/rules.h
+include/flint/flintxx/stdmath.h
+include/flint/flintxx/traits.h
+include/flint/flintxx/traits_fwd.h
+include/flint/flintxx/tuple.h
+include/flint/flintxx/vector.h
+include/flint/fmpq.h
+include/flint/fmpq_mat.h
+include/flint/fmpq_matxx.h
+include/flint/fmpq_poly.h
+include/flint/fmpq_polyxx.h
+include/flint/fmpq_vec.h
+include/flint/fmpqxx.h
+include/flint/fmpz-conversions.h
+include/flint/fmpz.h
+include/flint/fmpz_factor.h
+include/flint/fmpz_factorxx.h
+include/flint/fmpz_lll.h
+include/flint/fmpz_mat.h
+include/flint/fmpz_matxx.h
+include/flint/fmpz_mod_poly.h
+include/flint/fmpz_mod_poly_factor.h
+include/flint/fmpz_mod_poly_factorxx.h
+include/flint/fmpz_mod_polyxx.h
+include/flint/fmpz_mpoly.h
+include/flint/fmpz_poly.h
+include/flint/fmpz_poly_factor.h
+include/flint/fmpz_poly_factorxx.h
+include/flint/fmpz_poly_mat.h
+include/flint/fmpz_poly_matxx.h
+include/flint/fmpz_poly_q.h
+include/flint/fmpz_poly_qxx.h
+include/flint/fmpz_polyxx.h
+include/flint/fmpz_vec.h
+include/flint/fmpz_vecxx.h
+include/flint/fmpzxx.h
+include/flint/fq.h
+include/flint/fq_mat.h
+include/flint/fq_mat_templates.h
+include/flint/fq_nmod.h
+include/flint/fq_nmod_mat.h
+include/flint/fq_nmod_poly.h
+include/flint/fq_nmod_poly_factor.h
+include/flint/fq_nmod_vec.h
+include/flint/fq_poly.h
+include/flint/fq_poly_factor.h
+include/flint/fq_poly_factor_templates.h
+include/flint/fq_poly_templates.h
+include/flint/fq_templates.h
+include/flint/fq_vec.h
+include/flint/fq_vec_templates.h
+include/flint/fq_zech.h
+include/flint/fq_zech_mat.h
+include/flint/fq_zech_poly.h
+include/flint/fq_zech_poly_factor.h
+include/flint/fq_zech_vec.h
+include/flint/gmpcompat.h
+include/flint/hashmap.h
+include/flint/long_extras.h
+include/flint/longlong.h
+include/flint/mpf_mat.h
+include/flint/mpf_vec.h
+include/flint/mpfr_mat.h
+include/flint/mpfr_vec.h
+include/flint/mpn_extras.h
+include/flint/nmod_mat.h
+include/flint/nmod_matxx.h
+include/flint/nmod_poly.h
+include/flint/nmod_poly_factor.h
+include/flint/nmod_poly_mat.h
+include/flint/nmod_poly_matxx.h
+include/flint/nmod_polyxx.h
+include/flint/nmod_vec.h
+include/flint/nmod_vecxx.h
+include/flint/padic.h
+include/flint/padic_mat.h
+include/flint/padic_matxx.h
+include/flint/padic_poly.h
+include/flint/padic_polyxx.h
+include/flint/padicxx.h
+include/flint/perm.h
+include/flint/permxx.h
+include/flint/profiler.h
+include/flint/qadic.h
+include/flint/qadicxx.h
+include/flint/qsieve.h
+include/flint/templates.h
+include/flint/ulong_extras.h
+lib/libflint.so
+lib/libflint.so.13.5.2