aboutsummaryrefslogtreecommitdiff
path: root/math/freefem++
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-02-07 21:22:20 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-02-07 21:22:20 +0000
commit5601a3f83b26c00c6ab275db85c01bffbcbc467f (patch)
tree511dc4d29ecee6add6b575557137ef74593d3ac5 /math/freefem++
parent66d1aa84e24894df9b667bb0503ecc1460d5d67c (diff)
downloadports-5601a3f83b26c00c6ab275db85c01bffbcbc467f.tar.gz
ports-5601a3f83b26c00c6ab275db85c01bffbcbc467f.zip
Notes
Diffstat (limited to 'math/freefem++')
-rw-r--r--math/freefem++/Makefile13
-rw-r--r--math/freefem++/distinfo4
-rw-r--r--math/freefem++/files/patch-configure17
-rw-r--r--math/freefem++/files/patch-src::glx::Makefile.in11
-rw-r--r--math/freefem++/pkg-plist11
5 files changed, 28 insertions, 28 deletions
diff --git a/math/freefem++/Makefile b/math/freefem++/Makefile
index 6c8c8a4e16bd..850e54081253 100644
--- a/math/freefem++/Makefile
+++ b/math/freefem++/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= freefem++
-PORTVERSION= 1.43
+DISTVERSION= 1.45-6
CATEGORIES= math science
MASTER_SITES= ftp://ftp.inria.fr/INRIA/Projects/Gamma/freefem/ \
http://mule.ann.jussieu.fr/~hecht/ftp/freefem/
@@ -14,10 +14,11 @@ MASTER_SITES= ftp://ftp.inria.fr/INRIA/Projects/Gamma/freefem/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= An implementation of a language dedicated to the finite element method
-LIB_DEPENDS= atlas.1:${PORTSDIR}/math/atlas \
- f2c.2:${PORTSDIR}/lang/f2c \
- gsl.6:${PORTSDIR}/math/gsl \
- lapack.3:${PORTSDIR}/math/lapack
+LIB_DEPENDS= atlas.1:${PORTSDIR}/math/atlas \
+ f2c.2:${PORTSDIR}/lang/f2c \
+ gsl.6:${PORTSDIR}/math/gsl \
+ lapack.3:${PORTSDIR}/math/lapack \
+ fltk.1:${PORTSDIR}/x11-toolkits/fltk-threads
BUILD_DEPENDS= ${LOCALBASE}/lib/libumfpack.a:${PORTSDIR}/math/umfpack \
${LOCALBASE}/lib/libarpack.a:${PORTSDIR}/math/arpack \
dvips:${PORTSDIR}/print/dvipsk-tetex \
@@ -44,7 +45,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBBLAS= -lf2c -lf77blas -latlas -lgslcblas
LIBARPACK= -larpack -lalapack ${LIBBLAS}
-DOCS= AUTHORS BUGS COPYING HISTORY README TODO DOC/manual.pdf
+DOCS= AUTHORS BUGS COPYING HISTORY README TODO DOC/manual-full.pdf
BADSAMPLES= load/myfunction.o tutorial/Makefile.in.orig
.include <bsd.port.pre.mk>
diff --git a/math/freefem++/distinfo b/math/freefem++/distinfo
index 6ebc60718a0f..7a63b62547dd 100644
--- a/math/freefem++/distinfo
+++ b/math/freefem++/distinfo
@@ -1,2 +1,2 @@
-MD5 (freefem++-1.43.tar.gz) = 6c1e5be2f2fbf70af458dfb65b821f85
-SIZE (freefem++-1.43.tar.gz) = 11951306
+MD5 (freefem++-1.45-6.tar.gz) = 0b80ff8374e9e4f05cb5921e77af3c79
+SIZE (freefem++-1.45-6.tar.gz) = 8034336
diff --git a/math/freefem++/files/patch-configure b/math/freefem++/files/patch-configure
index 27be8f4203cc..0f1b00d4569a 100644
--- a/math/freefem++/files/patch-configure
+++ b/math/freefem++/files/patch-configure
@@ -1,6 +1,15 @@
---- configure.orig Mon Sep 6 16:00:20 2004
-+++ configure Thu Sep 9 00:14:54 2004
-@@ -7852,7 +7852,7 @@
+--- configure.orig Tue Feb 1 22:24:30 2005
++++ configure Thu Feb 3 22:07:34 2005
+@@ -7137,7 +7137,7 @@
+ # --------------------
+ ff_cadna_ok=no
+ ff_libs_old="$LIBS"
+-ff_ldflag_old="$LDFLAGS"
++ff_ldflags_old="$LDFLAGS"
+ ff_cadna_dir="${curdir}/download/cadna"
+ LDFLAGS="$LDFLAGS -L$ff_cadna_dir"
+ echo "$as_me:$LINENO: checking for arit_zero in -lcadnafree" >&5
+@@ -8137,7 +8137,7 @@
if test "${with_umfpack+set}" = set; then
withval="$with_umfpack"
ff_umfpack_ok=yes
@@ -9,7 +18,7 @@
cat >>confdefs.h <<\_ACEOF
#define HAVE_LIBUMFPACK 1
-@@ -7864,7 +7864,7 @@
+@@ -8149,7 +8149,7 @@
diff --git a/math/freefem++/files/patch-src::glx::Makefile.in b/math/freefem++/files/patch-src::glx::Makefile.in
deleted file mode 100644
index cee802a7f12c..000000000000
--- a/math/freefem++/files/patch-src::glx::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/glx/Makefile.in.orig Thu Oct 28 22:21:57 2004
-+++ src/glx/Makefile.in Thu Oct 28 22:22:07 2004
-@@ -121,7 +121,7 @@
- FreeFem___glx_SOURCES = ../Graphics/xglrgraf.cpp
- FreeFem___glx_DEPENDENCIES = ../fflib/libff.a ../lglib/liblg.a
- LDADD = ../lglib/liblg.a ../fflib/libff.a @UMFPACKLIB@ @ARPACKLIB@ \
-- @BLASLIB@ -lGLU -lGL
-+ @BLASLIB@ -lGLU -lGL -lXext
-
- INCLUDES = -I../fflib
- subdir = src/glx
diff --git a/math/freefem++/pkg-plist b/math/freefem++/pkg-plist
index 1bee11269758..b03083ca16a2 100644
--- a/math/freefem++/pkg-plist
+++ b/math/freefem++/pkg-plist
@@ -1,6 +1,6 @@
bin/FreeFem++
-bin/FreeFem++-glx
-%%MPI%%bin/FreeFem++-mpi
+bin/FreeFem++-cs
+bin/FreeFem++-cs-server
bin/FreeFem++-nw
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/BUGS
@@ -8,7 +8,7 @@ bin/FreeFem++-nw
%%PORTDOCS%%%%DOCSDIR%%/HISTORY
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%%%DOCSDIR%%/manual.pdf
+%%PORTDOCS%%%%DOCSDIR%%/manual-full.pdf
%%PORTDOCS%%%%EXAMPLESDIR%%/D2.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/NSP1P1.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/NSP1P1b.edp
@@ -25,6 +25,7 @@ bin/FreeFem++-nw
%%PORTDOCS%%%%EXAMPLESDIR%%/bilap.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bug/SegmentationFault.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bug/aaa.edp
+%%PORTDOCS%%%%EXAMPLESDIR%%/bug/bug-arg-string.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bug/bugborder.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bug/bugf.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bug/bugv1.18.edp
@@ -98,7 +99,7 @@ bin/FreeFem++-nw
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/freeboundary-weak.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/freeboundary.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/gnuplot.edp
-%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/makeref.edp
+%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/mat_interpol.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/medit.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/mesh.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/movemesh.edp
@@ -115,11 +116,11 @@ bin/FreeFem++-nw
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/schwarz-gc.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/schwarz-no-overlap.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/schwarz-overlap.edp
+%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/shur-comp.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/sparse-cmatrix.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/sparse-matrix.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/sphere.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/tablefunction.edp
-%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/tt.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/xyf
%%PORTDOCS%%%%EXAMPLESDIR%%/wafer-heating-laser-axi.edp
%%PORTDOCS%%@dirrm %%DOCSDIR%%