aboutsummaryrefslogtreecommitdiff
path: root/math/freefem++
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-06-29 21:07:03 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-06-29 21:07:03 +0000
commit73f8ddd93702030e566806c0dfda27aa4e6e871f (patch)
treee72781bdf772a725a1d0d0a5d88724206d9dbeb7 /math/freefem++
parentee6e4281f3dbb17418ae95868ef5a04e6373678f (diff)
downloadports-73f8ddd93702030e566806c0dfda27aa4e6e871f.tar.gz
ports-73f8ddd93702030e566806c0dfda27aa4e6e871f.zip
Notes
Diffstat (limited to 'math/freefem++')
-rw-r--r--math/freefem++/Makefile29
-rw-r--r--math/freefem++/distinfo6
-rw-r--r--math/freefem++/pkg-plist11
3 files changed, 20 insertions, 26 deletions
diff --git a/math/freefem++/Makefile b/math/freefem++/Makefile
index 9eb51c804da9..65990c6fd0c2 100644
--- a/math/freefem++/Makefile
+++ b/math/freefem++/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= freefem++
-PORTVERSION= 2.8
+DISTVERSION= 2.8-1
CATEGORIES= math science
MASTER_SITES= http://www.freefem.org/ff++/ftp/
@@ -44,7 +44,7 @@ CONFIGURE_ARGS= --disable-download \
CONFIGURE_ENV= CPPFLAGS="${MPICFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${MPILDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
-LIBBLAS= -lf2c -lf77blas -latlas -lgslcblas
+LIBBLAS= -lf2c -lf77blas -latlas_r -lgslcblas
LIBARPACK= -larpack -lalapack ${LIBBLAS}
DOC_TARGET= freefem++doc.pdf
@@ -61,20 +61,21 @@ MAKE_ARGS+= "PIC=-fPIC"
CONFIGURE_ARGS+= --disable-optim
.endif
-.if exists(${LOCALBASE}/mpich/bin/mpiCC)
-WITH_MPI= yes
+.if exists(${LOCALBASE}/mpich/mpich/include/mpicxx.h) && !defined(WITHOUT_MPI)
+WITH_MPI= yes # MPICH-2 is required
.endif
-.if defined(WITH_MPI)
-BUILD_DEPENDS+= ${LOCALBASE}/mpich/bin/mpiCC:${PORTSDIR}/net/mpich
-RUN_DEPENDS+= ${LOCALBASE}/mpich/bin/mpiCC:${PORTSDIR}/net/mpich
-MPICFLAGS= -I${LOCALBASE}/mpich/include
-MPILDFLAGS= -L${LOCALBASE}/mpich/lib
-CONFIGURE_ENV+= PATH="$$PATH:${LOCALBASE}/mpich/bin"
-CONFIGURE_ARGS+= --with-mpi=yes
-PLIST_SUB+= MPI=""
-.else
+#.if defined(WITH_MPI)
+#BUILD_DEPENDS+= ${LOCALBASE}/mpich/bin/mpiCC:${PORTSDIR}/net/mpich
+#RUN_DEPENDS+= ${LOCALBASE}/mpich/bin/mpiCC:${PORTSDIR}/net/mpich
+#MPICFLAGS= -I${LOCALBASE}/mpich/include
+#MPILDFLAGS= -L${LOCALBASE}/mpich/lib
+#CONFIGURE_ENV+= PATH="$$PATH:${LOCALBASE}/mpich/bin"
+#CONFIGURE_ARGS+= --with-mpi=yes
+#PLIST_SUB+= MPI=""
+#.else
PLIST_SUB+= MPI="@comment "
-.endif
+CONFIGURE_ARGS+= --without-mpi
+#.endif
pre-configure:
@${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" \
diff --git a/math/freefem++/distinfo b/math/freefem++/distinfo
index b81525476406..755831993a51 100644
--- a/math/freefem++/distinfo
+++ b/math/freefem++/distinfo
@@ -1,3 +1,3 @@
-MD5 (freefem++-2.8.tar.gz) = fc0c3a507988b62ff4288bd43cbd0f04
-SHA256 (freefem++-2.8.tar.gz) = 6820c2c58c95b0d789d74cccda42d199de844278f75f7967d85081466b4509fa
-SIZE (freefem++-2.8.tar.gz) = 10576500
+MD5 (freefem++-2.8-1.tar.gz) = a965fb259b118e2644f07897df537eb7
+SHA256 (freefem++-2.8-1.tar.gz) = 1bc42323e7c9fe9668be3e9e7ab379a2623287d1fd873a95c48606490dbf0526
+SIZE (freefem++-2.8-1.tar.gz) = 10562043
diff --git a/math/freefem++/pkg-plist b/math/freefem++/pkg-plist
index 08f2a01dfe09..e852fba7afdd 100644
--- a/math/freefem++/pkg-plist
+++ b/math/freefem++/pkg-plist
@@ -1,6 +1,7 @@
bin/FreeFem++
bin/FreeFem++-cs
bin/FreeFem++-client
+bin/FreeFem++-glx
bin/FreeFem++-ide
bin/FreeFem++-server
bin/FreeFem++-nw
@@ -20,22 +21,14 @@ bin/FreeFem++-nw
%%PORTDOCS%%%%EXAMPLESDIR%%/all.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/arrayoFVh.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bilap.edp
-%%PORTDOCS%%%%EXAMPLESDIR%%/bug/AAA.edp
-%%PORTDOCS%%%%EXAMPLESDIR%%/bug/NSP1P2.edp
-%%PORTDOCS%%%%EXAMPLESDIR%%/bug/P2b.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bug/SegmentationFault.edp
-%%PORTDOCS%%%%EXAMPLESDIR%%/bug/b.edp
-%%PORTDOCS%%%%EXAMPLESDIR%%/bug/bb.edp
+%%PORTDOCS%%%%EXAMPLESDIR%%/bug/aaa.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bug/bug-arg-string.edp
-%%PORTDOCS%%%%EXAMPLESDIR%%/bug/bug-mesh.edp
-%%PORTDOCS%%%%EXAMPLESDIR%%/bug/bug-toto.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bug/bugborder.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bug/bugf.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bug/bugv1.18.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bug/fe-vect.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bug/func.edp
-%%PORTDOCS%%%%EXAMPLESDIR%%/bug/laptopbig.edp
-%%PORTDOCS%%%%EXAMPLESDIR%%/bug/mesh.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bug/zArithmetic_bug1.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/ccc-adp.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/chapt3/BlackScholes2D.edp