aboutsummaryrefslogtreecommitdiff
path: root/math/freefem++
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2007-06-08 19:27:48 +0000
committerThierry Thomas <thierry@FreeBSD.org>2007-06-08 19:27:48 +0000
commitaae1c12d187c488b4e8ae87b77559dc02cea1b3f (patch)
tree601caefd741d4e22cf50fc7a26eb189d40a6fb2e /math/freefem++
parent94fa79673d07991eba1139969450f60e355f4397 (diff)
downloadports-aae1c12d187c488b4e8ae87b77559dc02cea1b3f.tar.gz
ports-aae1c12d187c488b4e8ae87b77559dc02cea1b3f.zip
- Upgrade to 2.17;
changelog at <http://www.freefem.org/ff++/ftp/INNOVATION> - Fix BLAS detection.
Notes
Notes: svn path=/head/; revision=193059
Diffstat (limited to 'math/freefem++')
-rw-r--r--math/freefem++/Makefile6
-rw-r--r--math/freefem++/distinfo6
-rw-r--r--math/freefem++/pkg-plist14
3 files changed, 20 insertions, 6 deletions
diff --git a/math/freefem++/Makefile b/math/freefem++/Makefile
index 77ed8d04c66b..31952a886bf6 100644
--- a/math/freefem++/Makefile
+++ b/math/freefem++/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= freefem++
-DISTVERSION= 2.16-4
+DISTVERSION= 2.17
CATEGORIES= math science
MASTER_SITES= http://www.freefem.org/ff++/ftp/
@@ -31,6 +31,8 @@ RESTRICTED= No resale or commercial use
WANT_FORTRAN= yes
FC= gfortran42
F77= gfortran42
+FORTRANLIBDIR= `${DIRNAME} \`gfortran42 -print-libgcc-file-name\``
+FORTRANLIBDIR2= `${DIRNAME} \`gfortran42 -print-libgcc-file-name\``/../../../
USE_BISON= yes
USE_GL= yes
USE_GMAKE= yes
@@ -66,7 +68,7 @@ WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS)
LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
-BLAS= -lcblas -lf77blas -latlas
+BLAS= -lcblas -lf77blas -latlas -L${FORTRANLIBDIR} -L${FORTRANLIBDIR2} -lgfortranbegin -lgfortran
LAPACK= -lalapack ${BLAS}
ARPACK= -larpack
.else
diff --git a/math/freefem++/distinfo b/math/freefem++/distinfo
index 7fbacf2a746d..f816874a6acb 100644
--- a/math/freefem++/distinfo
+++ b/math/freefem++/distinfo
@@ -1,3 +1,3 @@
-MD5 (freefem++-2.16-4.tar.gz) = 0ba6184effd20e657685044f4c198695
-SHA256 (freefem++-2.16-4.tar.gz) = fe5fabff54de36c7c85dc8e86ec9ffcab6664d9d6bf71688996408dc5106a2c3
-SIZE (freefem++-2.16-4.tar.gz) = 10573574
+MD5 (freefem++-2.17.tar.gz) = 3d0e789228c7cba75e43cf9ffb6927ed
+SHA256 (freefem++-2.17.tar.gz) = 4d84d9c96d6a6fbf180d91a9c5c905bdd3ffa81f4f5b0f89ce8420e53d33f958
+SIZE (freefem++-2.17.tar.gz) = 10593609
diff --git a/math/freefem++/pkg-plist b/math/freefem++/pkg-plist
index b26384a7cabe..68f236d330b9 100644
--- a/math/freefem++/pkg-plist
+++ b/math/freefem++/pkg-plist
@@ -21,14 +21,24 @@ bin/FreeFem++-nw
%%PORTDOCS%%%%EXAMPLESDIR%%/all.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/arrayoFVh.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bilap.edp
+%%PORTDOCS%%%%EXAMPLESDIR%%/bug/AAA.edp
+%%PORTDOCS%%%%EXAMPLESDIR%%/bug/MassP0.edp
+%%PORTDOCS%%%%EXAMPLESDIR%%/bug/NSP1P2.edp
+%%PORTDOCS%%%%EXAMPLESDIR%%/bug/P2b.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bug/SegmentationFault.edp
-%%PORTDOCS%%%%EXAMPLESDIR%%/bug/aaa.edp
+%%PORTDOCS%%%%EXAMPLESDIR%%/bug/b.edp
+%%PORTDOCS%%%%EXAMPLESDIR%%/bug/bb.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bug/bug-arg-string.edp
+%%PORTDOCS%%%%EXAMPLESDIR%%/bug/bug-mesh.edp
+%%PORTDOCS%%%%EXAMPLESDIR%%/bug/bug-toto.edp
+%%PORTDOCS%%%%EXAMPLESDIR%%/bug/bugRT.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bug/bugborder.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bug/bugf.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bug/bugv1.18.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bug/fe-vect.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bug/func.edp
+%%PORTDOCS%%%%EXAMPLESDIR%%/bug/laptopbig.edp
+%%PORTDOCS%%%%EXAMPLESDIR%%/bug/mesh.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/bug/zArithmetic_bug1.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/ccc-adp.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/chapt3/BlackScholes2D.edp
@@ -62,7 +72,9 @@ bin/FreeFem++-nw
%%PORTDOCS%%%%EXAMPLESDIR%%/eigen/LapnosymEigenValue.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/eigen/Stokes-eigen.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/eigen/all.edp
+%%PORTDOCS%%%%EXAMPLESDIR%%/eigen/bb.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/eigen/neuman.edp
+%%PORTDOCS%%%%EXAMPLESDIR%%/eigen/testeigen.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/funct.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/include.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/lap_mat.edp