aboutsummaryrefslogtreecommitdiff
path: root/math/freefem
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-14 19:08:43 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-14 19:08:43 +0000
commit899357e0ff0472ce1a1dbe36da49b7b9a35eaf98 (patch)
treeba067328c05f812a5e608284f9492994a7f56276 /math/freefem
parentdf688841b952636c84e435107acfa8b49394b73b (diff)
downloadports-899357e0ff0472ce1a1dbe36da49b7b9a35eaf98.tar.gz
ports-899357e0ff0472ce1a1dbe36da49b7b9a35eaf98.zip
Notes
Diffstat (limited to 'math/freefem')
-rw-r--r--math/freefem/Makefile19
-rw-r--r--math/freefem/distinfo6
-rw-r--r--math/freefem/files/patch-admin:ltmain.sh41
-rw-r--r--math/freefem/files/patch-freefem::fem::femParser.cpp14
-rw-r--r--math/freefem/pkg-plist54
5 files changed, 36 insertions, 98 deletions
diff --git a/math/freefem/Makefile b/math/freefem/Makefile
index a914a15141ef..0d9fbe574121 100644
--- a/math/freefem/Makefile
+++ b/math/freefem/Makefile
@@ -6,33 +6,26 @@
#
PORTNAME= freefem
-PORTVERSION= 3.5.7
-PORTREVISION= 1
+PORTVERSION= 3.5.8
CATEGORIES= math science
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= kfem
+MASTER_SITES= SF/kfem
MAINTAINER= ports@FreeBSD.org
COMMENT= A language for the Finite Element Method
+USE_XORG= ice sm x11
+USE_XLIB= yes
+USE_GNOME= gnometarget
USE_AUTOTOOLS= libtool:15
-USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-optimization
USE_LDCONFIG= yes
MAN1= freefem.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-O3 |\$$CXXFLAGS |g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|debian doc freefem|debian freefem|g ; \
+ @${REINPLACE_CMD} -e 's|admin doc freefem|admin freefem|g ; \
s|^install-data-am:|install-data-am: #|g' ${WRKSRC}/Makefile.in
post-install:
diff --git a/math/freefem/distinfo b/math/freefem/distinfo
index dc42a5e70d80..97c1993ff225 100644
--- a/math/freefem/distinfo
+++ b/math/freefem/distinfo
@@ -1,3 +1,3 @@
-MD5 (freefem-3.5.7.tar.gz) = e8f22515ab56f8e79fb789a11f8d4bef
-SHA256 (freefem-3.5.7.tar.gz) = 75a98043459952658287c910e2c7f8796ba657bba77c73c34dd2aa325ed2937e
-SIZE (freefem-3.5.7.tar.gz) = 357270
+MD5 (freefem-3.5.8.tar.gz) = b43d363fc82892d46281f0db60059862
+SHA256 (freefem-3.5.8.tar.gz) = e684ab4af03e23708d8bc86a270be75ce5b760de45ea12be795dedba576641b7
+SIZE (freefem-3.5.8.tar.gz) = 474317
diff --git a/math/freefem/files/patch-admin:ltmain.sh b/math/freefem/files/patch-admin:ltmain.sh
deleted file mode 100644
index 8ec30a2068dc..000000000000
--- a/math/freefem/files/patch-admin:ltmain.sh
+++ /dev/null
@@ -1,41 +0,0 @@
---- admin/ltmain.sh.orig Mon Oct 8 11:27:21 2001
-+++ admin/ltmain.sh Thu Mar 21 13:38:17 2002
-@@ -1043,14 +1043,14 @@
- # These systems don't actually have a C library (as such)
- test "X$arg" = "X-lc" && continue
- ;;
-- *-*-openbsd*)
-+ *-*-openbsd* | *-*-freebsd*)
- # Do not include libc due to us having libc/libc_r.
- test "X$arg" = "X-lc" && continue
- ;;
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd*)
-+ *-*-openbsd* | *-*-freebsd*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -2441,7 +2441,7 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-- *-*-openbsd*)
-+ *-*-openbsd* | *-*-freebsd*)
- # Do not include libc due to us having libc/libc_r.
- ;;
- *)
-@@ -4210,10 +4210,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/math/freefem/files/patch-freefem::fem::femParser.cpp b/math/freefem/files/patch-freefem::fem::femParser.cpp
deleted file mode 100644
index 0beb393bac3b..000000000000
--- a/math/freefem/files/patch-freefem::fem::femParser.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- freefem/fem/femParser.cpp.orig Thu Oct 25 00:49:36 2001
-+++ freefem/fem/femParser.cpp Mon Jul 21 13:32:54 2003
-@@ -2913,7 +2913,10 @@
- for( k =0; k<3*__mesh.getNumberOfCells();k++) (s->name)->table[k] = 0;
- }
- else
-- { (s->name)->table = new creal[__mesh.getNumberOfPoints()];
-+ { // This is in order to avoid an internal compiler error
-+ // with gcc 2.95.4 (FreeBSD)
-+ int n = __mesh.getNumberOfPoints();
-+ (s->name)->table = new creal[n];
- for( k =0; k<__mesh.getNumberOfPoints();k++) (s->name)->table[k] = 0;
- }
- }
diff --git a/math/freefem/pkg-plist b/math/freefem/pkg-plist
index 56a3b2718343..0ce1c06c1242 100644
--- a/math/freefem/pkg-plist
+++ b/math/freefem/pkg-plist
@@ -22,31 +22,31 @@ lib/libfreefem.so.0
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%%%EXAMPLESDIR%%/accous.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/adj.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/brachet.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/condens.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/convectn.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/convhill.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/crack.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/heat.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/holbeam.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/integ.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/lame.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/lamevar.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/multib.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/muonde.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/nacabig.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/nsstep.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/nsstepad.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/shock.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/stokespo.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/timedfm.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/triangle_laplace.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/valicplx.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/validate.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/validcplx.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/validsys.pde
-%%PORTDOCS%%%%EXAMPLESDIR%%/varvect.pde
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/accous.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/adj.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/brachet.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/condens.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/convectn.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/convhill.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/crack.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/heat.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/holbeam.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/integ.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lame.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lamevar.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multib.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/muonde.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nacabig.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nsstep.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nsstepad.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shock.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/stokespo.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/timedfm.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/triangle_laplace.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/valicplx.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/validate.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/validcplx.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/validsys.pde
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/varvect.pde
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%