aboutsummaryrefslogtreecommitdiff
path: root/math/gambit
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-02-26 20:20:10 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-02-26 20:20:10 +0000
commit2f8e8025d30ee0e5fb39844ad7176831e7edb865 (patch)
treeb0e14548f444aa5941a2b7b13917f61a203151f8 /math/gambit
parent7c89dee94e6d67cff533ed84144626b5aa6b40c7 (diff)
downloadports-2f8e8025d30ee0e5fb39844ad7176831e7edb865.tar.gz
ports-2f8e8025d30ee0e5fb39844ad7176831e7edb865.zip
- Fix build on 64 bits platforms
- Adopt maintainship Approved by: miwi (mentor)
Notes
Notes: svn path=/head/; revision=207965
Diffstat (limited to 'math/gambit')
-rw-r--r--math/gambit/Makefile10
-rw-r--r--math/gambit/files/patch-src-tools-enumpoly_pelqhull.cc11
2 files changed, 13 insertions, 8 deletions
diff --git a/math/gambit/Makefile b/math/gambit/Makefile
index ce5241c0a382..e6ba15aa2336 100644
--- a/math/gambit/Makefile
+++ b/math/gambit/Makefile
@@ -11,7 +11,7 @@ PORTVERSION= 0.2007.12.04
CATEGORIES= math
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@FreeBSD.org
COMMENT= A library of tools for doing computation in game theory
USE_GNOME= gnometarget gtk20
@@ -26,13 +26,7 @@ LDFLAGS= ${PTHREAD_LIBS}
CFLAGS+= -O2 -fno-strict-aliasing
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042 && ${ARCH} == "amd64"
-BROKEN= Does not compile
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/test/s|==|=|g' ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/gambit/files/patch-src-tools-enumpoly_pelqhull.cc b/math/gambit/files/patch-src-tools-enumpoly_pelqhull.cc
new file mode 100644
index 000000000000..108bec5100ab
--- /dev/null
+++ b/math/gambit/files/patch-src-tools-enumpoly_pelqhull.cc
@@ -0,0 +1,11 @@
+--- src/tools/enumpoly/pelqhull.cc.orig 2008-02-20 19:44:12.000000000 +0100
++++ src/tools/enumpoly/pelqhull.cc 2008-02-20 19:51:31.000000000 +0100
+@@ -939,7 +939,7 @@
+ else {
+ SETreturnsize_(set, size);
+ fprintf (fp, "%s set=%x maxsize=%d size=%d elems=",
+- string, (unsigned int) set, set->maxsize, size);
++ string, (size_t) set, set->maxsize, size);
+ if (size > (int)set->maxsize)
+ size= set->maxsize+1;
+ for (k=0; k<size; k++)