aboutsummaryrefslogtreecommitdiff
path: root/math/gemmlowp
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-10-05 09:49:39 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-10-05 09:49:39 +0000
commit5bc5c9628785eb06cf4767902b656a013d9c6bf4 (patch)
tree4bfe08dafaa8b03e05f3eed7029a3dec0facac70 /math/gemmlowp
parent69cb9f591ba22219b982015088c083ef8ca5096d (diff)
downloadports-5bc5c9628785eb06cf4767902b656a013d9c6bf4.tar.gz
ports-5bc5c9628785eb06cf4767902b656a013d9c6bf4.zip
New port: math/gemmlowp: Low-precision matrix multiplication library
Notes
Notes: svn path=/head/; revision=513824
Diffstat (limited to 'math/gemmlowp')
-rw-r--r--math/gemmlowp/Makefile26
-rw-r--r--math/gemmlowp/distinfo3
-rw-r--r--math/gemmlowp/pkg-descr4
-rw-r--r--math/gemmlowp/pkg-plist80
4 files changed, 113 insertions, 0 deletions
diff --git a/math/gemmlowp/Makefile b/math/gemmlowp/Makefile
new file mode 100644
index 000000000000..17ebac1250e1
--- /dev/null
+++ b/math/gemmlowp/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= gemmlowp
+DISTVERSION= g20190812
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Low-precision matrix multiplication library
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= google
+GH_TAGNAME= dc69acd
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+do-install:
+.for dir in public fixedpoint eight_bit_int_gemm internal profiling meta
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${STAGEDIR}${PREFIX}/include/${PORTNAME}
+.endfor
+ @${FIND} ${STAGEDIR} -name "*.cc" -delete
+
+.include <bsd.port.mk>
diff --git a/math/gemmlowp/distinfo b/math/gemmlowp/distinfo
new file mode 100644
index 000000000000..aa61291ec410
--- /dev/null
+++ b/math/gemmlowp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1570233373
+SHA256 (google-gemmlowp-g20190812-dc69acd_GH0.tar.gz) = 601015945fe8f80d7f5fe06f6f6ca32aab17bec6fbce1ddec52ccef0dbda06e2
+SIZE (google-gemmlowp-g20190812-dc69acd_GH0.tar.gz) = 838075
diff --git a/math/gemmlowp/pkg-descr b/math/gemmlowp/pkg-descr
new file mode 100644
index 000000000000..d403182f2e9f
--- /dev/null
+++ b/math/gemmlowp/pkg-descr
@@ -0,0 +1,4 @@
+Small, self-contained, headers-only low-precision GEMM (general matrix
+multiplication) library.
+
+WWW: https://github.com/google/gemmlowp
diff --git a/math/gemmlowp/pkg-plist b/math/gemmlowp/pkg-plist
new file mode 100644
index 000000000000..967e539f207d
--- /dev/null
+++ b/math/gemmlowp/pkg-plist
@@ -0,0 +1,80 @@
+include/gemmlowp/eight_bit_int_gemm/eight_bit_int_gemm.h
+include/gemmlowp/fixedpoint/fixedpoint.h
+include/gemmlowp/fixedpoint/fixedpoint_avx.h
+include/gemmlowp/fixedpoint/fixedpoint_msa.h
+include/gemmlowp/fixedpoint/fixedpoint_neon.h
+include/gemmlowp/fixedpoint/fixedpoint_sse.h
+include/gemmlowp/internal/allocator.h
+include/gemmlowp/internal/block_params.h
+include/gemmlowp/internal/common.h
+include/gemmlowp/internal/compute.h
+include/gemmlowp/internal/detect_platform.h
+include/gemmlowp/internal/dispatch_gemm_shape.h
+include/gemmlowp/internal/kernel.h
+include/gemmlowp/internal/kernel_avx.h
+include/gemmlowp/internal/kernel_default.h
+include/gemmlowp/internal/kernel_msa.h
+include/gemmlowp/internal/kernel_neon.h
+include/gemmlowp/internal/kernel_reference.h
+include/gemmlowp/internal/kernel_sse.h
+include/gemmlowp/internal/multi_thread_gemm.h
+include/gemmlowp/internal/output.h
+include/gemmlowp/internal/output_avx.h
+include/gemmlowp/internal/output_msa.h
+include/gemmlowp/internal/output_neon.h
+include/gemmlowp/internal/output_sse.h
+include/gemmlowp/internal/pack.h
+include/gemmlowp/internal/pack_avx.h
+include/gemmlowp/internal/pack_msa.h
+include/gemmlowp/internal/pack_neon.h
+include/gemmlowp/internal/pack_sse.h
+include/gemmlowp/internal/platform.h
+include/gemmlowp/internal/simd_wrappers.h
+include/gemmlowp/internal/simd_wrappers_common_neon_sse.h
+include/gemmlowp/internal/simd_wrappers_msa.h
+include/gemmlowp/internal/simd_wrappers_neon.h
+include/gemmlowp/internal/simd_wrappers_sse.h
+include/gemmlowp/internal/single_thread_gemm.h
+include/gemmlowp/internal/unpack.h
+include/gemmlowp/meta/README
+include/gemmlowp/meta/base.h
+include/gemmlowp/meta/generators/cc_emitter.py
+include/gemmlowp/meta/generators/common.py
+include/gemmlowp/meta/generators/metagemm_generate_headers.sh
+include/gemmlowp/meta/generators/neon_emitter.py
+include/gemmlowp/meta/generators/neon_emitter_64.py
+include/gemmlowp/meta/generators/quantized_mul_kernels_arm_32.py
+include/gemmlowp/meta/generators/quantized_mul_kernels_arm_64.py
+include/gemmlowp/meta/generators/quantized_mul_kernels_common.py
+include/gemmlowp/meta/generators/streams_arm_32.py
+include/gemmlowp/meta/generators/streams_arm_64.py
+include/gemmlowp/meta/generators/streams_common.py
+include/gemmlowp/meta/generators/transform_kernels_arm_32.py
+include/gemmlowp/meta/generators/transform_kernels_arm_64.py
+include/gemmlowp/meta/generators/transform_kernels_common.py
+include/gemmlowp/meta/legacy_multi_thread_common.h
+include/gemmlowp/meta/legacy_multi_thread_gemm.h
+include/gemmlowp/meta/legacy_multi_thread_gemv.h
+include/gemmlowp/meta/legacy_operations_common.h
+include/gemmlowp/meta/legacy_single_thread_gemm.h
+include/gemmlowp/meta/multi_thread_common.h
+include/gemmlowp/meta/multi_thread_gemm.h
+include/gemmlowp/meta/multi_thread_transform.h
+include/gemmlowp/meta/quantized_mul_kernels.h
+include/gemmlowp/meta/quantized_mul_kernels_arm_32.h
+include/gemmlowp/meta/quantized_mul_kernels_arm_64.h
+include/gemmlowp/meta/single_thread_gemm.h
+include/gemmlowp/meta/single_thread_transform.h
+include/gemmlowp/meta/streams.h
+include/gemmlowp/meta/streams_arm_32.h
+include/gemmlowp/meta/streams_arm_64.h
+include/gemmlowp/meta/transform_kernels.h
+include/gemmlowp/meta/transform_kernels_arm_32.h
+include/gemmlowp/meta/transform_kernels_arm_64.h
+include/gemmlowp/profiling/instrumentation.h
+include/gemmlowp/profiling/profiler.h
+include/gemmlowp/profiling/pthread_everywhere.h
+include/gemmlowp/public/bit_depth.h
+include/gemmlowp/public/gemmlowp.h
+include/gemmlowp/public/map.h
+include/gemmlowp/public/output_stages.h