aboutsummaryrefslogtreecommitdiff
path: root/math/gexpr
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:53:03 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:53:03 +0000
commitb185046be2ec03555daaf4f26d38542c403a9955 (patch)
tree0274ce607614533de66837fc1f70d4c35770d9e1 /math/gexpr
parent88d002074007544d532f2495aeb93729291e6275 (diff)
downloadports-b185046be2ec03555daaf4f26d38542c403a9955.tar.gz
ports-b185046be2ec03555daaf4f26d38542c403a9955.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead.
Notes
Notes: svn path=/head/; revision=84842
Diffstat (limited to 'math/gexpr')
-rw-r--r--math/gexpr/Makefile9
-rw-r--r--math/gexpr/files/patch-Makefile8
2 files changed, 8 insertions, 9 deletions
diff --git a/math/gexpr/Makefile b/math/gexpr/Makefile
index 8241d26cc26f..987763b06992 100644
--- a/math/gexpr/Makefile
+++ b/math/gexpr/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gexpr
PORTVERSION= 2.0.2
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= apps/math/calc
@@ -15,13 +16,11 @@ MASTER_SITE_SUBDIR= apps/math/calc
MAINTAINER= ijliao@FreeBSD.org
COMMENT= A shell calculator
-LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
-
+USE_GETOPT_LONG=yes
USE_REINPLACE= yes
+MAKE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
MAN1= gexpr.1
-post-patch:
- @${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile
-
.include <bsd.port.mk>
diff --git a/math/gexpr/files/patch-Makefile b/math/gexpr/files/patch-Makefile
index 54f3d5c71b87..66a75a976db9 100644
--- a/math/gexpr/files/patch-Makefile
+++ b/math/gexpr/files/patch-Makefile
@@ -1,16 +1,16 @@
---- Makefile.orig Thu Jun 14 05:36:02 2001
-+++ Makefile Thu Jun 14 05:39:22 2001
+--- Makefile.orig Sat Feb 13 02:28:35 1999
++++ Makefile Sun Jul 6 20:06:03 2003
@@ -1,11 +1,10 @@
# Makefile for gexpr
# Last updated: 10 February 1999
-CC = gcc
-OPTS = -s -O2 -Wall
-+OPTS = ${CFLAGS} -I%%LOCALBASE%%/include
++OPTS = ${CFLAGS} ${CPPFLAGS}
OBJS = eval.o read_token.o commands.o output.o errors.o gexpr.o
GEXPR = gexpr
-LIBS = -lm
-+LIBS = -lm -L%%LOCALBASE%%/lib -lgnugetopt
++LIBS = -lm ${LDFLAGS}
all: $(GEXPR)