aboutsummaryrefslogtreecommitdiff
path: root/math/gh-bc
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2019-01-28 21:59:41 +0000
committerStefan Eßer <se@FreeBSD.org>2019-01-28 21:59:41 +0000
commitabaea7ff90701f6a1e0ab97287377921729a4b16 (patch)
tree89d29167fbe0b6b97bc7c7ff64d5910567b079a0 /math/gh-bc
parent861e1a991b1f9222e79a18bd77f39f05a9ba8ad3 (diff)
downloadports-abaea7ff90701f6a1e0ab97287377921729a4b16.tar.gz
ports-abaea7ff90701f6a1e0ab97287377921729a4b16.zip
Notes
Diffstat (limited to 'math/gh-bc')
-rw-r--r--math/gh-bc/Makefile34
-rw-r--r--math/gh-bc/distinfo3
-rw-r--r--math/gh-bc/pkg-descr16
3 files changed, 53 insertions, 0 deletions
diff --git a/math/gh-bc/Makefile b/math/gh-bc/Makefile
new file mode 100644
index 000000000000..ed310949e577
--- /dev/null
+++ b/math/gh-bc/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= bc
+PORTVERSION= 1.1.0
+CATEGORIES= math
+PKGNAMEPREFIX= gh-
+
+MAINTAINER= se@FreeBSD.org
+COMMENT= GNU compatible bc/dc calculator
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+USE_GITHUB= yes
+GH_ACCOUNT= gavinhoward
+
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= configure.sh
+CONFIGURE_ARGS= -G
+
+CONFLICTS_INSTALL= bc-[0-9]*
+
+PLIST_FILES= bin/bc bin/dc man/man1/bc.1.gz man/man1/dc.1.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/bc ${STAGEDIR}${PREFIX}/bin/
+ ${LN} ${STAGEDIR}${PREFIX}/bin/bc ${STAGEDIR}${PREFIX}/bin/dc
+ ${INSTALL_MAN} ${WRKSRC}/manuals/bc.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/manuals/dc.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+do-test:
+ ${MAKE} -C ${WRKSRC} test
+
+.include <bsd.port.mk>
diff --git a/math/gh-bc/distinfo b/math/gh-bc/distinfo
new file mode 100644
index 000000000000..984f7028e3b9
--- /dev/null
+++ b/math/gh-bc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1548712045
+SHA256 (gavinhoward-bc-1.1.0_GH0.tar.gz) = 35ed59981aeb0571563bc3445f5948083919d4d834868f361fc4f7dc3c90e998
+SIZE (gavinhoward-bc-1.1.0_GH0.tar.gz) = 160425
diff --git a/math/gh-bc/pkg-descr b/math/gh-bc/pkg-descr
new file mode 100644
index 000000000000..1dbac6280f70
--- /dev/null
+++ b/math/gh-bc/pkg-descr
@@ -0,0 +1,16 @@
+This is an implementation of POSIX bc that implements GNU bc extensions, as
+well as the period (".") extension for the BSD flavor of bc.
+
+bc is an arbitrary precision numeric processing language. Its syntax is
+similar to C but differs in many substantial areas. It supports interactive
+execution of statements. The bc utility is included in the POSIX 1003.1-2008
+standard.
+
+This bc also includes an implementation of dc in the same binary, accessible
+via a symbolic link, which implements all FreeBSD and GNU extensions. If a
+single dc binary is desired, bc can be copied and renamed to dc.
+
+The "!" command is omitted; I believe that it poses security concerns and
+that such functionality is unnecessary.
+
+WWW: https://github.com/gavinhoward/bc