aboutsummaryrefslogtreecommitdiff
path: root/math/giacxcas
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-06-23 07:08:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-06-23 07:08:03 +0000
commit78f9344ae65832bc9bd96d55a973f5d75700c7c2 (patch)
treebe0fe748a6ec8b0260a2d536d0afbd6d958a5321 /math/giacxcas
parentdbb83a10f4914607c83a71a8f74398ac0c1192dd (diff)
downloadports-78f9344ae65832bc9bd96d55a973f5d75700c7c2.tar.gz
ports-78f9344ae65832bc9bd96d55a973f5d75700c7c2.zip
math/giacxcas: Fix build on 13-CURRENT
giacxas expects mallinfo in malloc.h On systems before 13 the detection of malloc.h fails, but on 13 it succeeds but compilation then fails due to a missing mallinfo function. Reported by: thierry, fallout
Notes
Notes: svn path=/head/; revision=539959
Diffstat (limited to 'math/giacxcas')
-rw-r--r--math/giacxcas/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/math/giacxcas/Makefile b/math/giacxcas/Makefile
index 154d675d85c4..9f3c2aedbd52 100644
--- a/math/giacxcas/Makefile
+++ b/math/giacxcas/Makefile
@@ -128,6 +128,9 @@ pre-configure:
--prefix=${FLTKDEV-GIAC} \
CXX="${CXX}" CXXFLAGS="${CXXFLAGS}")
+post-configure: # malloc.h on 13-CURRENT is missing mallinfo and compilation fails after it is discovered
+ @${FIND} ${WRKSRC} -name config.h | ${XARGS} ${REINPLACE_CMD} -e 's|#define HAVE_MALLOC_H 1|/* #undef HAVE_MALLOC_H */|'
+
pre-build:
@cd ${COCOALIB-GIAC} && ${DO_MAKE_BUILD} \
CXXFLAGS_SPECIFIC="${CXXFLAGS}" library