aboutsummaryrefslogtreecommitdiff
path: root/math/glm/pkg-plist
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2017-06-04 15:57:53 +0000
committerKurt Jaeger <pi@FreeBSD.org>2017-06-04 15:57:53 +0000
commitf95cb6b5302a81f08f6dc6cabdc07f6f363c1b78 (patch)
treeb803953972244e5e90099fd5893f6d1b79fa6741 /math/glm/pkg-plist
parent2e7e44b5df46ec7018c5e9c5c5134b06a743912b (diff)
Notes
Diffstat (limited to 'math/glm/pkg-plist')
-rw-r--r--math/glm/pkg-plist51
1 files changed, 31 insertions, 20 deletions
diff --git a/math/glm/pkg-plist b/math/glm/pkg-plist
index 4357fb3813af..1cf2a907e35f 100644
--- a/math/glm/pkg-plist
+++ b/math/glm/pkg-plist
@@ -9,35 +9,29 @@ include/glm/detail/_vectorize.hpp
include/glm/detail/dummy.cpp
include/glm/detail/func_common.hpp
include/glm/detail/func_common.inl
+include/glm/detail/func_common_simd.inl
include/glm/detail/func_exponential.hpp
include/glm/detail/func_exponential.inl
+include/glm/detail/func_exponential_simd.inl
include/glm/detail/func_geometric.hpp
include/glm/detail/func_geometric.inl
+include/glm/detail/func_geometric_simd.inl
include/glm/detail/func_integer.hpp
include/glm/detail/func_integer.inl
+include/glm/detail/func_integer_simd.inl
include/glm/detail/func_matrix.hpp
include/glm/detail/func_matrix.inl
+include/glm/detail/func_matrix_simd.inl
include/glm/detail/func_packing.hpp
include/glm/detail/func_packing.inl
+include/glm/detail/func_packing_simd.inl
include/glm/detail/func_trigonometric.hpp
include/glm/detail/func_trigonometric.inl
+include/glm/detail/func_trigonometric_simd.inl
include/glm/detail/func_vector_relational.hpp
include/glm/detail/func_vector_relational.inl
+include/glm/detail/func_vector_relational_simd.inl
include/glm/detail/glm.cpp
-include/glm/detail/intrinsic_common.hpp
-include/glm/detail/intrinsic_common.inl
-include/glm/detail/intrinsic_exponential.hpp
-include/glm/detail/intrinsic_exponential.inl
-include/glm/detail/intrinsic_geometric.hpp
-include/glm/detail/intrinsic_geometric.inl
-include/glm/detail/intrinsic_integer.hpp
-include/glm/detail/intrinsic_integer.inl
-include/glm/detail/intrinsic_matrix.hpp
-include/glm/detail/intrinsic_matrix.inl
-include/glm/detail/intrinsic_trigonometric.hpp
-include/glm/detail/intrinsic_trigonometric.inl
-include/glm/detail/intrinsic_vector_relational.hpp
-include/glm/detail/intrinsic_vector_relational.inl
include/glm/detail/precision.hpp
include/glm/detail/setup.hpp
include/glm/detail/type_float.hpp
@@ -66,6 +60,7 @@ include/glm/detail/type_mat4x3.hpp
include/glm/detail/type_mat4x3.inl
include/glm/detail/type_mat4x4.hpp
include/glm/detail/type_mat4x4.inl
+include/glm/detail/type_mat4x4_simd.inl
include/glm/detail/type_vec.hpp
include/glm/detail/type_vec.inl
include/glm/detail/type_vec1.hpp
@@ -76,9 +71,7 @@ include/glm/detail/type_vec3.hpp
include/glm/detail/type_vec3.inl
include/glm/detail/type_vec4.hpp
include/glm/detail/type_vec4.inl
-include/glm/detail/type_vec4_avx.inl
-include/glm/detail/type_vec4_avx2.inl
-include/glm/detail/type_vec4_sse2.inl
+include/glm/detail/type_vec4_simd.inl
include/glm/exponential.hpp
include/glm/ext.hpp
include/glm/fwd.hpp
@@ -86,12 +79,15 @@ include/glm/geometric.hpp
include/glm/glm.hpp
include/glm/gtc/bitfield.hpp
include/glm/gtc/bitfield.inl
+include/glm/gtc/color_encoding.inl
include/glm/gtc/color_space.hpp
include/glm/gtc/color_space.inl
include/glm/gtc/constants.hpp
include/glm/gtc/constants.inl
include/glm/gtc/epsilon.hpp
include/glm/gtc/epsilon.inl
+include/glm/gtc/functions.hpp
+include/glm/gtc/functions.inl
include/glm/gtc/integer.hpp
include/glm/gtc/integer.inl
include/glm/gtc/matrix_access.hpp
@@ -107,12 +103,14 @@ include/glm/gtc/packing.hpp
include/glm/gtc/packing.inl
include/glm/gtc/quaternion.hpp
include/glm/gtc/quaternion.inl
+include/glm/gtc/quaternion_simd.inl
include/glm/gtc/random.hpp
include/glm/gtc/random.inl
include/glm/gtc/reciprocal.hpp
include/glm/gtc/reciprocal.inl
include/glm/gtc/round.hpp
include/glm/gtc/round.inl
+include/glm/gtc/type_aligned.hpp
include/glm/gtc/type_precision.hpp
include/glm/gtc/type_precision.inl
include/glm/gtc/type_ptr.hpp
@@ -143,14 +141,15 @@ include/glm/gtx/euler_angles.hpp
include/glm/gtx/euler_angles.inl
include/glm/gtx/extend.hpp
include/glm/gtx/extend.inl
-include/glm/gtx/extented_min_max.hpp
-include/glm/gtx/extented_min_max.inl
+include/glm/gtx/extended_min_max.hpp
+include/glm/gtx/extended_min_max.inl
include/glm/gtx/fast_exponential.hpp
include/glm/gtx/fast_exponential.inl
include/glm/gtx/fast_square_root.hpp
include/glm/gtx/fast_square_root.inl
include/glm/gtx/fast_trigonometry.hpp
include/glm/gtx/fast_trigonometry.inl
+include/glm/gtx/float_notmalize.inl
include/glm/gtx/gradient_paint.hpp
include/glm/gtx/gradient_paint.inl
include/glm/gtx/handed_coordinate_space.hpp
@@ -229,6 +228,8 @@ include/glm/gtx/transform2.hpp
include/glm/gtx/transform2.inl
include/glm/gtx/type_aligned.hpp
include/glm/gtx/type_aligned.inl
+include/glm/gtx/type_trait.hpp
+include/glm/gtx/type_trait.inl
include/glm/gtx/vector_angle.hpp
include/glm/gtx/vector_angle.inl
include/glm/gtx/vector_query.hpp
@@ -247,11 +248,21 @@ include/glm/mat4x3.hpp
include/glm/mat4x4.hpp
include/glm/matrix.hpp
include/glm/packing.hpp
+include/glm/simd/common.h
+include/glm/simd/exponential.h
+include/glm/simd/geometric.h
+include/glm/simd/integer.h
+include/glm/simd/matrix.h
+include/glm/simd/packing.h
+include/glm/simd/platform.h
+include/glm/simd/trigonometric.h
+include/glm/simd/vector_relational.h
include/glm/trigonometric.hpp
include/glm/vec2.hpp
include/glm/vec3.hpp
include/glm/vec4.hpp
include/glm/vector_relational.hpp
lib/cmake/glm/glmConfig.cmake
+lib/cmake/glm/glmConfigVersion.cmake
lib/cmake/glm/glmTargets.cmake
-lib/cmake/glm/glmVersion.cmake
+libdata/pkgconfig/glm.pc