aboutsummaryrefslogtreecommitdiff
path: root/math/glm
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-02-22 10:17:45 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-02-22 10:17:45 +0000
commit9dbc7681f87ffac2b126419c21a979de056eadcf (patch)
tree7604b2ff1651ef369ad0804895f519d99f1e056a /math/glm
parentd09e174e1b0bcda00ccd80ceca85ef5a7617ee48 (diff)
downloadports-9dbc7681f87ffac2b126419c21a979de056eadcf.tar.gz
ports-9dbc7681f87ffac2b126419c21a979de056eadcf.zip
Update to 0.9.7.3.
Release notes: http://glm.g-truc.net/0.9.7/updates.html Add a build-time dependency on devel/cmake instead of installing files by hand. NO_BUILD is still set, but now the port also installs some helper CMake files.
Notes
Notes: svn path=/head/; revision=409329
Diffstat (limited to 'math/glm')
-rw-r--r--math/glm/Makefile9
-rw-r--r--math/glm/distinfo4
-rw-r--r--math/glm/pkg-plist3
3 files changed, 8 insertions, 8 deletions
diff --git a/math/glm/Makefile b/math/glm/Makefile
index a7b714a6ef66..eca9ec72c886 100644
--- a/math/glm/Makefile
+++ b/math/glm/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= glm
-PORTVERSION= 0.9.7.1
+PORTVERSION= 0.9.7.3
PORTEPOCH= 1
CATEGORIES= math graphics
@@ -15,13 +15,10 @@ LICENSE_FILE= ${WRKSRC}/copying.txt
USE_GITHUB= yes
GH_ACCOUNT= g-truc
-USES= dos2unix
-DOS2UNIX_FILES= glm/detail/dummy.cpp
NO_ARCH= yes
NO_BUILD= yes
-do-install:
- cd ${WRKSRC} && ${COPYTREE_SHARE} ${PORTNAME} \
- ${STAGEDIR}${PREFIX}/include '( ! -name *.orig )'
+CMAKE_ARGS= -DGLM_TEST_ENABLE:BOOL=OFF
+USES= cmake:outsource
.include <bsd.port.mk>
diff --git a/math/glm/distinfo b/math/glm/distinfo
index 3cdd7a37118b..8666fc827547 100644
--- a/math/glm/distinfo
+++ b/math/glm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (g-truc-glm-0.9.7.1_GH0.tar.gz) = 285a0dc8f762b4e523c8710fbd97accaace0c61f45bc8be2bdb0deed07b0e6f3
-SIZE (g-truc-glm-0.9.7.1_GH0.tar.gz) = 3453078
+SHA256 (g-truc-glm-0.9.7.3_GH0.tar.gz) = 24f286a3cba59c64d1bdf3fe30125eb76f824fe195a0a29964c29d4d520ff392
+SIZE (g-truc-glm-0.9.7.3_GH0.tar.gz) = 3454231
diff --git a/math/glm/pkg-plist b/math/glm/pkg-plist
index 5b22b9d1314c..4357fb3813af 100644
--- a/math/glm/pkg-plist
+++ b/math/glm/pkg-plist
@@ -252,3 +252,6 @@ include/glm/vec2.hpp
include/glm/vec3.hpp
include/glm/vec4.hpp
include/glm/vector_relational.hpp
+lib/cmake/glm/glmConfig.cmake
+lib/cmake/glm/glmTargets.cmake
+lib/cmake/glm/glmVersion.cmake