aboutsummaryrefslogtreecommitdiff
path: root/math/glm
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2013-12-26 18:45:50 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2013-12-26 18:45:50 +0000
commitf162cce54315a060dbd1a67fb018b053b70d9408 (patch)
treea83395fb0aa8f206a62d45f19be6f7b818602228 /math/glm
parent78d73e15d6af2db1e0463ae6f1cf0251f84bc19a (diff)
downloadports-f162cce54315a060dbd1a67fb018b053b70d9408.tar.gz
ports-f162cce54315a060dbd1a67fb018b053b70d9408.zip
Update to version 0.9.5.0.
Notes
Notes: svn path=/head/; revision=337596
Diffstat (limited to 'math/glm')
-rw-r--r--math/glm/Makefile2
-rw-r--r--math/glm/distinfo4
-rw-r--r--math/glm/pkg-plist204
3 files changed, 118 insertions, 92 deletions
diff --git a/math/glm/Makefile b/math/glm/Makefile
index 6e9c069d64e1..5c33502e107e 100644
--- a/math/glm/Makefile
+++ b/math/glm/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= glm
-PORTVERSION= 0.9.4.6
+PORTVERSION= 0.9.5.0
CATEGORIES= math graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ogl-math/${PORTNAME}-${PORTVERSION}
diff --git a/math/glm/distinfo b/math/glm/distinfo
index d3f6008c5623..0dd82d5ea059 100644
--- a/math/glm/distinfo
+++ b/math/glm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (glm-0.9.4.6.zip) = 947364c18cfe4b61ddad2f9656127d9176ee65dd1d10a9d79b2c65c709542022
-SIZE (glm-0.9.4.6.zip) = 5179610
+SHA256 (glm-0.9.5.0.zip) = 0af853ec4cb6c237a227e99c0762f161a23cb192e080d8ab97f9a09fee2df3da
+SIZE (glm-0.9.5.0.zip) = 4061048
diff --git a/math/glm/pkg-plist b/math/glm/pkg-plist
index 7836794a9de7..1d2476f8b777 100644
--- a/math/glm/pkg-plist
+++ b/math/glm/pkg-plist
@@ -1,88 +1,95 @@
include/glm/CMakeLists.txt
-include/glm/core/_detail.hpp
-include/glm/core/_fixes.hpp
-include/glm/core/_swizzle.hpp
-include/glm/core/_swizzle_func.hpp
-include/glm/core/_vectorize.hpp
-include/glm/core/dummy.cpp
-include/glm/core/func_common.hpp
-include/glm/core/func_common.inl
-include/glm/core/func_exponential.hpp
-include/glm/core/func_exponential.inl
-include/glm/core/func_geometric.hpp
-include/glm/core/func_geometric.inl
-include/glm/core/func_integer.hpp
-include/glm/core/func_integer.inl
-include/glm/core/func_matrix.hpp
-include/glm/core/func_matrix.inl
-include/glm/core/func_noise.hpp
-include/glm/core/func_noise.inl
-include/glm/core/func_packing.hpp
-include/glm/core/func_packing.inl
-include/glm/core/func_trigonometric.hpp
-include/glm/core/func_trigonometric.inl
-include/glm/core/func_vector_relational.hpp
-include/glm/core/func_vector_relational.inl
-include/glm/core/hint.hpp
-include/glm/core/intrinsic_common.hpp
-include/glm/core/intrinsic_common.inl
-include/glm/core/intrinsic_exponential.hpp
-include/glm/core/intrinsic_exponential.inl
-include/glm/core/intrinsic_geometric.hpp
-include/glm/core/intrinsic_geometric.inl
-include/glm/core/intrinsic_matrix.hpp
-include/glm/core/intrinsic_matrix.inl
-include/glm/core/intrinsic_trigonometric.hpp
-include/glm/core/intrinsic_trigonometric.inl
-include/glm/core/intrinsic_vector_relational.hpp
-include/glm/core/intrinsic_vector_relational.inl
-include/glm/core/setup.hpp
-include/glm/core/type.hpp
-include/glm/core/type_float.hpp
-include/glm/core/type_gentype.hpp
-include/glm/core/type_gentype.inl
-include/glm/core/type_half.hpp
-include/glm/core/type_half.inl
-include/glm/core/type_int.hpp
-include/glm/core/type_mat.hpp
-include/glm/core/type_mat.inl
-include/glm/core/type_mat2x2.hpp
-include/glm/core/type_mat2x2.inl
-include/glm/core/type_mat2x3.hpp
-include/glm/core/type_mat2x3.inl
-include/glm/core/type_mat2x4.hpp
-include/glm/core/type_mat2x4.inl
-include/glm/core/type_mat3x2.hpp
-include/glm/core/type_mat3x2.inl
-include/glm/core/type_mat3x3.hpp
-include/glm/core/type_mat3x3.inl
-include/glm/core/type_mat3x4.hpp
-include/glm/core/type_mat3x4.inl
-include/glm/core/type_mat4x2.hpp
-include/glm/core/type_mat4x2.inl
-include/glm/core/type_mat4x3.hpp
-include/glm/core/type_mat4x3.inl
-include/glm/core/type_mat4x4.hpp
-include/glm/core/type_mat4x4.inl
-include/glm/core/type_size.hpp
-include/glm/core/type_vec.hpp
-include/glm/core/type_vec.inl
-include/glm/core/type_vec1.hpp
-include/glm/core/type_vec1.inl
-include/glm/core/type_vec2.hpp
-include/glm/core/type_vec2.inl
-include/glm/core/type_vec3.hpp
-include/glm/core/type_vec3.inl
-include/glm/core/type_vec4.hpp
-include/glm/core/type_vec4.inl
+include/glm/common.hpp
+include/glm/detail/_features.hpp
+include/glm/detail/_fixes.hpp
+include/glm/detail/_literals.hpp
+include/glm/detail/_noise.hpp
+include/glm/detail/_swizzle.hpp
+include/glm/detail/_swizzle_func.hpp
+include/glm/detail/_vectorize.hpp
+include/glm/detail/dummy.cpp
+include/glm/detail/func_common.hpp
+include/glm/detail/func_common.inl
+include/glm/detail/func_exponential.hpp
+include/glm/detail/func_exponential.inl
+include/glm/detail/func_geometric.hpp
+include/glm/detail/func_geometric.inl
+include/glm/detail/func_integer.hpp
+include/glm/detail/func_integer.inl
+include/glm/detail/func_matrix.hpp
+include/glm/detail/func_matrix.inl
+include/glm/detail/func_noise.hpp
+include/glm/detail/func_noise.inl
+include/glm/detail/func_packing.hpp
+include/glm/detail/func_packing.inl
+include/glm/detail/func_trigonometric.hpp
+include/glm/detail/func_trigonometric.inl
+include/glm/detail/func_vector_relational.hpp
+include/glm/detail/func_vector_relational.inl
+include/glm/detail/glm.cpp
+include/glm/detail/hint.hpp
+include/glm/detail/intrinsic_common.hpp
+include/glm/detail/intrinsic_common.inl
+include/glm/detail/intrinsic_exponential.hpp
+include/glm/detail/intrinsic_exponential.inl
+include/glm/detail/intrinsic_geometric.hpp
+include/glm/detail/intrinsic_geometric.inl
+include/glm/detail/intrinsic_integer.hpp
+include/glm/detail/intrinsic_integer.inl
+include/glm/detail/intrinsic_matrix.hpp
+include/glm/detail/intrinsic_matrix.inl
+include/glm/detail/intrinsic_trigonometric.hpp
+include/glm/detail/intrinsic_trigonometric.inl
+include/glm/detail/intrinsic_vector_relational.hpp
+include/glm/detail/intrinsic_vector_relational.inl
+include/glm/detail/precision.hpp
+include/glm/detail/precision.inl
+include/glm/detail/setup.hpp
+include/glm/detail/type_float.hpp
+include/glm/detail/type_gentype.hpp
+include/glm/detail/type_gentype.inl
+include/glm/detail/type_half.hpp
+include/glm/detail/type_half.inl
+include/glm/detail/type_int.hpp
+include/glm/detail/type_mat.hpp
+include/glm/detail/type_mat.inl
+include/glm/detail/type_mat2x2.hpp
+include/glm/detail/type_mat2x2.inl
+include/glm/detail/type_mat2x3.hpp
+include/glm/detail/type_mat2x3.inl
+include/glm/detail/type_mat2x4.hpp
+include/glm/detail/type_mat2x4.inl
+include/glm/detail/type_mat3x2.hpp
+include/glm/detail/type_mat3x2.inl
+include/glm/detail/type_mat3x3.hpp
+include/glm/detail/type_mat3x3.inl
+include/glm/detail/type_mat3x4.hpp
+include/glm/detail/type_mat3x4.inl
+include/glm/detail/type_mat4x2.hpp
+include/glm/detail/type_mat4x2.inl
+include/glm/detail/type_mat4x3.hpp
+include/glm/detail/type_mat4x3.inl
+include/glm/detail/type_mat4x4.hpp
+include/glm/detail/type_mat4x4.inl
+include/glm/detail/type_vec.hpp
+include/glm/detail/type_vec.inl
+include/glm/detail/type_vec1.hpp
+include/glm/detail/type_vec1.inl
+include/glm/detail/type_vec2.hpp
+include/glm/detail/type_vec2.inl
+include/glm/detail/type_vec3.hpp
+include/glm/detail/type_vec3.inl
+include/glm/detail/type_vec4.hpp
+include/glm/detail/type_vec4.inl
+include/glm/exponential.hpp
include/glm/ext.hpp
+include/glm/fwd.hpp
+include/glm/geometric.hpp
include/glm/glm.hpp
include/glm/gtc/constants.hpp
include/glm/gtc/constants.inl
include/glm/gtc/epsilon.hpp
include/glm/gtc/epsilon.inl
-include/glm/gtc/half_float.hpp
-include/glm/gtc/half_float.inl
include/glm/gtc/matrix_access.hpp
include/glm/gtc/matrix_access.inl
include/glm/gtc/matrix_integer.hpp
@@ -92,14 +99,14 @@ include/glm/gtc/matrix_transform.hpp
include/glm/gtc/matrix_transform.inl
include/glm/gtc/noise.hpp
include/glm/gtc/noise.inl
+include/glm/gtc/packing.hpp
+include/glm/gtc/packing.inl
include/glm/gtc/quaternion.hpp
include/glm/gtc/quaternion.inl
include/glm/gtc/random.hpp
include/glm/gtc/random.inl
include/glm/gtc/reciprocal.hpp
include/glm/gtc/reciprocal.inl
-include/glm/gtc/swizzle.hpp
-include/glm/gtc/swizzle.inl
include/glm/gtc/type_precision.hpp
include/glm/gtc/type_precision.inl
include/glm/gtc/type_ptr.hpp
@@ -112,8 +119,6 @@ include/glm/gtx/bit.hpp
include/glm/gtx/bit.inl
include/glm/gtx/closest_point.hpp
include/glm/gtx/closest_point.inl
-include/glm/gtx/color_cast.hpp
-include/glm/gtx/color_cast.inl
include/glm/gtx/color_space.hpp
include/glm/gtx/color_space.inl
include/glm/gtx/color_space_YCoCg.hpp
@@ -123,6 +128,8 @@ include/glm/gtx/compatibility.inl
include/glm/gtx/component_wise.hpp
include/glm/gtx/component_wise.inl
include/glm/gtx/constants.hpp
+include/glm/gtx/dual_quaternion.hpp
+include/glm/gtx/dual_quaternion.inl
include/glm/gtx/epsilon.hpp
include/glm/gtx/euler_angles.hpp
include/glm/gtx/euler_angles.inl
@@ -148,6 +155,8 @@ include/glm/gtx/integer.hpp
include/glm/gtx/integer.inl
include/glm/gtx/intersect.hpp
include/glm/gtx/intersect.inl
+include/glm/gtx/io.hpp
+include/glm/gtx/io.inl
include/glm/gtx/log_base.hpp
include/glm/gtx/log_base.inl
include/glm/gtx/matrix_cross_product.hpp
@@ -173,8 +182,6 @@ include/glm/gtx/normalize_dot.hpp
include/glm/gtx/normalize_dot.inl
include/glm/gtx/number_precision.hpp
include/glm/gtx/number_precision.inl
-include/glm/gtx/ocl_type.hpp
-include/glm/gtx/ocl_type.inl
include/glm/gtx/optimum_pow.hpp
include/glm/gtx/optimum_pow.inl
include/glm/gtx/orthonormalize.hpp
@@ -191,10 +198,16 @@ include/glm/gtx/random.hpp
include/glm/gtx/raw_data.hpp
include/glm/gtx/raw_data.inl
include/glm/gtx/reciprocal.hpp
+include/glm/gtx/rotate_normalized_axis.hpp
+include/glm/gtx/rotate_normalized_axis.inl
include/glm/gtx/rotate_vector.hpp
include/glm/gtx/rotate_vector.inl
+include/glm/gtx/scalar_relational.hpp
+include/glm/gtx/scalar_relational.inl
include/glm/gtx/simd_mat4.hpp
include/glm/gtx/simd_mat4.inl
+include/glm/gtx/simd_quat.hpp
+include/glm/gtx/simd_quat.inl
include/glm/gtx/simd_vec4.hpp
include/glm/gtx/simd_vec4.inl
include/glm/gtx/spline.hpp
@@ -212,19 +225,32 @@ include/glm/gtx/unsigned_int.hpp
include/glm/gtx/unsigned_int.inl
include/glm/gtx/vec1.hpp
include/glm/gtx/vec1.inl
-include/glm/gtx/vector_access.hpp
-include/glm/gtx/vector_access.inl
include/glm/gtx/vector_angle.hpp
include/glm/gtx/vector_angle.inl
include/glm/gtx/vector_query.hpp
include/glm/gtx/vector_query.inl
-include/glm/gtx/verbose_operator.hpp
-include/glm/gtx/verbose_operator.inl
include/glm/gtx/wrap.hpp
include/glm/gtx/wrap.inl
+include/glm/integer.hpp
+include/glm/mat2x2.hpp
+include/glm/mat2x3.hpp
+include/glm/mat2x4.hpp
+include/glm/mat3x2.hpp
+include/glm/mat3x3.hpp
+include/glm/mat3x4.hpp
+include/glm/mat4x2.hpp
+include/glm/mat4x3.hpp
+include/glm/mat4x4.hpp
+include/glm/matrix.hpp
+include/glm/packing.hpp
+include/glm/trigonometric.hpp
+include/glm/vec2.hpp
+include/glm/vec3.hpp
+include/glm/vec4.hpp
+include/glm/vector_relational.hpp
include/glm/virtrev/xstream.hpp
@dirrm include/glm/virtrev
@dirrm include/glm/gtx
@dirrm include/glm/gtc
-@dirrm include/glm/core
+@dirrm include/glm/detail
@dirrm include/glm