aboutsummaryrefslogtreecommitdiff
path: root/math/glpk
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-07-29 17:31:43 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-07-29 17:31:43 +0000
commit156efdcc398bc12e28895ca7e504f49852fa2ee8 (patch)
treea8602320ccff5c5a15ab8b0ba2601c50731e02eb /math/glpk
parentb03cb9a35dc2496dfc544e3b76208ae4df347473 (diff)
downloadports-156efdcc398bc12e28895ca7e504f49852fa2ee8.tar.gz
ports-156efdcc398bc12e28895ca7e504f49852fa2ee8.zip
- Update to version 4.55 [1]
- Convert to USES=localbase - Move OPTIONS block to proper place, use helpers - Argument --disable-dl for MYSQL=off was dropped because it made configure script fail when IODBC=on PR: 203448 Submitted by: pfg [1]
Notes
Notes: svn path=/head/; revision=419263
Diffstat (limited to 'math/glpk')
-rw-r--r--math/glpk/Makefile55
-rw-r--r--math/glpk/distinfo4
-rw-r--r--math/glpk/pkg-plist3
3 files changed, 21 insertions, 41 deletions
diff --git a/math/glpk/Makefile b/math/glpk/Makefile
index 331a01871dbd..6750de7c5513 100644
--- a/math/glpk/Makefile
+++ b/math/glpk/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= glpk
-PORTVERSION= 4.52.1
-PORTREVISION= 3
+PORTVERSION= 4.55
CATEGORIES= math
MASTER_SITES= GNU
@@ -14,57 +13,39 @@ LICENSE= GPLv3
LIB_DEPENDS= libgmp.so:math/gmp
-OPTIONS_DEFINE= IODBC MYSQL DOCS
-IODBC_DESC= MathProg iodbc support
-MYSQL_DESC= MathProg mysql support
-
GNU_CONFIGURE= yes
-USES= gmake libtool
+USES= gmake libtool localbase
USE_LDCONFIG= yes
CFLAGS+= -trigraphs
-CPPFLAGS+= -D_LSEEK_DECLARED -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -D_LSEEK_DECLARED
CONFIGURE_ARGS+= --with-gmp
CONFLICTS= goblin-[0-9]*
-.include <bsd.port.options.mk>
+DOCS1= cnfsat.pdf glpk.pdf gmpl.pdf graphs.pdf miplib2.txt \
+ miplib3.txt netlib.txt
+DOCS2= dfeas.pdf gomory.pdf keller.pdf scaling.pdf
+PORTDOCS= ${DOCS1} ${DOCS2}
-.if ${PORT_OPTIONS:MIODBC} || ${PORT_OPTIONS:MMYSQL}
-CONFIGURE_ARGS+= --enable-dl=dlfcn
-.else
-CONFIGURE_ARGS+= --disable-dl
-.endif
+OPTIONS_DEFINE= IODBC MYSQL DOCS
-.if ${PORT_OPTIONS:MIODBC}
-CONFIGURE_ARGS+= --enable-odbc
-LIB_DEPENDS+= libiodbc.so:databases/libiodbc
-.else
-CONFIGURE_ARGS+= --disable-odbc
-.endif
+IODBC_DESC= MathProg iodbc support
+IODBC_CONFIGURE_ON= --enable-dl=dlfcn --enable-odbc
+IODBC_CONFIGURE_OFF= --disable-dl --disable-odbc
+IODBC_LIB_DEPENDS= libiodbc.so:databases/libiodbc
-.if ${PORT_OPTIONS:MMYSQL}
-CONFIGURE_ARGS+= --enable-mysql
-USE_MYSQL= yes
-.else
-CONFIGURE_ARGS+= --disable-mysql
-.endif
+MYSQL_DESC= MathProg mysql support
+MYSQL_CONFIGURE_ON= --enable-dl=dlfcn --enable-mysql
+MYSQL_CONFIGURE_OFF= --disable-mysql
+MYSQL_USES= mysql
post-patch:
@${REINPLACE_CMD} -e "s;\/usr\/include\/mysql;${LOCALBASE}\/include\/mysql;g" \
${WRKSRC}/configure
-DOCS1= cnfsat.pdf glpk.pdf glpk_faq.txt gmpl.pdf graphs.pdf miplib2.txt \
- miplib3.txt netlib.txt
-DOCS2= dfeas.pdf gomory.pdf keller.pdf scaling.pdf updating.pdf
-PORTDOCS= ${DOCS1} ${DOCS2}
-
-post-install:
- @${INSTALL_DATA} ${WRKSRC}/src/glplpx.h ${STAGEDIR}${PREFIX}/include
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @cd ${WRKSRC}/doc ; \
+ cd ${WRKSRC}/doc ; \
${INSTALL_DATA} ${DOCS1} ${DOCS2:S|^|notes/|} ${STAGEDIR}${DOCSDIR}
-.endif
check regression-test test: build
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} check)
diff --git a/math/glpk/distinfo b/math/glpk/distinfo
index 5f075791d43f..9ee26acc9d17 100644
--- a/math/glpk/distinfo
+++ b/math/glpk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (glpk-4.52.1.tar.gz) = 3231685b9ff92d30ccbb5c21ba7815b25ba59c7d1e5194e57a880dd1ebb3e95b
-SIZE (glpk-4.52.1.tar.gz) = 2812957
+SHA256 (glpk-4.55.tar.gz) = 37090d7f16796ec1034496e182a39d5cc8bb7c9fb5dc48a38b13d620bf2b1de7
+SIZE (glpk-4.55.tar.gz) = 3424345
diff --git a/math/glpk/pkg-plist b/math/glpk/pkg-plist
index 1811a893603c..95cfc8fcb874 100644
--- a/math/glpk/pkg-plist
+++ b/math/glpk/pkg-plist
@@ -1,7 +1,6 @@
bin/glpsol
include/glpk.h
-include/glplpx.h
lib/libglpk.a
lib/libglpk.so
lib/libglpk.so.36
-lib/libglpk.so.36.0.1
+lib/libglpk.so.36.1.2