aboutsummaryrefslogtreecommitdiff
path: root/math/gmp
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2013-12-14 04:47:22 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2013-12-14 04:47:22 +0000
commit55c37aca95bb370899b0e6a10fac1320be198a72 (patch)
treee10da4a1ced387af3221b2b0bf61293fae75f322 /math/gmp
parent0a4bc243ef4741e0e9b8246a9cf5d47586101f73 (diff)
downloadports-55c37aca95bb370899b0e6a10fac1320be198a72.tar.gz
ports-55c37aca95bb370899b0e6a10fac1320be198a72.zip
The MCPU_OPTS conditional block currently incorrectly sets ABI=64 for
all ARCH strings that in 64. GMP expects mode64, mode32 or 32 as valid values for the ABI option [1]. Using an invalid value causes the following build error on powerpc64: configure: error: ABI=64 is not among the following valid choices: mode64 mode32 32 This is the minimum change to set the correct "mode64" ABI value when ARCH is powerpc64, while also keeping all other semantics the same. A more complete refactor of this port is possible, but would need an exp-run to test for regressions. The change was tested on powerpc64 (thanks justin) and amd64 (for regression) While I'm here: - Remove indefinite article from COMMENT [1] https://gmplib.org/manual/Build-Options.html PR: ports/179127 Submitted by: jhibbits Reviewed by: jhibbits, ak Approved by: maintainer timeout (6 months)
Notes
Notes: svn path=/head/; revision=336420
Diffstat (limited to 'math/gmp')
-rw-r--r--math/gmp/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/math/gmp/Makefile b/math/gmp/Makefile
index 941feb922abf..5fc5f6190b4c 100644
--- a/math/gmp/Makefile
+++ b/math/gmp/Makefile
@@ -8,7 +8,7 @@ MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gmp
MAINTAINER= ale@FreeBSD.org
-COMMENT= A free library for arbitrary precision arithmetic
+COMMENT= Free library for arbitrary precision arithmetic
LICENSE= LGPL3
@@ -34,7 +34,11 @@ INFO= gmp
.if ! ${PORT_OPTIONS:MCPU_OPTS}
CONFIGURE_ARGS+=--build=${ARCH}-portbld-freebsd${OSREL}
.elif ${ARCH:S/64//} != ${ARCH}
+.if ${ARCH} == powerpc64
+CONFIGURE_ENV+= ABI="mode64"
+.else
CONFIGURE_ENV+= ABI="64"
+.endif
.else
CONFIGURE_ENV+= ABI="32"
.endif